Nethserver on Raspberry Pi

rpi
arm

(Mark Verlinde) #122

the mini how-to is based on the alpha-2 @dev-team has done a realy good job,
“new” interfaces are recognized now.

This looks like it’s close to a new module for nethserver(-arm) :slight_smile:

I’v been thinking about it, did not figure out a way to filter out the wireless interfaces other that the name starts with a “w”.


(Alessio Fattorini) split this topic #123

19 posts were split to a new topic: Build web filter modules for ARM


(Giacomo Sanchietti) #124

CentOS has just released the ARM64 build:

https://lists.centos.org/pipermail/centos-announce/2017-January/022193.html


(Alessio Fattorini) #125

@arm_team would you like to spend some time with that?


#126

yes, i’m following it but from what i know, actually only very nice and very expensive enterprise-class ARMv8 board are fully supported.
ordroid-c2 and pine64 are community supported at the moment, but i have only a rpi3 maybe it’s time tu buy an ordroid…

more info:
https://wiki.centos.org/SpecialInterestGroup/AltArch/AArch64

and for rpi3:
https://www.spinics.net/lists/centos-arm-devel/msg01961.html


#127

no upgrade path at the moment… while @mark_nl is busy, i’m testing ns7 final on rpi…

if someone what to help me, are really welcome :slight_smile:
is only a test, probably not so stable so, be careful

create the sd with centos 7-1611 as per wiki
http://wiki.nethserver.org/doku.php?id=ns_raspi2

then set your keyboard, ie:
localectl set-keymap de

and expand root partition:
/usr/local/bin/rootfs-expand

update:
yum clean all
yum update -y

install ns7
yum localinstall http://mirror.framassa.org/nethserver7-arm/nethserver-release-7arm.rpm
nethserver-install

please report back, and please have patience, i really am short on time :frowning:
tested only on rpi2 (i’ve left in the repo the aarch64 files but i didn’t have hardware to test)
tnx


Nethserver 7 on Pine64 (aarch64)
(Indra) #128

Yes this is just perfect, I’ll try it in the next few days on my RPi 3.
I tried OpenMediaVault with OwnCloud and a nextcloud ubuntu image from here but bot were lacking in speed an stability.
If this works well it could be the solution to my problem (many mobile users taking photos, needing backup)


(Alessio Fattorini) #129

Thanks man for your time, hope that someone else will help you @arm_team @Tom @EddieA @islipfd19


Build web filter modules for ARM
(Mark Edworthy) #130

I am also interested in using Nethserver with a Arm based SoC (a Banana / Lamobo BPi-R1) but do to other commitments, I am going have to put this project on the back burner for a while.


Build web filter modules for ARM
(JamesMillar) #131

Unfortunately I do not have any spare RPi’s available.


(Alessio Fattorini) #132

Sounds great let us know how your tests go


#133

new wiki page, for Nethserver 7 on Raspberry/Arm
please report back, tnx

http://wiki.nethserver.org/doku.php?id=ns7_rasp


(Indra) #134

Yes, great work, thanks. Came in handy today :slight_smile:
Did a reinstall from scratch on my RPi3, flashed the image and resized the partitions on the SD with computer and copied my tweaked board settings config.txt (and remove swap partition and fstab entry while I was at it).
Boot up on the RPi, login and update … failed to get some firmware packages (userland’s fault?). Manually downloaded and localinstall-ed affected packages and update went through.
Installed nextcloud and webserver from the servermanager. I’ll have to connect some disks and shares and remount them in proper places, but thats for my next adventure :innocent:
Also the dashboard patch is great


(Emiliano Vavassori) #135

Nice job, works quite well from what I’m seeing. This is going to be in a demo for some Electronic Fairs and other local events in which we will show RPis and other platforms (I have a Pine64 and also some Onion Omegas).

Unfortunately 1611 image for arm7l lacks firmware for the Broadcom Wireless interface (shame). I found someone that managed to find all the needed files and put together a script, so:

curl -sSL https://gist.githubusercontent.com/rhwood/9d4bd315bf6a183c057c156743646d48/raw/65e28a279d753b86e8e9e6ffaf4d8337eb16c3e3/rpi3-wireless-drivers.sh | bash

So this has to be done before the mini-wireless howto put up from @mark_nl and my additional information on auto-starting wpa_supplicant. Run the script, reboot, then go on with the mini-howto. Add my commands, then enjoy your wireless interface going up on boot :wink:


Build web filter modules for ARM
(Denis Robel) #136

Hallo,

today I checked my raspi 3’s ram in Nethserver Dashboard:

there are only 924 MB of Ram shown. How can I assign more RAM of the 2GB for system under Nethserver?

[EDIT]
Okay I was a little bit confused, the RPI3 has only 1 GB of RAM. I confused the technical spec’s of RPI with my Jolla C …
[/EDIT]

Then I have the problem that the RAM will be full after 2 days and the pi hangs.

Has somebody else this problem too?

How can I solve that problem? By increasing the swap only or are there other possibilities?

with warm regards from Leipzig

Denis


Build web filter modules for ARM
(Alessio Fattorini) #137

@arm_team @syntaxerrormmm @indra @medworthy could you help Denis? I would appreciate it


(Denis Robel) #138

Hallo,

I wrote a script for crontab to clear the memory cache:

!/bin/bash sync; sysctl vm.drop_caches=1

I run this script every 5 minutes and until now it seems to fix the problem. The raspi does not swaping so often anymore.


(Emiliano Vavassori) #139

I didn’t leave it up for so long, so I cannot say it is behaving the same.
I can see is that after 2 hours up the RAM is nearly filled (924 MB used, 11 free); it can be OK (unused RAM is wasted money), unless it really hangs.

Last week it was up and running for about 6-7 hours with no issues.

I will let you know; during the weekend it is going to be up for a lot more hours.


(Mark Edworthy) #140

My understanding of the RPI3 is that it contains 1GB of RAM and that the memory can not be upgraded / added to (ref: https://www.raspberrypi.org/forums/viewtopic.php?f=45&t=114326 )

After analysing the partitions that CentOS creates during the installation process / writing the image to a SD card, I noticed that the CentOS image creates a swap partition that is only 512M in size.

I am now wondering if, increasing the size of the swap partition (using either SUSE Yast partitioning tools, Gparted or some other partition tool that supports both Linux based file system formats and that can resize these partitions) to 2.5 GB (ie. increasing the swap partition to be no larger then 1.5 times the size of the actual physical RAM) and then increasing the ‘swappiness’ be changing vm.swappiness variable within /etc/sysctl.conf could resolve the memory limitations of the RPI3.

Obviously, using the above method would slow down read/write access to the RAM (as the RPI3 is now using a SD medium to act as virtual memory, which is slower then actual physical RAM), but theoretically, this should give the RPI3 an increase the RAM of up to an extra 2.5GB (resulting in 3.5GB of accessible RAM).


(Mark Edworthy) #141

On a side note, does anybody know if there is a ARM branch of CentOS’s EPEL repository (as far as I can deduce, EPEL is only available for x86 / x86-64 architectures)?