Nethserver on Raspberry Pi

rpi
arm

(Marc) #142

Quote from the Centos Wiki:

there is no official EPEL repository for armfhp. But because lot of users were asking for this, we decided to use the centos armhfp builders to (re)build Source packages from EPEL 7 (and try to track those automatically) when they’re idle. Please note that it’s just an automatic rebuild without any QA/test, and also resulting pkgs aren’t signed either.


#143

yes @dnutan is right
you can find the epel repo here (not so-official not fully tested):
https://armv7.dev.centos.org/repodir/epel-pass-1/

at the moment only the epel packages we need are in our ns7arm repo, instead of using directly the repo. This is how @mark_nl setup the repo and i have maintained this config. This give us a better control of what we have in repo (and for me to better understand what we really use/need). If you find some useful package let me know and i will add to the ns7arm repo

the situation is quite different for aarch64 where it seems to be an official repo:
https://dl.fedoraproject.org/pub/epel/7/aarch64/

same tructure also for ns7arm on aarch64, please remember that while i’ve left in the repo the aarch64 files, probably thy aren’t updated as for armhfp.
sorry, i didn’t have hardware to test aarch64, i will order something compatible this week so i can test it


#144

i’ve my rpi3 working for weeks, but not heavily stressed, only simple bridged AP. Which service/module do you have installed? only wifi and proxy?


(Denis Robel) #145

I think the webfilter is responsible for that behavior .
But the pi is running now. During the meantime there is a new release of ufdbguard available. It is working well on my pi. Maybe I can tune the webfilter config a little bit I’ll try it in the next days


(Mark Edworthy) #146

I was just browsing the Armbian web site ( www.armbian.com ) and stumbled upon ClearFog Pro SoC board and thought that this would make an interesting development board to use Nethserver with.


#147

pushed some nethserver packages updates… let me know if there are any problems
tnx


(Denis Robel) #148

Hallo,

I increased the swap to 1.5Gb an now the pi is running since a week without freezing.

[edit]
okay there was an other reason for randomly freezing: my power supply was to small for the pi and I did not figured it out :flushed: - shame on me


(Denis Robel) #149

Hallo,

today I installed fail2ban to my kidsrouter.
It was necessary because I had 2 much brute force attacks in the logs…

I took the src rpm from Stephane de Labrusse’s repo and the src rpms of fail2ban from epel. I recompiled them and it’s working like a charm.
Many thanks to Stefano for the excellent plugin!!!

with warm regards Denis


(Alessio Fattorini) #150

Steph will be definitely happy to hear that
Where is the rpm? It would be great to add it to the PI spin :slight_smile: @arm_team


#151

great! but I have to apologize. I had already ported but I forgot to write it down :frowning:
I also tested locally nethserver-dokuwiki and nethserver-ddclient but I didn’t copy them in nethserver-testing on repo.
As soon as i can i’ll do it and write it here and on the wiki.
if i remember well i had some major problem with nethserver-transmission but i do not remember why …

ah, and i had added nethserver-diagtools in updates
but i still need to rebuild latest version of ufdbguard…
if/when you build new packages let me know so i can add them to repo…
tnx!


(Alessio Fattorini) #152

:heart_eyes: :heart_eyes:

Next step asterisk :slight_smile: @Stll0 @jobezic


(Denis Robel) #153

Hallo,

today I tried

yum install nethserver-mail-server-1.10.9

and I received an error:

[CODE]
Transaction check error:
file /etc/e-smith/db/configuration/defaults/postfix/access conflicts between attempted installs of nethserver-mail-server-1.10.9-1.ns7.noarch and nethserver-mail-common-1.6.3-1.ns7.noarch

Error Summary
[/CODE]

what is going wrong with the dependencies? My goal is to run Nextcloud with mail server on the raspi…


#154

sorry, i miss to sync the latest nethserver-mail-server package (1.10.11-1.ns7)
can you retry with
yum install @nethserver-mail
or from software center?
tnx


(Denis Robel) #155

Hallo,

I tried it yesterday from software-center and from console login with the same error.

Today all installed fine from software center. I cleaned the yum cache manually before.

Now I’m not able to login to nextcloud but I’m not able to figure out why. The logfile from httpd says nothing. I’m on the same point as 2 month ago.
Is there somebody who is running nextcloud on the raspi?


(Alessio Fattorini) #156

Yeah, maybe some guys could help you here
@ibico @Tom @Mark @rasi @jackyes


(Denis Robel) #157

I solved the problem by recompiling the last src rpm from nethserver repo…

The next problem was that the ldap backend was not enabled by default. I had to do that manually …

But now nextcloud is running well


(Himuura) #158

netherserver-colelctd is not creating a rrd folder in /var/lib/collectd/. This is what im having: Error: No Collectd hosts found in /var/lib/collectd/rrd. Besides, it’s a piece of work to install the Statistics plugin, lots of unmet dependencies (libpango libcairo and so on). Got it to install though, any idea why i’m not getting the graphics?


(Denis Robel) #159

Hallo,

last weeks I installed prosody (xmpp server) on Nethserver for testing with an domain from nsupdate.info for testing.

At first without ldap integration…

It’s working well for my phones with omemo encryption, group chat and omemo encrypted http_upload :slight_smile:

Now I have a little problem:

I want to create a redirect rule from my raspi to the web frontend of my mythtvserver .

Sitiuation is:

I-net —>router—>portforwarding 80,443 to nethserver —> https mod_rewrite rule —> https://192.168.1.4/mythweb (green lan of nethserver)

How can I create a rewrite rule for httpd which is rewrite the ^/mythweb to https://192.168.1.4/mythweb ?

The goal is to access the mythtv webfrontend via:

https://server.nsupdate.info/mythweb

for http://server.nsupdate.info/mythweb I have a working rule with reverse proxy.

But for creating the same rules for https I don’t have a plan yet. Any help would be appreciated.

With warm regards from Leipzig

Denis


(Markus Neuberger) #160

Hallo @denis.robel,

Did you see this?

http://docs.nethserver.org/en/v7/proxy_pass.html#manual-configuration

For me this rule works:


(Denis Robel) #161

Hallo,

okay it woks. I had a knode in my brain… I tested it from a wrong W-Lan subnet.

Oh man :slight_smile:

But many thanks for replay