Nethserver on Raspberry Pi

rpi
arm

#1

Hi,
Has anyone succeeded in installing NethServer on a Pi. Is it possible?
Tom


Nethserver for ARM/PI devel questions
Building the Arm Team
Building Arm Team
#2

Hi,

It’s not possible… Nethserver is x86_64 only.


(Giacomo Sanchietti) #3

Since the Raspberry 3 is out, we have some changes.
The new Raspberry is 64 bit, and CentOS has an alpha built for ARM64: http://mirror.centos.org/altarch/7.2.1511/os/aarch64/.

Still, no one has tried yet.

Edit: CentOS 7 image for ARM64: https://t.co/qiDlSZAOA3 (source https://twitter.com/Arrfab/status/704666761212338178)


#4

Before de Raspi 3, the maintream CentOS was on Raspi 2

Can we imagine a future Nethserver ARM compliant?
( at leat to put in the Nethmonitor ) :smiling_imp:


#5

Are there parts of nethserver that would need to be compiled for Arm?
Tom


(Eddie Atherton) #6

Or wait for the 64-bit version of this.

Cheers.


(jack) #7

http://mirror.centos.org/altarch/7/isos/armhfp/

There is a raspberry 3 image but 32bit only for now…64 bit cooming soon…

https://wiki.centos.org/SpecialInterestGroup/AltArch/Arm32/RaspberryPi3

Epel 7 repo from redsleeve:
http://ftp.redsleeve.org/pub/el7-devel/el7/EPEL-full/mirrors

i’m tryng this… the pi with little overclock @ 1.3ghz with samba, transmission, fail2ban and owncloud 9 works very well :smiley:


(Mark Verlinde) #8

It does run on a rpi 2, athough it’s just a prove of concept.

It’s a band-aided setup running on redsleeve;
an rhel 7.1 arm derivative unfortunately compiled for armv5tel
@jackyes network configuration is working very quirky me, Nic’s have to brought up manually, how did you solve this?


(jack) #9

i’m not trying nethserver…i configure that package by hand…mmm

try to use This CentOS 7.2 image for raspberry Pi 2
To install nethserver you have run the normal procedure? tomorrow i will try on Rpi3 :sunglasses:


(Mark Verlinde) #10

CentOS is missing a lot of packages,
next try would be fedora…

No not normal procedure, as said i’ts just a prove of concept


(jack) #11

No problem with network configuration on Centos 7.2 on my Rpi3…


(Giacomo Sanchietti) #12

Guys you’re amazing! :smiley:


#13

You are recompiling every package for the Arm architectur ?


(Alessio Fattorini) #14

Wow! You’re making @nrauso so happy! :heart_eyes_cat:


(Mark Verlinde) #15

Mabey i’m missing some eth-tools -utils to get the by NS used ifup ifdown working;
Or just wait, IMO IFup IF down does not suite a modern distro (to put it polite).

Oh No
Nethserver packages are arch independent (noarch) containing basically 2/3 sections:

  • web-ui snippets (html, ccs, php, … and ohter web-stuf)
  • e-smit configuration layer: templates and scripts for configuration
    and creation/population the configuration databases (perl, bash, …)
  • dependencies: actual packages used (ie samba or dovecot) and some
    extra tools/libraries.

I was just curious if the e-smit configuration layer would work without huge adoptions. And it does :grinning: !
On redsleeve i had to gather/(re)build just a few packages and do some dirty :pensive: yum-repo configuration.
[root@nethpi ~]# ls /home/repo/7/local/arm/Packages/
lsm-0.195-1.el7.armv5tel.rpm
perl-Authen-PAM-0.16-21.el7.armv5tel.rpm
perl-Crypt-Cracklib-1.7-5.fc18.armv5tel.rpm
perl-Mail-RFC822-Address-0.3-1.el7.noarch.rpm
perl-Net-IPv4Addr-0.10-19.el7.noarch.rpm
perl-Text-Template-1.45-12.el7.noarch.rpm
python-simplejson-3.5.3-2.el7.armv5tel.rpm
shorewall-4.6.5.3-1.el7.noarch.rpm
shorewall-core-4.6.5.3-1.el7.noarch.rpm

the noarch and lsm (source files) come from NS repo’s,
python-simplejson, perl-Authen-PAM are built from fedora 22 source files
http://fr2.rpmfind.net/linux/fedora/linux/releases/22/Everything/source/SRPMS/

perl-Crypt-Cracklib is a hard nut to crack, and did not succeed (re)buidling… :rage:
found an arch- and perl-version compatible one in a obscure place on the internet:
http://armpkgs.fedoraproject.org/packages/perl-Crypt-Cracklib/1.7/5.fc18/armv5tel/

Duc does not (out of the box) compile for arm
CentOS is missing mdadm no problem compiling that, it dependency libreport is another story… :cry:
(although you could argue if softraid is really needed on a pi…)

Mabey some on more knowledgeable does succeed :grinning: , i’m fairly new to the rhel family and don’t know how to set up a toolchain/crosscompiler for userspace packages.


#16

It’s really intersting,
It would be fantastic if you write a documentation on your experimentations :smile:


(Mark Verlinde) #17

It’s way too early for documenting this proof of concept, everything to reproduce is up there.
I admit, on point’s attentional vague: it does not lead to a proper installation.
(The notes are quite chaotic too Started organized going through :confounded: :angry: :rage: :sweat: :grinning: :grin: :laughing: just rattled on keyboard and forgot to take notes… )

Nevertheless it shows it is worth putting effort/time in this ! :sweat_smile:

IMO we should try to resolve the basic (see list above) dependencies on CentOS 7.2 and go from there.

first severe hurdles:

  • perl-Crypt-Cracklib
  • mdadm & libreport

(Filippo Carletti) #18

We could try to avoid using perl-Crypt-Cracklib even on x86_64.
Software RAID is probably not useful on RPi.
I’ll try to work on duc in the coming days.


(Davide Principi) #19

We can ignore it, it is not used anymore! We can remove that dependency on the next ns7 release


Nethserver for ARM/PI devel questions
(Mark Verlinde) #21

Apologies for hacking your post, got too exited it could work.
yes we tried!