Nethserver on Raspberry Pi

rpi
arm

#102

i’ve tested with my contrib nethserver-arpwatch and nethserver-openvpn and it builded correctly on ns7-arm (while both packages are noarch)

can i use your fork of nethserve-release on github to reproduce your problem or it’s outdated?


(Mark Verlinde) #103

nethserver-release on the git hub is in sync with the the repo;
you could correct two typo’s: in /root/sbin/netserver-install:

line 64 /var**/**log/…journalctl …
line 112 “this can take over 5 minutes”


(Mark Verlinde) #104

l see the fault in the package,

Is done old style… on the rp3 (build om x86 is good, what am I doing wrong?)


(Giacomo Sanchietti) #105

Just released the new nethserver-base package without mdadm dependency
See: https://github.com/NethServer/dev/issues/5031

/cc @mark_nl


(Mark Verlinde) #106

@dz00te any success?

I made a chroot with mock --init, mounted proc, sysfs after installing yum in to it installed nethserver-devtools in the chroot.

Everything seems to be oke, ie all files are on the right place
the only thing i can think of is it can’t find build macro’s and/or genfilelist script. In the chroot the script is in the the right place (/bin), can there be something wrong with “{_exec_prefix}”?


#107

yesterday i’ve tried to build on arm… build ok install conflict
I no longer have the rpi2… waiting for rpi3 but
i’ve tested with rpmrebuild the package builded on x86_64 vs arm

x86_64:

%attr(0644, root, root) “/etc/yum/vars/distroversion”
%attr(0755, root, root) “/usr/sbin/nethserver-arm-preconf”
%attr(0755, root, root) “/usr/sbin/nethserver-install”
%dir %attr(0755, root, root) “/usr/share/doc/nethserver-release-7arm”
%doc %attr(0644, root, root) “/usr/share/doc/nethserver-release-7arm/COPYING”
%changelog

arm:

%attr(0644, root, root) “/etc/yum/vars/distroversion”
%dir %attr(0755, root, root) “/usr”
%dir %attr(0755, root, root) “/usr/sbin”
%attr(0755, root, root) “/usr/sbin/nethserver-arm-preconf”
%attr(0755, root, root) “/usr/sbin/nethserver-install”
%dir %attr(0755, root, root) “/usr/share/doc/nethserver-release-7arm”
%doc %attr(0644, root, root) “/usr/share/doc/nethserver-release-7arm/COPYING”
%changelog

i’m quite sure that if you comment the line:
%dir %attr(0755, root, root) “/usr/sbin”

…the rebuild should give an installable package… :pray:
ofcourse i don’t know why there are those (and other) differences :persevere:

if you want to try rpmrebuild on rpi2 i’ve added it t our epel-repo so
yum install rpmrebuild should work, then
rpmrebuild -pe nethserver-release-??.rpm


(Mark Verlinde) #108

Throw the towel for mock, to unfamiliar with it…

if perl-Krb5.spec is build using mock, rpm -i --test says it for a different architecture. Same spec using rpmbuild come out fine…?? :astonished:


(Filippo Carletti) #109

I’m not familiar with mock, too, but I used nethserver-mock which hides mock behind the command make-rpms.
I followed the instructions here:
http://wiki.nethserver.org/doku.php?id=developer:nethserver_7_kickstart
It’s been a straightforward and simple process.


(Mark Verlinde) #110

To be frank, the only thing i like about mock is mock --init…

But i’v got it! :sweat_smile: it’s the mishmash of armv7l - armv7hl - armhpf;
in the mock cfg:

config_opts['target_arch'] = 'armv7hl'
config_opts['legal_host_arches'] = ('armv7l')
....
....
""").substitute(distroversion=distroversion, basearch='armhfp', releasever=releasever, infra='stock')

with this successfully built netserver-release-arm7 and perl-Krb5

Edit:
@dz00te Pushed it to github, the nethserver-mock package can be build using initial mock cfg (thx @filippo_carletti) ; if is its oke mock package in repo could be updated.


(Mark Verlinde) #111

Testing nethserver-base-2.10.1-1.80.gf831fcb.ns7.noarch.rpm and (as expected) installs without mdadm, thx!

Like the initial DHCP support, don’t have to use the current workaround removing NetworkworkManager before system-init. Nice :slight_smile:
Although having some troubles with it, the pi is connected to a test lan “behind” two internal routers. After system-init resolf.conf contains only 2 internal dns servers, it cant resolve external domains. This go’s on list of my personal quick’s need to be fixed :flushed:


(Mark Verlinde) #112

Hi all, we’dd just updated the nethserver-arm repo’s (see Nethserver for ARM/PI devel questions)

We added some extra packages

  • Statistics (nethserver-collectd)
  • Mail Server
  • Openvpn
  • Build system (nethserver-mock)

The mail server pushes a PI to it’s hardware limitations. :anguished: Especially the memory usage of ClamAV is worrying. If someone knows ways to push resource usage of ClamAV down please let us know!

To try it out follow the wiki, and keep us posted of your test results.

Keep in mind it’s is still alpha (of an alpha) :slight_smile:
BTW it run’s fine on a rpi3, just use the right centos-userland.

EDIT : OOPS discovert a fault in /etc/mock/nethserver-7-armhfp.cfg
(https://github.com/markVnl/nethserver-mock/commit/3d74566c7b518d4aa5204aace86ffe19a78a874d)
Will be oke with next update. (DONE)


(Filippo Carletti) #113

You need to remove rules (main and daily c*d files).
And disable freshclam.


(Mark Verlinde) #114

Cant find freshclam, is this the freshclam-sleep cron ??

This frees up about 250MB of memory;
What are the consequences of this and the above?


(Filippo Carletti) #115

Set FRESHCLAM_DELAY=disabled in /etc/sysconfig/freshclam.
Removing main.c*d, some old virii will not be detected.


#116

I have just started testing Nethserver on my RasPi 3. I followed the Wiki and the install has gone perfectly. I can ssh to the server and the Web interface is working. :smiley:
I have one network card and I am on my own internal lan. Can I set static IP from the Web interface, (not obvious how to do so, as the edit option on the Network configuration screen don’t seem to have an option to set ip), or do I do it from the command line?
Tom


(Alessio Fattorini) #117

@mark_nl or @jackyes will be happy to help, definitely


(Mark Verlinde) #118

Yes, it’s not quite clear how to do this (go to):
Network > Edit (interface) > choose “Internet (red)” from the pull-down menu and (without saving anything) “LAN (green)” again. (@giacomo …)

You be able to set a fixed IP, its not possible to set it back to “DHCP” once a fixed IP is set.

Tnx for testing!


(Mark Verlinde) #119

mini howto wireless network

(on a rpi3: install firmware as described in README in root directory)

show all network interfaces
ip a

Look for your wireless interface (probably wlan0).
This mini-howto assumes wlan0 is the interface to be configured.

Systemd unit wpa_supplicant loads configuration from /etc/sysconfig/wpa_supplicant --and–
/etc/wpa_supplicant/wpa_supplicant.conf

edit /etc/sysconfig/wpa_supplicant

# Use the flag "-i" before each of your interfaces, like so:
#  INTERFACES="-ieth1 -iwlan0"
INTERFACES="-iwlan0"

setup your network credentials:
edit /etc/wpa_supplicant/wpa_supplicant.conf ; and add

network={
   ssid="YOUR_NETWORK_NAME"
   psk="YOUR_NETWORK_PASSWORD"
}

start and enable wpa_supplicant.service:

systemctl start wpa_supplicant
systemctl enable wpa_supplicant

check the results: (wpa_state=COMPLETED if authentication to wifi network succeeded)
wpa_cli status

run the config-network script. (this is quite a blunt tool, i don’t know a better one :hushed:)
nethserver-config-network

wlan0 can be configured in the web-gui.:slight_smile:


Testers needed nethserver-arm img
Wifi card as RED network interface
#120

Thanks Mark. Worked perfectly.
Also the response of the web interface is good and very usable.

Tom


(Emiliano Vavassori) #121

Don’t know where to post this, so I probably take the more generic post of all.

I followed instructions on wiki and the mini-howto fom @mark_nl some post before and all worked perfectly.

The only thing that didn’t work out of the box was the wireless interface. Plus, once manually configured (following wifi mini-howto) and assigned a role within the NethGUI, on restart the interface wouldn’t automatically go in up state.

You may fix it (and onboot behavior of the wlan0 interface) with the following commands:

db configuration set wpa_supplicant service status enabled mkdir /etc/e-smith/db/configuration/defaults/wpa_supplicant echo "service" > /etc/e-smith/db/configuration/defaults/wpa_supplicant/type echo "enabled" > /etc/e-smith/db/configuration/defaults/wpa_supplicant/status signal-event runlevel-adjust