Full DNS software, even via docker

Has anyone managed to deploy a full DNS software on nethserver.

One that can enable the creation of A, AAA,MX,TXT and other DNS records?

Is this something that we could or can see in Nethserver builtin in future?

Something like BIND (or PoweDNS, TechnitumDNS…)?

There were similar requests:

And an old howto (bind9+facileManager webui), but unsure how many people use it within NethServer.

1 Like

Ill try this.

This is what i was talking about. ill check it out, see if it works etc.

1 Like

please let us know (I don’t get why this doesn’t happen officially or at least as a “app” package)

hello, I installed the Bind DNS server, using the instructions provided on the link, but modified the file to the latest version of Facilemanager.

yum install bind bind-utils php-mysql wget vim php-posix

wget http://www.facilemanager.com/download/facilemanager-complete-4.0.3.tar.gz
tar zxvf facilemanager-complete-4.0.3.tar.gz
cd facileManager

mv server/ /var/www/html/facileManager
chmod -R 750 /var/www/html/facileManager/

nano /etc/httpd/conf.d/facilemanager.conf

Alias /facileManager /var/www/html/facileManager
<Directory “/var/www/html/facileManager”>
AllowOverride All

mysql -e "create database facileManager;" 
mysql -e "grant all on facileManager.* to admin identified by 'pwd';"

 service httpd restart

http://ip/facileManager

After running the ip address, i am getting error 403,
what could be the problem?

Httpd log error or access could explain better

i see this as being related

Logs

Search

[Mon Sep 13 21:44:42.067243 2021] [core:crit] [pid 14278] (13)Permission denied: [client 154.159.252.236:31447] AH00529: /var/www/html/facileManager/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/var/www/html/facileManager/’ is executable

i was able to edit using sudo chmod -R 755 /var/www/html/facileManager/

am now getting requirement error on the system it requires
PHP >= 5.5.0

how can i enable it to use a specific php version

edit: i was able to solve it by specifying <FilesMatch .php$>
SetHandler “proxy:unix:/var/run/rh-php73-php-fpm/nethserver-glpi-php73.sock|fcgi://localhost”

which i copied from glpi settings

not sure what i should have defined that specifc to this case, maybe you cn help me change

This is what i have:

if i am to enable ssl, which path should be chosen?