Collabora uses rh-php71 without requiring it

Hello, I’m trying to give a test with collabora. It didn’t work for the moment because “loolwsd” is searching for php71 but 72 is only installed.
Saving configuration to : /etc/loolwsd/loolwsd.xml ...
Saved
Unable to open /etc/scl/conf/rh-php71!

[root@srviia01 ~]# ls /etc/scl/conf/
rh-php72

Then, should I install rh-php71 or searching to edit loolwsd.xml ?

EDIT : on a clean-fresh server install :wink:

To use a non standard version of php you will need php-scl module

Then you can choose for each VHost a different version of php.

Hi Christophe,

welcome to Nethserver Community.

Great, you found a bug - I changed the category and moved the posts to a new thread.

nethserver-collabora uses rh-php71 without requiring it. This was no problem because Nextcloud required rh-php71. Now Nextcloud uses rh-php72 so on newer systems nethserver-collabora doesn’t work anymore.

As a workaround please install rh-php71 and do a

signal-event nethserver-collabora-update

on command line.

I am going to open a bug/PR the next days…

Thank you for reporting, but I’m pretty sure that collabora doesn’t use PHP at all.

Where do you see the error?

Rh-php71 is used to configure Nextcloud:

Good catch, but it’s nethserver-collabora which uses PHP to collabora itself.

The fix should just change php71 to php72 in that script, since if nextcloud is installed all PHP stack is installed too. IIRC nextcloud has been switched to PHP72 a couple of releases ago.

Also collabora has been updated. Of course the package needs a little bit of love :smiley:

1 Like

Hello, in /var/log/messages

1 Like

It can be (nethserver-)nextcloud switched to PHP72, this does not mean nethserver-rh-php71-php-fpm is removed. Saw this after updating an old test-vm: the rh-php71-php-fpm service kept on running while nothing needed/used it.

I think that’s why this “bug” was unnoticed for so long.
I bet there are quite some systems out-there running php71 without any reason.:hushed:

We all know that rpm does an unsatisfactory job in removing unneeded requirements - to put it mildly - however this old test-vm miraculously survived yum autoremove ; which caught php71 too.

2 Likes

Fully agree.

1 Like

sorry @krisden for hijacking this post, although it is not completely off topic.

With arm we have a similar issue which keeps (nethserver-)nextcould unsupported. On arm we do not have rh-php7x instead we use an rebuild of remi-safe. (attempts to rebuild rh-php7x died in the dependency labyrinth).
where i’m thinking about is some kind of property which defines the “nextcloud terminal command” (ie scl enable appropriate-php7x "/usr/share/nextcloud/occ) which can be used by other modules such as nethserver-collabora but also be set for different archs / setups…

1 Like

What about getting the nextcloud php requirement with yum and use it in collabora conf script? Or get most actual installed rh-phpXX?
That way no prop is needed.

1 Like

seems better to use yum / rpm “requires” with a smart grep/sed…

the only thing we need is the name of the required php software collection … rh-php71, rh_php72 or php72
(for reference an old commit to test nextcloud support on arm)

but is does not solve the arm issue :sob:

1 Like

Hello all :wave:
What I do yesterday : install rh-php71 as describe in stephdl wiki, php error disapear but now nethserver-nextcloud-update failed ( it doesn’t achieve the process but nextcloud is accessible via Firefox) ; no time today to search why, maybe tomorrow I give a try.

Forgot to mention : certs are self-signed but edited to be compliant, collabora run in the same server on a dedicated virtual-host then I doesn’t set the “AllowWopiHost”
Acces to /loleaflet/dist/admin/admin.html return the classical error

Sorry for the late reply,

Any updates on this?

Yes there is an issue with self-signed certificates…


Forgot how to solved it…
IIRC I had to copy the CA of self-signed certificate - ?? somewhere ??- in the nextcloud configuration directory’s.