How to install Collabora Online Development Edition (CODE)

You have to run httpd -S after the configuration steps to see the vhost.

You only need the domain without servername:

config setprop loolwsd VirtualHost
signal-event nethserver-collabora-update

I don’t know if it’s the case but you can’t use the same domain as the Nethserver server domain that you set via “Server name” in the web UI. You need a different domain or a subdomain.

If the servername is you need a another domain like or a subdomain like

I ran httpd -S after the configuration steps. I have the same result this morning.

Also I tried to configure loolwsd just with the domain without the servername with the same result.

You said I can´t use the same domain I set with the web UI. As you said I do not have to create another virtual host as this is done by

yum install nethserver-collabora

So do you think I should create a seperate virtual host like ? Will the installscript use this created virtual host?

No, you don’t need to create a virtualhost in Nethserver for collabora.

You just need to get another domain (like from your (ddns) provider and configure it in Nethserver:

config setprop loolwsd VirtualHost
signal-event nethserver-collabora-update

After these steps httpd -S should show the domain.

I set up a spearate VM for testing and registered a seperate domain from


yum install nethserver-collabora


config setprop loolwsd VirtualHost
signal-event nethserver-collabora-update
loolconfig set-admin-password

I have the same situation. I cannot access the admin dashboard.

Thank you @mrmarkuz for your assistance. Now I´ll try onlyoffice and hope I´ll have more success with it.

Best regards,

If you use a VM, did you port forward the https port to the VM?

You have to use the collabora domain to get to the admin interface.

Please check /var/log/messages for errors.

3 posts were split to a new topic: Nethserver-collabora uses rh-php71 without requiring it

A post was split to a new topic: Portforwarding config collabora

Old news but related to the topic. There’s a built-in collabora CODE nextcloud app, but I guess the package from Markus shall perform at least the same or a bit better (unaware of the internal differences on the built-in app).

provides a built-in server with all of the document editing features of Collabora Online. Easy to install, for personal use or for small teams. It is a bit slower than a standalone server and without the advanced scalability features.

the built-in CODE server has some limitations in terms of performance


So, which version is better to be used?
NethServer integration or Nextcloud integration?


Hi @mrmarkuz ,

Please help with this issue:
I have installed nethserver-collabora package following your steps and of course, the documentation.
I can access the Admin console at
If I check in browser I get (please see photo 1).
In Nextcloud: “Could not establish connection to the Collabora Online server.” (please see photo 2).
What did I do wrong?
From where I must start to check?


Please post your config:

config show loolwsd

Thank you for answer!

[root@mail ~]# config show loolwsd
[root@mail ~]# 

Sorry for late answer, I wasn’t in front of a PC to check my settings…
If your Neth hostname is not the same as your public domain name, you need to set AllowWopiHost to the domain name you use in your browser to connect to Nextcloud.

config setprop loolwsd AllowWopiHost
signal-event nethserver-collabora-update

If you use port forwarding to your Nextcloud instance, it may help to enable hairpin nat in the firewall settings if you’re testing from internal LAN:


You may check /var/log/messages or /var/lib/nethserver/nextcloud/nextcloud.log for more detailed error messages.

Even after I made the settings for WopiHost, it didn’t work.
Following your hint about the host name and the public domain name, I realized that I did not set an alias for
After I seted this alias, it’s working!

Thank you for your help!
Kind regards,

1 Like


I know why I forgot the alias!
The virtual host was created automatically by the nethserver-collaborate package during installation, but not the alias.
When you create a virtual host from GUI, the process create also the alias.


The Collabora integrated server is definitely easier to install and maintain (it is a web application self-contained inside NC) but lacks a lot of features (the most important one being sandboxing each open document).

I will say for “personal” use the NC/Collabora integrated one is sufficient. If you are part of a team using Collabora/LibreOffice Online for production and/or collaboration, I would continue recommending the great job of Markus :slight_smile:


Thank you for the explanation of the differences between the two versions.
As you can see, I already use Markus’s version, NS integration and Markus already helped me.
Indeed, great job of @mrmarkuz !

1 Like

Nethserver: 7.8.
Modules: Webserver, Mail, NextCloud, Webtop5, Firewall, IPS, Thread Shield

I installed Collabora from Software center and get errors.

Current State:

  1. Installation Nexcloud, Webtop5 --> working well integrated

  2. providing vhost with LE- certificate:

  3. alias exists

  4. Configuration.

    config show loolwsd

    ~]# netstat -tlpnu | grep loolwsd
    tcp 0 0* LISTEN 15578/loolwsd
    tcp 0 0* LISTEN 15578/loolwsd

    ~]# systemctl status loolwsd
    ● loolwsd.service - LibreOffice Online WebSocket Daemon
    Loaded: loaded (/usr/lib/systemd/system/loolwsd.service; enabled; vendor preset: disabled)
    Active: active (running) since Sun 2020-11-15 17:51:45 CET; 11min ago
    Main PID: 15578 (loolwsd)
    CGroup: /system.slice/loolwsd.service
    ├─15578 /usr/bin/loolwsd --version --o:sys_template_path=/opt/lool/systemplate --o:child_root_path=/opt/lool/child-roots --o:file_server_root_path=/usr/share/loolwsd
    ├─15749 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/systemplate --lotemplate=/opt/collaboraoffice6.0 --childroot=/opt/lool/child-roots/ --clientport=9980 --masterport=9981…
    └─16146 /usr/bin/loolforkit --losubpath=lo --systemplate=/opt/lool/systemplate --lotemplate=/opt/collaboraoffice6.0 --childroot=/opt/lool/child-roots/ --clientport=9980 --masterport=9981…

    ~]# httpd -S
    port 80 namevhost (/etc/httpd/conf.d/virtualhosts.conf:273)
    port 443 namevhost (/etc/httpd/conf.d/virtualhosts.conf:218)
    port 443 namevhost (/etc/httpd/conf.d/zz_collabora.conf:9)

    ~]# config show nextcloud

  5. result:
    The requested URL /loleaflet/dist/admin/admin.html was not found on this server.

/var/log/httpd/ssl_access_log: - - [15/Nov/2020:18:32:49 +0100] "-" 408 -

where is the stumbling stone?

Best regards, Marko

no idea anybody? @mrmarkuz?

what i also cannot explain is the lonal name resolution.
dig 0 IN A

dig 0 IN A

dig 86400 IN A

the subdomains are differently bound to green and red IP-Address.

It seems you defined in the virtualhosts and in the loolwsd entry in config db. It’s only needed in the loolwsd entry in the config db so please delete the vhost.