Asterisk 13 and FreePBX 14 on NethServer 7

Just browse: https://your_server/freepbx


I will start testing tonight


Hi Stefano,

but under that url I get 404?

Perhaps,no sure!, I’ve done something wrong!

Mybe, how have you installed it? Are you connecting from green interface? Is there FreePBX in “Applications” page on NS web interface? Is there any error in /var/log/messages?


yes green, and no,no freepbx under “Applications” and in the log some error about backup nothing about asterisk or freepbx.

how did I install it?..well,

yum --enablerepo=nethserver-testing install freepbx-0:14.0-2.1 5.gf380335.ns7.noarch

and I had some(more then 100) warning about-

depmod: WARNING: /lib/modules/3.10.0-327.36.3.el7.x86_64/weak-updates/dahdi-linux/oct612x/oct612x.ko needs unknown symbol dahdi_register_device

that’s the right install command:
yum --enablerepo=nethserver-testing install nethserver-freepbx
I suggest to start over again instead of trying to fix this installation

about depmod warning, I have the same problem, but I haven’t studied it yet

[update] There is an Asterisk13 package known issue: asterisk user and group are created with fixed id and in some installation they could be already in use. Before installation, launch

groupadd -r asterisk
useradd  -r -s /sbin/nologin -d /var/lib/asterisk -M -c 'Asterisk User' -g asterisk asterisk


I’ve done it.

Now I try to find out how it works.

1 Like

Hi guys,

Apologies for being so quiet and very distant.

I decided to erradicate 5 of our production gentoo machines and Nethserve them, 2 of these machines were asterisk machines. After 2 weeks, no crashes and lots of cofffffffeeeeee. Freepbx is running, nethserver is just cruising and all is well.


I will test it this weekend

1 Like

Keep us updated, you will make @Stll0 happy

1 Like

I’ve started some testing and the only problem i found so far was right at the start, when updating the Core module

After trying to do an “update all modules”, Core just stuck on “disabled” and I couldn’t reload the config either

Error thrown on Core module update:

changing ownership of /etc/asterisk/http_custom.conf from root to asterisk apparently solved it and was able to update core and install all the other modules

Anything else i tried so far works well, the new modular UCP is a beast!

1 Like

Thanks for reporting it Davide. Are you planning to use it into a “real” environment?

Someone is talking about us

1 Like

The issue seemed to be a problem with the user not having mysql installed.

Out of interest, can the latest version of freepbx run using php7?

1 Like

FreePBX 14 stable version release


I tested FreePBX today and updated to and installed/updated all modules, even the commercial ones.
FreePBX complaining about missing sox and mpg123 so I did

yum install sox mpg123

The digium phones module is not working, when applying config I get:

exit: 255
Unable to continue. mkdir(): Permission denied in /var/www/html/freepbx/admin/modules/digium_phones/ on line 50
#0 [internal function]: Whoops\Run->handleError(2, 'mkdir(): Permis...', '/var/www/html/f...', 50, Array)
#1 /var/www/html/freepbx/admin/modules/digium_phones/ mkdir('/var/www/html/d...', 493, true)
#2 /var/www/html/freepbx/admin/modules/digium_phones/classes/digium_phones.php(2019): digium_phones_get_http_path()
#3 /var/www/html/freepbx/admin/modules/digium_phones/classes/digium_phones.php(56): digium_phones->read_customapps()
#4 /var/www/html/freepbx/admin/modules/digium_phones/classes/digium_phones.php(36): digium_phones->load()
#5 /var/www/html/freepbx/admin/modules/digium_phones/ digium_phones->digium_phones()
#6 /var/lib/asterisk/bin/retrieve_conf(585): digium_phones_conf->digium_phones_conf()
#7 {main}

even if it may be just a permission problem, I didn’t change anything, because installing other modules worked so I decided to just remove the digium phones module, which I maybe never need.

Some more issues with modules:

Installing ucp
Updating table ucp_sessions…Done
gcc-c++ is not installed
Error(s) installing ucp:
Failed to run installation scripts
Installing xmpp
MongoDB is not installed
Error(s) installing xmpp
Failed to run installation scripts

Installed gcc-c++ and mongodb-server

yum install gcc-c++ mongodb-server mongodb
systemctl enable mongod
systemctl start mongod

The ucp module did install, but I could not use it. No login with any user and the “forgot password” way leads to “E-Mail address unknown”.
The xmpp module did install, but the letschat process needs 100% of CPU so I asked Google for help and found but CPU load kept high and they were discussing a disk space problem in the end.
For now I just removed the xmpp module because using Nethserver jabberd is smarter.
I saw a system firewall module, but this is really redundant on Nethserver.

Setup extension, trunk, outbound route and inbound route and…now I am able to call the speaking clock with a sip client(MicroSip).
Tired now, but the next steps are network/NAT, inbound/outbound calling…and a lot of FreePBX functions.


Hi @mrmarkuz, nice work!

  • I’m adding mpg123 in FreePBX dependecies. Sox should be required by FreePBX RPMs, could you please check your version and requires?

    rpm -q freepbx
    rpm -q --requires freepbx

  • Digium phones module is trying to create a directory under /var/www/html/… You can manually change permissions to allow it, I don’t think that we should allow more writing permissions to asterisk user, it already have too much :smile:
    Maybe you can just create manually the directory. Let me know if you fix it, we should add it to docs

  • UCP is nice and useful it would be great to have it running. I’ll work on it soon, keep me posted if you have more tips. I don’t think we should install gcc-c++ as dependency, I don’t like it in production environment; we can write it on documentation when we’re able to get UCP to work


You are right. Maybe the older version didn’t have sox installed, FreePBX complained about it at dashboard.
[root@server ~]# rpm -q freepbx
[root@server ~]# rpm -q --requires freepbx | grep "sox|mpg123"

Full ACK

Changed permissions of /var/www/html for applying the config. The digium phones module wants to create the directory /var/www/html/digium_phones:
chmod go+w /var/www/html
Change back after applying config:
chmod go-w /var/www/html
But the module won’t work because it needs package asterisk13-res_digium_phone. I googled and found and there should be a free license.

Fully agree. I think it just needs it once to compile (parts of) the module, so I did
yum remove gcc-c++
and UCP still reachable. Don’t know if we can provide c++ only for module updates?

1 Like

Managed to login to ucp now. I had to allow the user in “User Management” in FreePBX and set rights for ucp there. Then it’s working.