Nethserver on Raspberry Pi


BUMP :slight_smile:

Anybody using a pi to run nethserver? Id be interested in using it as a mail server/LDAP. From what I can tell, email is not supported on ARM, but I have not tested it. Maybe tonight.

Hi Joel,

The arm package-repositories need some work… they are lagging behind the x86-64 repo and the centos repo’s.

However openLdap and mail is supported but there is one cave-cat:
Scanning for Viruses with clam-av (nethserver-filter) demands a lot of memory and if you are planing to use full mail filter support on a Rasberry pi you will find out it is a bit to demanding…
and therefor it is optional for arm.

EDIT: see for a quick view

grtz Mark


I installed the latest centos arm build minimal, and then added the nethserver repo from the other post. Works fast, only thing missing is SOGO. I screwed up ldap but thats my fault.


We never “released” SOGo although it does compile for arm: it is not very responsive.
Still looking for other solution for {Cal, Card}-Dav / active sync…

1 Like

Its pretty cool though…runs much faster than expected on pi

1 Like

What about horde?


Very interesting option to pursuit;
do I understand correctly it is plain php-5.4?

it is in the unofficial-armhfp-epel repository…


Yes, it’s working with PHP5.4.

Horde 5 requires the use of PHP 5.3 or above.

Great! I’ll test it the next days…it’s installabe via pear too, don’t know if it works on arm:


Hi Mark,
the active-sync part too? I searched for it for a “normal” x86/x64 system and on tachtler they say: active-sync only can be installed with pear because of it’s license.

Tachtler - Horde ActiveSync

ACHTUNG - Aus lizenzrechtlichen Gründen existiert aktuell KEIN rpm-Paket für ActiveSync!

ATTENTION - For licensing reasons there is currently NO rpm package for ActiveSync!

1 Like

IMHO having a low resource {cal card}-DAV solution enhances the mail server to something usefull,
I have to admit i use active sync for all my mobile devices and would not like to miss it on my “main” server.

We could try to find out which part of the license is holds feodora / Rhel back.
I do not see strange restrictions in the debian package;
If there are no further restrictions as there are with other implementation os active-sync, nothing would hold us back to make a package in time…

Just checked the SOGo documentarian, they used to have an disclaimer about the usage of active-sync which is removed… EDIT: still there

In order to use the SOGo ActiveSync support code in production environments, you need to get a proper usage license from Microsoft. Please contact them directly to negotiate the fees associated to your user base.

To contact Microsoft, please visit: and send an email to

Inverse inc. provides this software for free, but is not responsible for anything related to its usage.

1 Like

Horde and activesync works on a raspberry in a first test with Outlook as client!

Enable unofficial epel repo and install horde:

mv /etc/yum.repos.d/epel.repo ~
cat > /etc/yum.repos.d/epel.repo << EOF
name=Epel rebuild for armhfp
yum clean all
yum install

Enable activesync (which installs the activesync module via pear as it’s not in the unofficial epel repo - thanks @m.traeumner):

config setprop horde activesync enabled
signal-event nethserver-horde-update

You have to enable Activesync in the Horde web UI too. Don’t test on a production system!


kudo’s to @mrmarkuz & @m.traeumner :clap::clap:


I don’t know if I have follow a correct procedure… but I have installed Nethserver 7.6 full on Raspberry PI 3 B+… and it’s fantastic!


Kudos to our arm team @mark_nl @mrmarkuz @dz00te

1 Like

Do u think that can we ever have cockpit on Raspberry? :star_struck:

It should work because cockpit is a noarch package.

1 Like

I’ve do
yum install nethserver-cockpit
and I’m obtaining dependency error

Which dependencies?

Error: Package: nethserver-subscription-3.3.3-1.ns7.noarch (nethserver-updates)
           Requires: puppet-agent
Error: Package: cockpit-system-183-1.el7.noarch (nethserver-base)
           Requires: cockpit-bridge >= 183-1.el7
           Installed: cockpit-bridge-176-4.el7.centos.armv7hl (@extras)
               cockpit-bridge = 176-4.el7.centos
           Available: cockpit-bridge-173-7.el7.centos.armv7hl (base)
               cockpit-bridge = 173-7.el7.centos
           Available: cockpit-bridge-176-2.el7.centos.armv7hl (extras)
               cockpit-bridge = 176-2.el7.centos
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The problem is that cockpit requires a x86 package. It has to be fixed. Thanks for pointing that out.