Cannot change permissons for single folder on file share - access denied


(Armin) #1

NethServer Version: 7.4.1708-x86_64
Module: file sharing

Hello everyone,

I have a file share via my Nethsever, the domain controller works and I can access it via my Windows 7 after joining the domain. Now I would like to change via Windows the access permissions for one folder on that share but can’t do that. I always get and access denied when trying to change permissions for one folder in the share. I did that on a Samba share before and have no idea why it’s not working now.

My Windows is currently not in English but this screenshot might help explaining what I try to do:

Can somebody help me?
Thank you!

(Jeroen Visser) #2

You will have to set seDiskOperatorPrivilege and NOT use any usermappings in order for that to work. (You do need a username mapping tho) Let me dig up my similar question and answer for ya …

Edit: here ya go

(Armin) #3

Seems like I have to go back to Zentyal then, where this works without command line magic that I don’t unterstand sufficiently…
Thank you for your effort and answer nonetheless!

(Jeroen Visser) #4

I’m working on a step-by-step, but have to migrate a windoze server to nethservers first.

I hope to have the guide ready before the end of the year. I would recommend to try how far you get with copy and paste before giving up. It’s worth it.

(Armin) #5

I will gladely try a step-by-step guide once you made one! Without that I see myself sitting for days, only to end up with so many errors that I start with a new install. I am looking forward to the end of the year!

(Saito Benkei) #6

My experience:

enable administrator@domain.tld user in Nethserver “Users and Groups” panel (it should be sufficient to assign a password to the user), then, on an pc, access to the share you want to change the permissions with the administrator’s credentials user that you have just enabled.

(Armin) #7

Yes, that works for me too! Thank you!

(Davide Principi) #8

I’m planning to grant full privileges to members of “Domain Admins” (thus admin user at least, by default)

See also

It says it affects share permissions only. I understand it does not affect filesystem ACLs!

Desactivating access permission heritage for new folder on share doesn't work - access denied
(Jeroen Visser) #9

Nah, that’s just sloppy wording. With SeDiskOperatorPrivilege AND extended filesystem attributes on during mounting (something Nethserver doesnt seem to do default either?) you can set security permissions, as long as a username map exists for root = administrator

(Armin) #10

Hello everybody,

It seems this issue came back and I can’t figure out what has changed for it to stop working.

Issue: I create a new folder on my share and desactivate access permission heritage (is it clear what I mean? - my Windows is not in English) - access denied. That worked before and I don’t remember changing a thing.

Did an update change anything?

Does anybody have a solution for that?