Zabbix and mrmarkuz repo testing

Please test Zabbix and my new repo…

Release notes

Zabbix

  • Tested with Zabbix 4.4
  • New zabbix DBs are created with unicode
    • a warning was shown in newer Zabbix versions
  • Add db migrate script
    • use zabbixUnicode.sh to migrate old db to unicode
  • Add Zabbix application to cockpit - thanks to @flatspin for providing this wiki article
  • Updated device images
  • Add HTTPS redirect as newer versions don’t allow http login anymore

mrmarkuz Repository:

I added some features that are already included in @danb35 or @stephdl repos. Thanks guys for providing information and source code.

  • Update mail
    • root and domain admins get an update mail if there are new packages
  • Backup
    • repo is included in backup now
  • Metadata signing
    • a second key is used for metadata signing
  • Keys provided as file instead of http link
  • Server change
    • I use another VPS for my repo now and keep the old one as backup. If these tests are successful I’ll provide the new repo on the old server and with the next update everybody should use the new server. I keep the old server for backup repo so there should be no problem even if someone rarely updates.

Install procedure

You need to Install the new mrmarkuz repo first to get nethserver-zabbix.

yum -y install https://mrmarkuz.dynu.net/mirror/mrmarkuz/7/noarch/nethserver-mrmarkuz-0.0.1-4.ns7.noarch.rpm

Zabbix repo

Install the new Zabbix repo:

yum -y install https://repo.zabbix.com/zabbix/4.4/rhel/7/x86_64/zabbix-release-4.4-1.el7.noarch.rpm
yum clean all

Fresh install

To install nethserver-zabbix run following command:

yum -y install nethserver-zabbix

Update

To update nethserver-zabbix and Zabbix run the following command:

yum --enablerepo=mrmarkuz,zabbix update nethserver-zabbix zabbix-*

Testing

  • Open Zabbix by using the new server manager.

  • Check if Zabbix works in your environment.

  • If possible check fresh install and update

  • If you have old database and get a warning in dashboard, use the zabbixUnicode.sh script

7 Likes

Morning Markus!

Will test a little later, as soon as the caffein level is adequate… :slight_smile:

Good work!

Andy

PS: Here’s the latest Zabbix-Images file:
https://www.anwi.ch/downloads/Zabbix_ANWI-Library_2020-03-25.zip

2 Likes

@mrmarkuz

Coffee level up to testing… :slight_smile:

Installed the update:

yum -y install nethserver-zabbix
Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
epel/x86_64/metalink | 28 kB 00:00:00

  • ce-base: repo.uk.bigstepcloud.com
  • ce-extras: repo.uk.bigstepcloud.com
  • ce-sclo-rh: repo.uk.bigstepcloud.com
  • ce-sclo-sclo: repo.uk.bigstepcloud.com
  • ce-updates: repo.uk.bigstepcloud.com
  • epel: ftp.fau.de
  • nethforge: mrmarkuz.dynu.net
  • nethserver-base: mrmarkuz.dynu.net
  • nethserver-updates: mrmarkuz.dynu.net
    ce-base/7/x86_64/signature | 811 B 00:00:00
    ce-base/7/x86_64/signature | 3.6 kB 00:00:00 !!!
    ce-extras/7/x86_64/signature | 811 B 00:00:00
    ce-extras/7/x86_64/signature | 2.9 kB 00:00:00 !!!
    ce-sclo-rh | 3.0 kB 00:00:00
    ce-sclo-sclo | 2.9 kB 00:00:00
    ce-updates/7/x86_64/signature | 811 B 00:00:00
    ce-updates/7/x86_64/signature | 2.9 kB 00:00:00 !!!
    epel | 4.7 kB 00:00:00
    mrmarkuz/7/signature | 490 B 00:00:00
    Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mrmarkuz
    Importing GPG key 0xF144E5A3:
    Userid : “Markus Neuberger dev@markusneuberger.at
    Fingerprint: b0ef d107 b433 ccf0 db12 c453 6a35 e5a2 f144 e5a3
    Package : nethserver-mrmarkuz-0.0.1-4.ns7.noarch (@/nethserver-mrmarkuz-0.0.1-4.ns7.noarch)
    From : /etc/pki/rpm-gpg/RPM-GPG-KEY-mrmarkuz
    Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mrmarkuz-2
    mrmarkuz/7/signature | 2.9 kB 00:00:00 !!!
    nethforge/7/x86_64/signature | 836 B 00:00:00
    nethforge/7/x86_64/signature | 3.6 kB 00:00:00 !!!
    nethserver-base/7/x86_64/signature | 836 B 00:00:00
    nethserver-base/7/x86_64/signature | 2.9 kB 00:00:00 !!!
    nethserver-updates/7/x86_64/signature | 836 B 00:00:00
    nethserver-updates/7/x86_64/signature | 3.6 kB 00:00:00 !!!
    stephdl | 2.9 kB 00:00:00
    zabbix | 2.9 kB 00:00:00
    Not using downloaded zabbix/repomd.xml because it is older than what we have:
    *** Current : Mon Mar 23 11:54:34 2020***
    *** Downloaded: Mon Mar 23 10:42:22 2020***
    zabbix-non-supported | 951 B 00:00:00
    (1/16): ce-base/7/x86_64/group_gz | 165 kB 00:00:00
    (2/16): ce-extras/7/x86_64/primary_db | 164 kB 00:00:00
    (3/16): ce-sclo-sclo/7/x86_64/primary_db | 344 kB 00:00:00
    (4/16): ce-base/7/x86_64/primary_db | 6.0 MB 00:00:00
    (5/16): ce-updates/7/x86_64/primary_db | 7.6 MB 00:00:00
    (6/16): epel/x86_64/group_gz | 95 kB 00:00:00
    (7/16): epel/x86_64/updateinfo | 1.0 MB 00:00:00
    (8/16): nethforge/7/x86_64/group_gz | 1.7 kB 00:00:00
    (9/16): nethserver-base/7/x86_64/primary_db | 353 kB 00:00:00
    (10/16): nethserver-updates/7/x86_64/group_gz | 22 kB 00:00:00
    (11/16): nethforge/7/x86_64/primary_db | 112 kB 00:00:00
    (12/16): mrmarkuz/7/primary_db | 27 kB 00:00:00
    (13/16): nethserver-updates/7/x86_64/primary_db | 653 kB 00:00:00
    (14/16): epel/x86_64/primary_db | 6.7 MB 00:00:00
    (15/16): stephdl/7/primary_db | 219 kB 00:00:00
    (16/16): ce-sclo-rh/7/x86_64/primary_db | 4.2 MB 00:00:03
    Package nethserver-zabbix-0.0.1-7.ns7.noarch already installed and latest version
    Nothing to do

Seems to work, but I get this, which is a bit irritating:

Bildschirmfoto 2020-03-25 um 07.09.55

Will observe further, and test on other installations…

Will also (later) test with a completly fresh installation.

Andy

1 Like

@mrmarkuz

Small typo discovered:

1 Like

Thanks, fixed it.

1 Like

The fresh installed Testserver is installing…

:slight_smile:

1 Like

@mrmarkuz

Hi

Already found a few “Gotchas”, one is from the new Cockpit and has nothing to do with Zabbix:

On a freshly installed NethServer, Zabbix works as expected, and also displays the correct version:

Bildschirmfoto 2020-03-25 um 09.09.00

The updated ones (tested 4 so far) display the same version as before the update.

Another issue i found, but not specific with your update:

On long running and mostly problemless systems, the Zabbix Database can get quite large…
I have a treuhand company, one of the first I installed your Zabbix package two years ago, where the database has grown to 30+ GB (!).

As is well known, the included clean up packages do not work very well. Part of the problem is PostgreSQL itself, it seems that after deleting the data in the tables, even when writing the database during shutdown, the used space is NOT recovered.
A backup / restore seems to be needed.

This could be included in a simple script, maybe with 1-2 options in the new cockpit GUI…
(Retend time frame / purge from date backwards / older…)

I haven’t been successful so far, need to optimize the database…
Any suggestions?

My 2 cents
Andy

A big thank you @mrmarkuz , I hope to share a beer with you soon

1 Like

Thanks for testing!

Just klick on Example.Org and edit.

I think zabbix repo is disabled and we need the following to update Zabbix too. (check /etc/yum.repos.d/zabbix.repo for enabled=0)

yum -y --enablerepo=mrmarkuz,zabbix install nethserver-zabbix

Thx!

The translation “Leistung” doesn’t quite fit with the english “Power”… :slight_smile:
Some newbies might expect “overclocking” or other gags.

Andy

@mrmarkuz

Doesn’t work here, it’s needed 1-2 steps earlier already, methinks…

Any suggestions?

Andy

Does update instead of install work?

yum -y --enablerepo=mrmarkuz,zabbix update nethserver-zabbix

Not really, same…

1 Like

You can do it with phppgadmin

https://www.postgresql.org/docs/9.2/sql-vacuum.html or on CLI

Also tried this:

yum -y --enablerepo=mrmarkuz,zabbix install https://repo.zabbix.com/zabbix/4.4/rhel/7/x86_64/zabbix-release-4.4-1.el7.noarch.rpm
Loaded plugins: changelog, fastestmirror, nethserver_events
zabbix-release-4.4-1.el7.noarch.rpm | 14 kB 00:00:00
Examining /var/tmp/yum-root-QAQAn4/zabbix-release-4.4-1.el7.noarch.rpm: zabbix-release-4.4-1.el7.noarch
/var/tmp/yum-root-QAQAn4/zabbix-release-4.4-1.el7.noarch.rpm: does not update installed package.
Error: Nothing to do

Even after a reboot, the old version is displayed in Zabbix:

Zabbix 4.0.19. © 2001–2020, Zabbix SIA

1 Like

We need a update command and define zabbix-* additionally. Please try

yum --enablerepo=mrmarkuz,zabbix update nethserver-zabbix zabbix-*

Not yet…

[root@awr7-nethserver ~]# yum --enablerepo=mrmarkuz,zabbix update nethserver-zabbix zabbix-*
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile

another

yum clean all

then the same command works…
Seems to be an additional issue with the mirror…

:slight_smile:

Still testing…

1 Like

Please do another

yum clean all

and try again

I think it’s a yum issue. The yum clean all just forces it to recognize new packages.