Wordpress error curl 28

Hello everybody . By doing an analysis of the Wordpress control system, I found the following:

REST APIs are the way WordPress, and other applications, communicate with the server. An example is the block editor screen, which depends on the REST API to view and save your articles and pages.

The request to the REST API has failed due to an error.
Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 out of -1 bytes received (http_request_failed)

I investigated the internet, and this curl error could have been generated by little memory in php and more. I ask someone if they can give me an indication. It also appears to be generated by an old version of “CURL”. My server currently has all the updates from the official repository

Did you try to increase it at your php.ini?

Can you give us some information what you have tried till now, what wordpress version you have installed?

Did you try this version?

Package wordpress-AutoUpdater-5.2.3-1.ns7.sdl.noarch already installed and latest versionI deactivated the autoupdate to execute them manually, at the moment the blog has version 5.4

Furthermore I wanted to simulate the installation of wordpress from scratch and now this appears:

yum install nethserver-wordpress
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile

  • ce-base: mirror.ox.ac.uk
  • ce-extras: mirror.ox.ac.uk
  • ce-sclo-rh: mirror.ox.ac.uk
  • ce-sclo-sclo: mirror.ox.ac.uk
  • ce-updates: mirror.ox.ac.uk
  • epel: mirror.i3d.net
  • nethforge: markusneuberger.at
  • nethserver-base: markusneuberger.at
  • nethserver-updates: markusneuberger.at
    Resolving Dependencies
    -> Running transaction check
    —> Package nethserver-wordpress.noarch 0: 1.1.6-1.ns7.sdl will be installed
    -> Processing Dependency: wordpress for package: nethserver-wordpress-1.1.6-1.ns7.sdl.noarch
    -> Running transaction check
    —> Package wordpress.noarch 0: 5.1.4-1.el7 will be installed
    -> Processing Conflict: nethserver-wordpress-AutoUpdater-1.1.9-1.ns7.sdl.noarch conflicts wordpress
    -> Processing Conflict: nethserver-wordpress-AutoUpdater-1.1.9-1.ns7.sdl.noarch conflicts nethserver-wordpress
    -> Finished Dependency Resolution
    Error: nethserver-wordpress-AutoUpdater conflicts with nethserver-wordpress-1.1.6-1.ns7.sdl.noarch
    Error: nethserver-wordpress-AutoUpdater conflicts with wordpress-5.1.4-1.el7.noarch
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Please have a look at the following message from @stephdl :

both cannot be installed at the same time, they conflict

Hi, I downloaded for wordpress about curl error 28 a plugin https://en-ca.wordpress.org/plugins/query-monitor/ with which you could have more information on what was happening.
The plugin provided me immediately after launching the slate state of wordpress an error related to the certificate ssl check set to false. It has been suggested by the developers to try disabling some plugins.
So I ran the first test related to the error:

Subsequently deactivating the plugins one by one, I realized that what caused the problem was:


I rerun all the texts and this is the result:

I would say in a low voice that I have solved … without any unknown errors.

1 Like

Could you mark the topic as solved please,or do you want to test a little bit more?

Yes I knew. I just wanted to test a little more even though it is evident that it works. thanks a lot for your directions

1 Like