Upgrade rspamd to rspamd-1.7.9

testing
development

(Stéphane de Labrusse) #1

Who want to break his server, mine is already upgraded, nothing to say much

list of new features https://github.com/vstakhov/rspamd/releases/tag/1.7.9

Thank you in advance


We Are NethServer - Community Overview - Sep 18
(Uwe) #2

Updated and it works fine.

Regards

Uwe


(Bill ) #3

Update went fine. Reseting history now works!
clicking on configuration pops up a message “local > Request failed: Language not found” Not sure what that’s about.


(Stéphane de Labrusse) #4

thank for reporting, introduced by 1.7.9, we hide all score settings in rspamd and it seems problematic


(Alessio Fattorini) #5

@happnatious1 @transocean you felt very brave! :muscle:


(Uwe) #6

@alefattorini

The world belongs to the brave.:grinning:


(Stéphane de Labrusse) #7

ok got a fix

yum install http://packages.nethserver.org/nethserver/7.5.1804/autobuild/x86_64/Packages/nethserver-mail2-filter-2.2.7-1.3.pr71.g1e7a4c8.ns7.noarch.rpm

the UI expect a 200 return, and we block all actions URL by the reverse proxy, hence apache answers a 404. This is the error we can see.

In short to test rspamd-1.7.9

yum update rspamd --enablerepo=nethserver-testing
yum install http://packages.nethserver.org/nethserver/7.5.1804/autobuild/x86_64/Packages/nethserver-mail2-filter-2.2.7-1.3.pr71.g1e7a4c8.ns7.noarch.rpm

please test and report


(Bill ) #8

Everything looks good.
Thanks stephdl :smiley:


(Bill ) #9

After installing the latest release from the software center it looks like the problem is back.


(Stéphane de Labrusse) #10

What issue ?

Check the nethserver-mail2-filter IS still the right version


(Bill ) #11

clicking on configuration in the rspamd page pops up a message “local > Request failed: Language not found”
rspamd version 1.7.9


(Stéphane de Labrusse) #12

rpm -qa | grep nethserver-mail2


(Stéphane de Labrusse) #13

well found, You got an update which has overwritten my fix, check the rpm is now nethserver-mail2-filter noarch 2.2.8-1.ns7 nethserver-updates 67 k


(Bill ) #14

the output of the command rpm -q nethserver-mail2-filter is:
nethserver-mail2-filter-2.2.8-1.ns7.noarch


(Stéphane de Labrusse) #15

good my fix is gone :slight_smile:


(Bill ) #16

I hate it when I fix stuff too. :face_with_raised_eyebrow:


(Stéphane de Labrusse) #17

Be patient, in few days we will release my fix and rspamd 1.7.9.


(Bill ) #18

I understand, thank you for all your hard work.


(Stéphane de Labrusse) #19

Ola

Someone to test and report the upgrade to rspamd-1.7.9, please check https://github.com/NethServer/dev/issues/5561#issuecomment-418278813


(Markus Neuberger) #20

Upgraded a server and it worked so far except of a minor issue:
Clicking on history shows a “Request failed” which fades away after 2 seconds. I tried with firefox and chrome.

I don’t see any other errors or score thresholds in configuration tab or elsewhere.