Upgrade rspamd to rspamd-1.7.9

testing
development

(Stéphane de Labrusse) #21

question, does this server is a real server with a long history to display, I could reproduce this error but after a

systemctl restart redis-rspamd

the error was no more displayed, can you still reproduce it ?

EDIT: speaking too fast, rspamd error see https://github.com/rspamd/rspamd/issues/2435

cc @davidep @giacomo


(Markus Neuberger) #22

No. But now I have an error after restarting rpsamd and redis-rspamd. Maybe it does only occur if there are no errors?

cannot write command 5(408) to the worker 24648(hs_helper), fd: 19: Broken pipe

I think this error is because of the restart.


(Stéphane de Labrusse) #23

it seems the root cause, we could probably wait for the next update…do not know. with 1.7.8 you cannot reset the history :slight_smile:


(Stéphane de Labrusse) #24

please someone to test and report for this issue https://github.com/NethServer/dev/issues/5561#issuecomment-418278813

the test is to upgrade nethserver-mail-filter with rspamd-1.7.8 and check if no errors appears in the configuration tab.

so

yum install nethserver-mail2-filter --enablerepo=nethserver-testing

Thank in advance :slight_smile:


(Markus Neuberger) #25

I hope you ment rspamd-1.7.9-1. Or do I have to downgrade?

It worked without errors in configuration tab. :+1: I tested it on two physical servers. On one of them I could see the errors before the testing upgrade.


(Stéphane de Labrusse) #26

we would not release yet 1.7.9 for everybody, yes please test it with 1.7.8 :’(

in fact with 1.7.9 you could have an error in the history tab if you have no errors to display :slight_smile:


(Markus Neuberger) #27

Ok, but I installed mail2-filter without testing repo before and got rspamd 1.7.9-1.

I am going to downgrade and report…

EDIT:

Worked with rspamd-1.7.8-1 without errors in config tab! :sunglasses:


(Stéphane de Labrusse) #28

Merci bien, thank you so much