Update problems

updates

(Michael Träumner) #1

NethServer Version: 7.4
Module: update

Hi to all,
I try to explain what happened till now:

I’ve a test server where I had installed a subscription plan to test. After test period and changing back to community version I didn’t get any updates. This problem was solved by @giacomo

Also before this I had a yum cache error and had to rebuild the rpmbd

After these steps I could do updates at the terminal but not at softwarecenter. Softwarecenter shows yum cache error again.

Yesterday I tried to do updates and the error Giacomo solved before occurs again. After doing his steps, I could install updates at the terminal. Till today, today the same error.
After I did the steps of Giacomo again update works again.

Back to software center it shows clear yum cache, after doing this I have no entries for installed and not installed software. (Software center didn’t work in the right way before too, it has the message for a wrong repository, because of the testperiod of subscription).

Now I tried to install Nethser 7.5 from terminal with the following steps

yum clean all && yum update
yum update @nethserver-iso

and get the following message:

Warning: Group nethserver-iso does not have any packages to install.
No packages marked for update

Version at Dashboard is shown as 7.4.

Anybody an idea?

Thanks Michael


NethServer 7.5 RC1 released
(Markus Neuberger) #2

I get the same, seems this only worked during the early testing phase.

You may try to install the new release directly from mirror:

yum install http://packages.nethserver.org/nethserver/7.5.1804/base/x86_64/Packages/nethserver-release-7-6.ns7.noarch.rpm


(Michael Träumner) #3

Thanks Markus, this has worked. I had to install 41k :smiley: for new nethserver release.
Sadly the problem with yum errors still exist

This is the message at software center:

And the following at the terminal

[root@GroupwareBackup ~]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
https://m1.nethserver.com/stable/7.4.1708/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

https://m1.nethserver.com/stable/7.4.1708/centos-sclo-rh/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.


 One of the configured repositories failed (Stable mirror: SCLo rh 7),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=sb-centos-sclo-rh ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable sb-centos-sclo-rh
        or
            subscription-manager repos --disable=sb-centos-sclo-rh

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=sb-centos-sclo-rh.skip_if_unavailable=true

failure: repodata/repomd.xml from sb-centos-sclo-rh: [Errno 256] No more mirrors to try.
https://m1.nethserver.com/stable/7.4.1708/centos-sclo-rh/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

@giacomo How can I change to community repository not only temporarily.


(Giacomo Sanchietti) #4

The given instructions are permanent.
If you have packages installed from testing, the following apply:
http://docs.nethserver.org/en/latest/subscription.html#removing-a-subscription


(Michael Träumner) #5

signal-event software-repos-save

This doesn’t work for me. The folder

software-repos-save

doesn’t exist. Could this be my problem?


(Giacomo Sanchietti) #6

As I said before, only if you have installed from testing.

Please execute the commands given on the other thread:

config setprop subscription Secret '' SystemId ''
eorepo base centos-sclo-rh centos-sclo-sclo epel extras nethforge nethserver-base nethserver-updates updates
yum clean all
echo "nethserver-updates" > /etc/nethserver/pkginfo.conf

(Michael Träumner) #7

Hi @giacomo,
thanks for your patience. Earlier I used the testing repo to load some modules for testing, but it’s a long time ago.

The first three commands I did everytime when it doesn’t work anymore. After these steps yum at command line works mostly for the next updates. Next time I tried, I had the same problem with the “Stable Release”.
After doing the last command I had a look to

pkginfo.conf

There is only one line with nethserver-updates, so I think I don’t have the testing repository anymore.


(Giacomo Sanchietti) #8

Basically if SystemId has a value, everything is switched to subscription repos.
We have been reworked this part for the NS release lock feature, so please be patient until the update is out.

Or you can try it from testing:

yum --enablerepo=nethserver-testing update

And then execute:

signal-event software-repos-save

If you still have problems, I’d prefer to have direct access to the machine to see what is happening.

Thank you for your collaboration!


(Michael Träumner) #9

Hi @giacomo,
thanks again and sorry for late reply, I had a long weekend :smiley:.
I installed updates from testing now with

But the following doesn’t work:

Can’t open directory /etc/e-smith/events/software-repos-save

This is because the folder software-repos-save doesn’t exist. May I only create this folder?

After updates from testing I don’t have the lock feature at the software center (Software center seems to work again, no errors)

Here is my repo-list:

[root@GroupwareBackup events]# yum repolist -v
Loading "changelog" plugin
Loading "fastestmirror" plugin
Loading "nethserver_events" plugin
Config time: 0.075
Yum version: 3.4.3
Loading mirror speeds from cached hostfile
 * base: mirror.ratiokontakt.de
 * epel: mirror.neostrada.nl
 * extras: mirror.cuegee.de
 * nethforge: server.liftingtrade.hu
 * nethserver-base: server.liftingtrade.hu
 * nethserver-updates: server.liftingtrade.hu
 * updates: centosmirror.netcup.net
Setting up Package Sacks
pkgsack time: 0.081
Repo-id      : base/7/x86_64
Repo-name    : CentOS-7 - Base
Repo-revision: 1525378614
Repo-updated : Thu May  3 22:17:37 2018
Repo-pkgs    : 9,911
Repo-size    : 8.2 G
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock
Repo-baseurl : http://mirror.ratiokontakt.de/mirror/centos/7.5.1804/os/x86_64/
             : (9 more)
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:56 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : centos-sclo-rh/x86_64
Repo-name    : CentOS-7 - SCLo rh
Repo-revision: 1527163724
Repo-updated : Thu May 24 14:10:49 2018
Repo-pkgs    : 7,467
Repo-size    : 6.6 G
Repo-baseurl : http://mirror.centos.org/centos/7/sclo/x86_64/rh/
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:56 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/CentOS-SCLo-scl-rh.repo

Repo-id      : centos-sclo-sclo/x86_64
Repo-name    : CentOS-7 - SCLo sclo
Repo-revision: 1526296152
Repo-updated : Mon May 14 13:09:15 2018
Repo-pkgs    : 521
Repo-size    : 109 M
Repo-baseurl : http://mirror.centos.org/centos/7/sclo/x86_64/sclo/
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/CentOS-SCLo-scl.repo

Repo-id      : epel/x86_64
Repo-name    : Extra Packages for Enterprise Linux 7 - x86_64
Repo-revision: 1528050902
Repo-updated : Sun Jun  3 20:56:14 2018
Repo-pkgs    : 12,585
Repo-size    : 13 G
Repo-metalink: https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64
  Updated    : Sun Jun  3 20:56:14 2018
Repo-baseurl : https://mirror.neostrada.nl/epel/7/x86_64/ (92 more)
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/epel.repo

Repo-id      : extras/7/x86_64
Repo-name    : CentOS-7 - Extras
Repo-revision: 1527610607
Repo-updated : Tue May 29 18:18:56 2018
Repo-pkgs    : 305
Repo-size    : 545 M
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=extras&infra=stock
Repo-baseurl : http://mirror.cuegee.de/centos/7.5.1804/extras/x86_64/ (9 more)
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : nethforge/7/x86_64
Repo-name    : NethForge 7
Repo-revision: 1526481335
Repo-updated : Wed May 16 16:35:36 2018
Repo-pkgs    : 22
Repo-size    : 26 M
Repo-mirrors : http://mirrorlist.nethserver.org/7/nethserver?release=7&repo=nethforge&arch=x86_64
Repo-baseurl : http://server.liftingtrade.hu/nethserver/7.5.1804/nethforge/x86_64/
             : (14 more)
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/NethForge.repo

Repo-id      : nethserver-base/7/x86_64
Repo-name    : NethServer-7 - Base
Repo-revision: 1509031675
Repo-updated : Thu Oct 26 17:27:59 2017
Repo-pkgs    : 250
Repo-size    : 830 M
Repo-baseurl : http://mirror.nethserver.org/nethserver/7/base/x86_64/
Repo-mirrors : http://mirrorlist.nethserver.org/?release=7&repo=base&arch=x86_64&nsrelease=7.4.1708
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/NethServer.repo

Repo-id      : nethserver-updates/7/x86_64
Repo-name    : NethServer-7 - Updates
Repo-revision: 1526568476
Repo-updated : Thu May 17 16:48:16 2018
Repo-pkgs    : 432
Repo-size    : 1.7 G
Repo-baseurl : http://mirror.nethserver.org/nethserver/7/updates/x86_64/
Repo-mirrors : http://mirrorlist.nethserver.org/?release=7&repo=updates&arch=x86_64&nsrelease=7.4.1708
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:57 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/NethServer.repo

Repo-id      : updates/7/x86_64
Repo-name    : CentOS-7 - Updates
Repo-revision: 1527864102
Repo-updated : Fri Jun  1 16:46:22 2018
Repo-pkgs    : 654
Repo-size    : 2.3 G
Repo-mirrors : http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=updates&infra=stock
Repo-baseurl : http://centosmirror.netcup.net/centos/7.5.1804/updates/x86_64/ (9
             : more)
Repo-expire  : 21,600 second(s) (last: Mon Jun  4 11:14:58 2018)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

repolist: 32,147

(Giacomo Sanchietti) #10

No, it’s included in nethserver-base-3.3.0-1.ns7.noarch.

Good, you have now standard repos.
Everything seems fine :wink:


(Michael Träumner) #11

I don’t know. Dashboard shows 7.5.1804 beta, but no updates are available. What is about the RC and the lock feature? (I don’t need it, it is only a test server, but I wanted to help with testing.)


(Giacomo Sanchietti) #12

I just noticed that your machine has a value for nsrelease.
Try also this:

echo > /etc/yum/vars/nsrelease
yum clean all && yum update

One of my baremetal installs still says beta
(Michael Träumner) #13

Hi @giacomo,
thanks so much for your constantly help. Now it works fine. I’ve the RC and the configure button at the software center.


(Giacomo Sanchietti) #14

Let me know if something breaks again, but I hope not! :pray: