NethServer 7.5 RC1 released

(Dr Thomas Quinton) #4

Thank you for your incredible work. Just right now in Friuli at a conference.

(Rob Bosch) #5

I took the jump. Only for my main homeserver and I did make a snapshot before removing the repo lock.
650packages updated and now running a new and shiny NS 7.5 RC!

(Davide Principi) split this topic #6

A post was split to a new topic: FreePBX 14 proxy error

(Giacomo Sanchietti) #7

Because both options have been removed before final package release.
The firewall should be able to do a good QoS without any special options.

I removed the section from the manual.
Thank you for pointing it out!

(Michael Kicks) #8

Back on the bleeding (or unstable? :laughing:) edge…

I need to find a solution for my scapegoat to reboot without power-cord-operations…

(James Nesbitt) #9

This is where I love’s a little Cisco router trick for making updates:

  1. Plan your updates and have the commands ready in a text editor.
  2. When you log into the Cisco router, set an automatic restart for x number of minutes time (x being the number of minutes + an extra 2-3 spare minutes).
  3. Run the various commands to update the router config.
    4a) If everything works, save the new configuration and either cancel the router restart or allow the router to restart.
    4b) If the config breaks and you still have access to the router, revert out your changes and start again
    4c) If the config breaks and you loose access to the router, wait for the router to restart and you’re back with the original config

Now the fun past is to get Numbers 2 and 4c working for when things go wrong…:grin:

(Rob Bosch) #10

The magic word: Snapshot :rofl:

(Michael Kicks) #11

To keep things clear: scapegoat (my NethServer installation test) is a crappy Acer Veriton with AMD CPU that don’t seems to handle at best the reboot. I don’t remember the kernel version which started to do the trick (installation started with 7.3) but i don’t think the issue come by CentOS. It’s just crappy hardware, which is silent, powerful and low consumption enough to play with the toy.
It’s expendable.

Maybe in a couple of months i will get in touch with a SFF Optiplex 790, with an i3 CPU. And i will try the death and resurrection of my scapegoat (also known as Backup and Restore…)

(Michael Träumner) #12

Installed 7.5 RC at two servers, installation was a little bit tricky, but the systems work without problems now.
At the first server I had a generally update problem, because I tested subscription before. See here:

The second one missed some PHP dependency for dokuwiki. Enable @stephdl -repo for update did the trick:

yum update --enablerepo=stephdl

@dev_team, @alefattorini and all other who did some work for it. Thanks for your great work

Hi Everyone - What has Nethserver been up to
(Dr Thomas Quinton) #13

Unfortunately I had to revert to the snapshot I did before because Nextcloud was not working any more…I already tried twice…

(Giacomo Sanchietti) #14

We have nextcloud installation on our production server and it’s working since beta without problems.

Do you mind to open another thread and report the problem? Please let us know if you’re using a virtualhost or not and what are the errors inside /var/log/http/ directory along with errors from /var/opt/rh/rh-php71/log/php-fpm/error.log.

(Dr Thomas Quinton) #15

We added serveral fuctions like notes calender and prepared for OnlyOffice- probably that the problem- I´ll report in a new topic…


Upgraded a virtualbox 7.4 test server with NextCloud from the software center successfully.

Tried to upgrade a virtualbox 7.4 production server with Nextcloud from the software center… was presented with dc errors… no time to troubleshoot, restored snapshot…
Haven’t dared to try the update with any of my other production servers.
Very short of free time, one of the reasons I haven’t been active here.

Now the production servers are held up for updates because they are still all or nothing upgrades from the gui. It’s time consuming to figure out which security related updates can be applied without triggering a dependency based, full distro upgrade to 7.5.

Samba is not working (SSSD accountsprovider error)
(Davide Principi) split this topic #17

5 posts were split to a new topic: WebVirtMgr alternatives

(Jon) #18

Hi to all!

-NethServer: 7.5.1804 final?? :scream::smiley:

(Michael Träumner) split this topic #19

A post was merged into an existing topic: WebVirtMgr alternatives

(fpausp) #20

ISO Image download ?

(Davide Principi) #21

We’re waiting for @alefattorini’s #announcements :unamused:

(Juan Carlos Fernandez) #22

Are this two features going to be re-enabled? I really liked the [Reserve bandwidth for VoIP]

(Giacomo Sanchietti) #23

Just create a class with a reserved bandwidth, then go the firewall rules and create a rule matching voip traffic.