Unresponsive server when installing on a VPS

Hi,

I have been trying to install Nethserver on a CentOS 6.4 minimal distro, on two different VPS from two different providers, none of which is OVH. Unfortunately the result is always an unresponsive server.

I have tried installing after updates, before updates, turning iptables off, I have tried the official method, alternative tutorials such as this one found here in the forum - Install NethServer on DigitalOcean - But unfortunately the result is always the same.

The installation itself goes on without a problem and the install log reveals that it has completed successfully without any error. But then I get a message saying “Configuring system, please wait” and the machine becomes unresponsive. and I have to reinstall the OS.

I have tried the official method a few times and was surprised to find such an issue as I would imagine most people would run this on a server or VPS. yet, I dont seem to find many reports of this happening.

Any help or idea would be very much appreciated and thanks in advance.

Fred

Hi Fred,

Try to install on CentOS 6.7 x64 if you want NS 6.7.

http://docs.nethserver.org/en/latest/installation.html#install-on-centos

BR
Gabriel

Hi @StreetGuru

Minimal requirement for Latest build of Nethserver is clean Centos 6.7 after that you should follow the steps below:

http://docs.nethserver.org/en/latest/installation.html#install-on-centos

Hi and thanks for your prompt replies.

I only have access to the distros available at the VPS - both are 6,4 minimal installation. But I do a yum update && yum groupinstall core && yum groupinstall base which should bring me up-to-date no? I have also tried in a clean 6.4 with the same result.

I then follow the instructions here

http://docs.nethserver.org/en/latest/installation.html#install-on-centos

But the result is always an unresponsive server.

Like i said, the installation itself completes without any issue. It is when it starts “configuring the system, please wait” that i loose ssh access and the server becomes unresponsive.

Can this have to do with some network configuration done by nethserver on the configuration phase? However, I can still access the server through console.

Any packages missing on 6,4 that are required? I get no dependencies missing…

Is your VPS on OpenVZ?

yes, both are OVZ.

Oh it is known issue :

1 Like

Oh!! Been browsing the forums looking for an answer and in a few days didn’t manage to find that post!

Many thanks, will give it a try and report back!

@StreetGuru do not hesitate to ask if our assistance is required.

NS 6.7 is based on CentOS 6.7 (the version number of NS is the same with the version number of CentOS).
When you install NS from ISO, the version of CentOS is the same with NS.
When you install ontop of CentOS, the version of CentOS must be the same with NS version.

The minimal version of CentOS is 6.5 for NS 6.5.
After that you can try the upgrade instructions from here:
http://docs.nethserver.org/en/latest/release_notes.html (replace /latest/ with the proper NS version).

@GG_jr it is not that situation )

@StreetGuru please one more question

How about network interface ? Is it venet or bridge?

venet

I was originally thinking this was a network configuration problem but when I managed to access it via console I discarded that possibility. Can that be causing some conflict as well?

@Nas I dont really get the first step of the tutorial you sent me, can you clarify please? What exactly does it mean by “Then create CT in ProxMox using this template” ?

Thanks for your help

Fred

This step it is for OpenVZ provider )
Begin from step 2
and pls answer about Network.

@Nas I answered already above but forgot to mention you.

It is indeed venet.

Is there any additional configuration required for the network?

Many thanks,

Fred

Ok, this is the result:

I started by updating the system having in account what GG_jr mentioned above:

yum -y update
yum -y groupinstall core
yum -y groupinstall base

Then I reboot. I then start at the tutorial posted above:

yum install yum-utils && yum-complete-transaction && yum update

Which tells me that all packages are already installed and none was installed/upgraded. Fine, so i skip reboot as i had done this already after the upgrade. so i move on to the next step:

yum localinstall -y http://mirror.nethserver.org/nethserver/nethserver-release-6.6.rpm && yum update

Several packages get installed. I move on to the latest step:

nethserver-install

and that gives me the following output:

[root@box ~]# nethserver-install

NethServer is already installed!

You can access the Web interface at:

https://.:980
Login: root
Password: <your_root_password>

Installation log can be found here: /var/log/nethserver-install.log

When I check the instalation log it only contains two sentences:

Dom Jan 31 11:48:15 EST 2016 Already installed
Dom Jan 31 11:48:15 EST 2016 End

It’s obvious nethserver didn’t even get installed as for some reason it recognized it was already installed?? Also, there does seem to require some additional network configuration as it is not detecting the server’s IP address.

Any help would be very much appreciated, thanks!

Fred

@StreetGuru :

  1. yum install yum-utils && yum-complete-transaction && yum update

  2. yum localinstall -y http://mirror.nethserver.org/nethserver/nethserver-release-6.7.rpm

  3. nethserver-install

@StreetGuru

It is needed to change Venet to bridge, is it possible ?

@Nas

I dont think it is possible as this is the setup of the provider.

I have the exact same results with your tutorial. I have checked CentOs version at first boot and it is 6,4. So i rum yum -y update and that brings me to version 6,7 (Final). I install yum-utils & yum-complete-transaction and that goes fine. I then install nethserver and also installs successfully. And now I’m again stuck at “Configuring system, please wait…”

I really think this is a network configuration problem. Any other ideas? I would imagine most people would want to run this on a VPS and most cheap providers use OVZ with venet (I have 5 linux VPS and they all use OVZ and venet). But it feels like nethserver is not ready to be deployed in such an evironment?

I would really like to have this working so I could give it a try but honestly I am close to giving up on it… it’s been a couple of days, about 10 attempts in different machines and still I’m at the same point where i started!

Any configuration that can be done in venet adapter to configure the network right? I can not connect to the server again through ssh but I can connect on the console on port 22!

Amy ideas? Thank you for the assistance.

Fred

It is normal because NS do not recognize VENET network and after this words, it remove all /etc/sysconfig/network-scripts/ as by default template.

So it is a limitation of design,