Installation causes remote connection/server to hang

NethServer Version: v7

I had a fully working installation with nextlcoud running with ldap integration on a VPS. I was trying to modify ldap but at a sudden point the remote connection was cut. I assumed that sth went really wrong with the configuration and decided to make a clean installation of everything. The strange issue is that when trying to install nethserver the hang happened again right at the point of initiating the network service:

Last output during installation before the freeze:

symlink from /etc/systemd/system/ to /usr/lib/systemd/system/nethserver-config-network.service

I requested a manual reset of the server. If that does not work i cannot imagine what went wrong. The installation was working fine for a week already which mean that whatever went wrong at the first hang is somehow retained when making a clean installation. Anyone have any ideas?

Which provider/virtualization is used?




Hetzner. Not sure what virtualization they use by default. I find it weird that the hang was so sudden. And all the previous times the installation was set up with no issue. Been playing with it for at least a couple of weeks.

Seems to be a known issue:

Hmm. I see…Interesting that it worked fine all this time. I was actually using 1 single red interface that i would set up when i first logged in the nethserver web interface. And never had the issue until today.

I will try out the solutions. Thank you!

1 Like

Looking at the solution i kinda think that using a hetzner root server with Nethserver is not the best idea. I wanted to set up nextcloud server along side other services and have them authenticate with the same ldap accounts. But risking suddenly for the network interface to stop working because of the single network interface hetzner has it not really practical. If this is in production cannot risk the data to be suddenly completely inaccessible.

As CentOS 7 is supported and Nethserver 7 is based on it, it should work.

Did you install from ISO or from yum?

Unfortunately I don’t have a hetzner VPS to test, I use contabo.
This article helps to setup a working CentOS 7, so you may install Nethserver from yum:

Try to setup CentOS and later Nethfy it could be an option?
Don’t forget the “dummy” interface as VLan

1 Like

Always installed a CentOS 7.6 install from the Hetzner images and then installed nethserver with yum. Worked fine at first.

Please. create the interface before starting to install NethServer. And use the vLan as green interface.

Same issue even using the dummy vlan. Hangs during installation and server is inaccessible.