Subnet refused by GUI

openvpn

(Michael Kicks) #1

NethServer Version: 7.6.1810

I’m trying to setup my OpenVPN with subnet 172.31.4.240 mask 255.255.255.240 and GUI answers

Network
regular expression /^(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(0)$/

If i use 172.31.4.0 with same mask completes without errors.


(Filippo Carletti) #2

Confirmed. The ip validation doesn’t like 172.31.4.240.
Would you like to open an issue on github?


(Michael Kicks) #3

I don’t have any account on github, sorry.
I tried also with different numbers on the third octet, maybe is only a matter of the fourth octet for being validated.


(Filippo Carletti) #4

Workaround:

config setprop openvpn@host-to-net Network 172.31.4.240
signal-event nethserver-openvpn-save

(Michael Kicks) #5

Thanks @filippo_carletti.


(Filippo Carletti) #6

GH issue:


(Giacomo Sanchietti) #7

The package is ready for testing.

Would you like to give it a try @pike?


(Michael Kicks) #8

Please, post how may I try :wink:


(Giacomo Sanchietti) #9

This is the command to install the new RPM:

yum --enablerepo=nethserver-testing update nethserver-openvpn

Then try to modify the configuration from the UI using another netmask and save. Finally go back to your netmask and verify that the UI accepts it.


(Michael Kicks) #10

All /28 subnets seems ok. Anyone can try the /29, /30 and also /31 missing subnets :wink:

I also tried to feed a wrong subnet id, and it was detected.
I don’t know if it’s a bug, but if i change settings, disable the server, and i click on save, the subnet id and mask can still be edited and saved while clicking on save.
Only if i reload the page edit is disabled.


(Giacomo Sanchietti) #11

Thank you for testing.

Yes, it’s a little bug in UI framework, we have it since ages :smiley:

IMHO it doesn’t worth fixing it now.


(Michael Kicks) #12

seem never worth fixin…