SOGo and Activsync

NethServer Version: 7b2
Module: nethserver-sogo

After having had to reinstall the server, I’m now able to use SOGo web interface, but not ActiveSync.

When I try to contact I receive a 404 error, and in fact, both Android and Windows Phone cannot complete the registration of the email account hosted on nethserver.

I have tried on a different server hosting the previous version of SOGo and https://fully.qualified.domain.differentname/Microsoft-Server-ActiveSync return an error due to the fact that I’m not authorized, that is the expected behaviour.

I have installed SOGo from the command line with yum install nethserver-sogo, do I have to install also sogo-activesync ?

Thank you


You are right, it is’t working :cry:

The virtual host for Activsync is not configured, and to be quite frank i’m still figuring out how it al works in the new virtual-host setup an V7-beta2.

I got it running, but it is better if someone else checks this solution.
If it’s good we make it permanent, always remember nethsever most of the configuration file are overwritten at certain events. So you should never manually change them, and that’s exactly what i did. :pensive:

edit /etc/httpd/conf.d/SOGo.conf
un-mark Microsoft ActiveSync support

# Enable to use Microsoft ActiveSync support
# Note that you MUST have many sogod workers to use ActiveSync.
# See the SOGo Installation and Configuration guide for more details.
ProxyPass /Microsoft-Server-ActiveSync \ \
 retry=60 connectiontimeout=5 timeout=360

edit /etc/httpd/conf.d/
add a redirect, last line (BTW sooner or later this will be overwritten)

RewriteEngine On
RewriteRule ^/sogo(/.*)?\$ https://%{SERVER_NAME}/SOGo$1 [R=301,L]
RewriteRule ^/SOGo(/.*)?\$ https://%{SERVER_NAME}/SOGo$1 [R=301,L]
RewriteRule ^/Microsoft-Server-ActiveSync(/.*)?\$ https://%{SERVER_NAME}/Microsoft-Server-ActiveSync$1 [R=301,L]

at least you can test it this way…

1 Like

Thanks Mark, it works.

For the time being it is fine even if I have to manually make changes every now and then. I just want to test the new Nethserver 7, it is not production.


You can do like a pro (if you up to it) :wink:

have a look in:
> ls -l /etc/e-smith/templates/etc/httpd/conf.d/
> cat /etc/e-smith/templates/etc/httpd/conf.d/

this are default templates witch construct the configuration files,
you should not touch them! make a custom template instead:

make a directory for it
mkdir -p /etc/e-smith/templates-custom/etc/httpd/conf.d/

copy the default template

cp /etc/e-smith/templates/etc/httpd/conf.d/ \

edit the custom template
and add the custom RewriteRule:

#custom RewriteRule
RewriteRule ^/Microsoft-Server-ActiveSync(/.*)?\$ https://%{SERVER_NAME}/Microsoft-Server-ActiveSync$1 [R=301,L]

simulate a SOGo update:

signal-event nethserver-sogo-update

and have a look at the httpd configuration file

cat /etc/httpd/conf.d/

The SOGo.conf remains untouched, I’m not sure it should even be there :blush:

Happy testing


Hi @andreadb
You test the @mark_nl solution? It has solved your problem?
I’m interested in hearing about your experience. Thank you :+1:

1 Like

Hi all, I’m sorry to have not been able to respond for a long time. As I said I’m only testing Nethserver to check if I can replace the current mail server with an OS solution, but I still have to manage the current one :slight_smile:

Yes, activesync worked perfectly, I have been able to configure it on two different mobile phones without any issue, but I still had not time to check the suggestion of mark to make the change permanent. I hope to have more time to test it soon.

Thanks for your support,


1 Like

I can’t get if you have added this into your rpm. Looks like a good hack :slight_smile:

Sure, Active Sync & dag are enabled by default, webtop AS has preference.