Active sync, CalDav, Dovecot filters - Stopped working - NS 7.2 RC1

I too am experiencing problems with NS7.2 RC1 (not to be confused with the more recent post about email problems). What I had was all working fine in Beta2. Then “the upgrade”…

Using Email, SOGo, Roundcube and filters

The symptoms are:

  • Thunderbird calendars and tasks not longer synchronize
  • BB10 MS Exchange access - totally dead
  • Serverside filtering of email into different folders - no longer working

What does work is IMAP through Thunderbird.

Ideas of where to get more info??

Have scanned the various logs but nothing jumps out at me.

Same at my side, the whole active sync is not functional and so it is not possible to use sogo for email,calender and contacts and sync it with mobiles or outlook. i am on a fresh ns 7.2 rc1

Did you get MS activesync going?

Could you expclain how you used to set this up?
It would help me tracking down things to fix on the SOGo package :slight_smile:

1 Like

Please note that it WAS ALL working in beta2. They stopped working in RC1. I’ve been using them all since NS7 Alpha1

I fixed Thunderbird calendar / task access by:- unsubscribing the calendar- deleting the http SOGo.conf file- reinstall sogo- signal-event nethserver-sogo-update- resubscribing to calendar

I removed the ActiveSync connection from my BB10. And setup an IMAP entry for email and CardDav entry for contacts. ActiveSync does NOT work in RC1.

Server side email filters are setup using Roundcube web interface. They’re all present BUT not working. ‎I am fairly certain that these filters are not in SOGo but more likely in dovecot. Since I have used dovecot and filtering on BSD, methinks that there may just be a lost setting somewhere the nethserver config.

I could not find something wrong in the sogo setup, it is a straight forward connection to the sieve-port (4190) on the local host. Documentation of sogo is a bit vague about the used credentials, there is one reference they are the same as authentication dor Imap (makes sense) Dovecot is listing on port 4190, I’m out of options :pensive:

ONly other thing i can think of is dovecot can’t write them in the users home dir, but am not even sure where NS7 store’s users sieve filters. :hushed:

1 Like

My biggest concern is that ActiveSync is not working.

Filters are something that I can check out myself

Have you tried this?

this works just fine for me; @andreadb and @hucky have reported it works for them too. :grinning:

When it comes to dav support it’s there, (for now) only on hostname/SOGo/dav.

1 Like

Many thanks for that one. Yes it corrected the problem.

Now onto sieve filters…

1 Like

The sieve filters for some reason (possibly my own ffp “fat finger problems”) has been corrected by going into Roundcube mail - Settings - Filters - disabling/(re)enabling the filters.


tried but does not work for me. I have tested with two different accounts to create filters and they don’t work at all on my RC1 installation… Tested again and again from the beginning and the filter do not work. Any idea?

Sorry for taking so long to respond. Have been a little tied up.

I have used Roundcube filters with Dovecot for years at the server level.

Make sure that you sign on using the Roundcube interface (/webmail). Once you go into settings and select Filters there are three panes to the left and one main pane on the right,

Screen shot 1

Two things that I have had to double check - the first is that the filter set is enabled, and the second is that the filter is enabled. The following screen shot shows a sample filter completed as well.

Not sure if this helps at all.

Thank you very much for the good explanation.
There is however a small glitch in the roundcube / login that is going to be fixed. (see

However, I have no idea why editing the filters in the roundcube is unreliable.
Sometime the (+) button don’t work only after a refresh. The same also if I select an existing rule. I suspect the Safari browser… Firefox seems fine… at least worked with the first test…