SoftwareCenter Problems (update not working, modules not shown)

softwarecenter
v7

(Marc) #21

What’s the output of:

yum --assumeno update @nethserver-iso

(Michael Kicks) #22

@jrieder are you using 7.5?


#23

Here is the output- I executed the command two times as first there was a network issue?

[root@homeserver1 Modules]# yum --assumeno update @nethserver-iso
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
epel/x86_64/metalink                                                            |  28 kB  00:00:00
 * epel: ftp.uni-bayreuth.de
centos-sclo-rh                                                                  | 3.0 kB  00:00:00
centos-sclo-sclo                                                                | 2.9 kB  00:00:00
https://fedora.cu.be/epel/7/x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to 2001:67c:314::feed:efff: Network is unreachable"
Trying other mirror.
epel                                                                            | 4.7 kB  00:00:00
https://mirror.ehv.weppel.nl/epel/7/x86_64/repodata/repomd.xml: [Errno -1] repomd.xml does not match metalink for epel
Trying other mirror.
epel                                                                            | 4.7 kB  00:00:00
(1/2): epel/x86_64/updateinfo                                                   | 959 kB  00:00:02
(2/2): epel/x86_64/primary_db                                                   | 6.6 MB  00:00:08
Warning: Group nethserver-iso does not exist.
No packages marked for update
[root@homeserver1 Modules]# yum --assumeno update @nethserver-iso
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
 * epel: mirror.i3d.net
Warning: Group nethserver-iso does not exist.
No packages marked for update
[root@homeserver1 Modules]#

#25

Hi, see my very post:

NethServer Version: System version NethServer release 7.5.1804 (final)
Kernel release 3.10.0-862.14.4.el7.x86_64
Module: see below


#26

Hello, are there any thoughts based on the outcome of the commands?
Thanks for your support!


(Marc) #27

From the last outcome, I think the server didn’t contact nethserver repos (or at least I get the same message on an old v7.4 instance after disabling nethserver repos).

From the image showing packages to update (post #1), all the packages shown are matching packages from nethserver-base repo, none from nethserver-updates.

What @pike says about having an older release version is also relevant. Not all nethserver mirrors have a copy of older repositories, and that can have an impact when the release lock is in place.

EDIT: I can confirm the problem you are getting is due to having release lock enabled.
To make it work, go to software center and configure release lock to unlocked. Save the changes and from the comand line:

yum --enablerepo=* clean all
yum update

which shall update your server to v7.6.xxxx


#28

I disabled the release locking.
Then I saw all the packages again in SW center (installed as well available).
However, trying then your suggestion “yum --enablerepo=* clean all; yum update” again fails


(393/398): zlib-1.2.7-18.el7.i686.rpm | 91 kB 00:00:00
(394/398): zlib-1.2.7-18.el7.x86_64.rpm | 90 kB 00:00:00
(395/398): tomcat8-8.5.35-1.ns7.noarch.rpm | 8.5 MB 00:00:48
(396/398): nextcloud-15.0.5-1.el7.noarch.rpm | 51 MB 00:04:14
(397/398): sogo-4.0.5-2.ns7.x86_64.rpm | 20 MB 00:01:27
(398/398): webtop5-1.2.12-1.ns7.noarch.rpm | 115 MB 00:02:43
Some delta RPMs failed to download or rebuild. Retrying…
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://mirror.wiuwiu.de/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 0.0 B/s | 0 B --:–:-- ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED 13% [========== ] 0.0 B/s | 85 kB --:–:-- ETA
http://mirror.cuegee.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 0.0 B/s | 85 kB --:–:-- ETA
Trying other mirror.
(1/2): webtop5-zpush-1.1.5-1.ns7.noarch.rpm | 472 kB 00:00:02
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://mirror.easyname.at/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://mirror.nextlayer.at/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://ftp.fau.de/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://mirror.inode.at/data/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://centos.mirroraustria.at/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://mirror.digitalnova.at/CentOS/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://ftp.tugraz.at/mirror/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.
polkit-0.112-18.el7_6.1.x86_64 FAILED
http://ftp.antilo.de/pub/linux/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable ] 148 kB/s | 212 kB 00:00:02 ETA
Trying other mirror.

Error downloading packages:
  polkit-0.112-18.el7_6.1.x86_64: [Errno 256] No more mirrors to try.

[root@homeserver1 ~]#

I searched a bit and it could be the same issue then here

https://www.linuxquestions.org/questions/linux-newbie-8/centos-7-update-failing-4175650609/

or here

https://www.centos.org/forums/viewtopic.php?t=70035

I tried

[root@homeserver1 yum]# echo deltarpm=0 >> /etc/yum.conf

then finally the upgrade to release
System version NethServer release 7.6.1810 (final)
was successful. :grinning:

However, I think if the SW-lock leads to such behavour this is probably not the intended behaviour for this feature and eventualy not really useable, or I’m I wrong?

Thanks anyway for all the help.


(Marc) #29

Yep, you got an unrelated error from a CentOS repo: [Errno 256] No more mirrors to try

In the past there was a bug but in your case the lock was working, but some of the locked repos could be unavailable or an extra upgrade step required. Nonetheless, leading to problems surely isn’t the intended behavior.
From command line most repos pointed to the locked version release but the ones that don’t support minor versions (epel, scl…), IIRC.

Release lock has been modified to always locked and manual upgrade to new release, IIRC: Ultimate ns7 software updates origin policy