Setup pppoe connection FTTH

Hi,

im trying to setup my Internet connection with Nethserver. My internet provider offers me an FTTH Connection which allows me to connect directly to the server via PPPOE without any Modem.

When i´m trying to setup my ppp0 Interface there comes a error: “S70network-start #8 (exit status 256)”

Can anybody tell me what that error means?
What infos i have to Enter to the “Provider” field?

This are the logs from “/var/log/messages”

Aug 29 19:47:10 NET01 esmith::event[16760]: Action: /etc/e-smith/events/nethserver-firewall-base-save/S89nethserver-shorewall-restart SUCCESS [1.394002]
Aug 29 19:47:10 NET01 pppd[16143]: LCP: timeout sending Config-Requests
Aug 29 19:47:10 NET01 pppd[16143]: Connection terminated.
Aug 29 19:47:10 NET01 pppd[16143]: Modem hangup
Aug 29 19:47:10 NET01 esmith::event[16760]: lsm stop/pre-start, process 17241
Aug 29 19:47:10 NET01 esmith::event[16760]: [INFO] lsm has been started
Aug 29 19:47:10 NET01 esmith::event[16760]:
Aug 29 19:47:10 NET01 esmith::event[16760]: Action: /etc/e-smith/events/actions/adjust-services SUCCESS [0.265193]
Aug 29 19:47:10 NET01 esmith::event[16760]: Event: nethserver-firewall-base-save SUCCESS
Aug 29 19:47:10 NET01 esmith::event[16758]: Action: /etc/e-smith/events/trusted-networks-modify/S94firewall-adjust SUCCESS [2.232279]
Aug 29 19:47:10 NET01 esmith::event[16758]: Event: trusted-networks-modify SUCCESS
Aug 29 19:47:10 NET01 esmith::event[15439]: Action: /etc/e-smith/events/interface-update/S95trusted-networks-modify SUCCESS [2.321726]
Aug 29 19:47:10 NET01 esmith::event[15439]: Event: interface-update FAILED
Aug 29 19:47:14 NET01 pppoe[16144]: Timeout waiting for PADO packets
Aug 29 19:47:14 NET01 pppd[16143]: Exit.

It seems that your connection is not PPPoE. Honestly, I don’t have experience on FTTH, I just searched google for the above message.
Could you share with us the instructions given by your ISP?

My ISP just gave me the following Data:

User: username.fiber.providername
PW: Secret

And some login Data for VoIP (Registrar etc.)

Although they gave me instructions how to setup my Fritzbox 7490. When i´m trying to connect via Fritzbox i don´t have any Problems.
I got a simple public IPv4 Adress from my ISP when i connect via Fritzbox.

No idea?

No idea, really. Maybe the instruction for the fritzbox could help. You could try searching for centos and ftth and/or ask your provider if they have instructions for centos.

Okay thank you.

Another clue may be that instead of PPPoE it may be VLAN. Without having FTTH and a FritzBox, I scanned some Telkom support pages (translated from German) and there was discussion about setting VLAN settings in Windows.

Just a thought.

3 Likes

A VLAN would explain why NethServer didn’t see PADO packets.
Probably you put us on the right track.

EDIT
Something like this:
http://www.dslreports.com/forum/r29358085-VLAN-Tagging-on-Tomato-for-FTTH

Oh yes! I forgot the VLAN ID! My ISP gave me an VLAN ID that i entered in a deeper option at the Fritzbox so i forgot about it.

Sorry for this missing info!

So i have to configure my Internet Interface as a VLAN? And where i have to enter the login data which i got from my ISP?

AFAIK, vlan tagged pppoe is still unsupported by the web gui.

With the help of @Nas we tried to make it work. See this thread:

Please, try to follow the instructions in that thread and let us know. Thank you.

1 Like

Okay thank you guys. It works!

This is how:

  1. Setting up PPPoE Interface via WebGUI
  2. Typing this parameteres to the command line:

db networks set eth1.500 vlan role pppoe
db networks settype ppp0 xdsl
db networks setprop ppp0 role red user test Password test
signal-event interface-update

When you get an authentication error in /var/log/messages make sure that your eth1 Interface has no role. Command for that:

db networks setprop eth1 role ‘’

The only problem i have is that my Internet connection is slowed down. I runned a lot of speedtests directly on my NS Server and it never gets more than 100Mbit/s which is less than half what my ISP is offering me.
Connecting the FritzBox i got over 200Mbit/s.
Does anybody know why?

I just searched for this problem and found this: NS Throttling Internet Connection

But i don´t have installed the IPS Software.

Any other ideas?

I already checked my NIC - it can manage 1Gbit connections. But maybe it´s a limit from driver or someting else?

2 Likes

The category of the network cable?

It´s a complete Gbit Infrastructure. All switches all cables all NICs i checked everything. Lowest Network cable is Cat6.

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: off (auto)
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes
[root@NET01 ~]# ethtool eth1
Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 1000baseT/Full
10000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: off
MDI-X: Unknown
Supports Wake-on: uag
Wake-on: d
Link detected: yes

1 Like

Just a shot in the dark: if you have snort enabled, try to disable it.

Thanks for reply! I can´t find any function called “snort” in the WebGUI.

Please have a look in your Software Center. Do you have Intrusion Prevention System installed?´This is what Giacomo means.

Snort is an IPS and you don’t have it installed.
I guess the performance problems are related to the PPPoE implementation.
As you know, I’m not an expert. Reading what I found on the net, I’m not sure if we can use a better/faster implementation (or maybe we’re already using it).

It seems that you could try adding the following line to /etc/sysconfig/network-scripts/ifcfg-pp0 and then restart the connection with service network restart:
LINUX_PLUGIN=/usr/lib64/pppd/2.4.5/rp-pppoe.so

2 Likes

Entering “LINUX_PLUGIN=/usr/lib64/pppd/2.4.5/rp-pppoe.so” in the ifcfg-ppp0 file and reloading by “signal-event interface-update” doesn´t have any effect. It just removed the entered line in ifcfg-ppp0.

I said:

  1. add the line
  2. type service network restart

If you use the interface-update event, you’ll loose the manual modification.
If you could confirm that adding that lines it’s the solution, we will make the modification permanent.

Doing so gives the following output:

[root@NET01 network-scripts]# service network restart
Shutting down interface ppp0: [ OK ]
Shutting down interface eth1.802: [ OK ]
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: Determining if ip address 192.168.177.6 is already in use for device eth0…
[ OK ]
Bringing up interface eth1.802: [ OK ]
Bringing up interface ppp0: [ OK ]

/var/log/messages shows:

Sep 1 22:31:37 NET01 adsl-stop: Killing pppd
Sep 1 22:31:37 NET01 pppd[29091]: Terminating on signal 15
Sep 1 22:31:37 NET01 pppd[29091]: Connect time 242.0 minutes.
Sep 1 22:31:37 NET01 pppd[29091]: Sent 214540401 bytes, received 496499639 bytes.
Sep 1 22:31:37 NET01 adsl-stop: Killing pppoe-connect
Sep 1 22:31:37 NET01 pppoe[29092]: read (asyncReadFromPPP): Session 1687: Input/output error
Sep 1 22:31:37 NET01 pppoe[29092]: Sent PADT
Sep 1 22:31:37 NET01 kernel: lo: Disabled Privacy Extensions
Sep 1 22:31:38 NET01 kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Sep 1 22:31:38 NET01 kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Sep 1 22:31:40 NET01 kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Sep 1 22:31:40 NET01 kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sep 1 22:31:41 NET01 ntpd[22574]: Deleting interface #55 eth1.802, fe80::6034:35ff:fe66:3965#123, interface stats: received=0, sent=0, dropped=0, active_time=14522 secs
Sep 1 22:31:41 NET01 ntpd[22574]: Deleting interface #54 ppp0, 130.255.120.150#123, interface stats: received=80, sent=80, dropped=0, active_time=14522 secs
Sep 1 22:31:41 NET01 ntpd[22574]: 212.18.3.18 interface 130.255.120.150 -> (none)
Sep 1 22:31:41 NET01 ntpd[22574]: 146.0.32.144 interface 130.255.120.150 -> (none)
Sep 1 22:31:41 NET01 ntpd[22574]: 46.4.19.10 interface 130.255.120.150 -> (none)
Sep 1 22:31:41 NET01 ntpd[22574]: 178.63.135.195 interface 130.255.120.150 -> (none)
Sep 1 22:31:41 NET01 ntpd[22574]: Deleting interface #53 eth0, 192.168.177.6#123, interface stats: received=14, sent=14, dropped=0, active_time=14522 secs
Sep 1 22:31:41 NET01 ntpd[22574]: Deleting interface #47 eth0, fe80::3463:31ff:fe66:3364#123, interface stats: received=0, sent=0, dropped=0, active_time=24837 secs
Sep 1 22:31:42 NET01 pppd[31048]: Plugin /usr/lib64/pppd/2.4.5/rp-pppoe.so loaded.
Sep 1 22:31:42 NET01 pppd[31048]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep 1 22:31:42 NET01 pppd[31048]: pppd 2.4.5 started by root, uid 0
Sep 1 22:31:42 NET01 pppd[31048]: PPP session is 1723
Sep 1 22:31:42 NET01 pppd[31048]: Connected to d4:ca:6d:01:10:67 via interface eth1.802
Sep 1 22:31:42 NET01 pppd[31048]: Using interface ppp0
Sep 1 22:31:42 NET01 pppd[31048]: Connect: ppp0 <–> eth1.802
Sep 1 22:31:42 NET01 pppd[31048]: CHAP authentication succeeded
Sep 1 22:31:42 NET01 pppd[31048]: peer from calling number D4:CA:6D:01:10:67 authorized
Sep 1 22:31:42 NET01 pppd[31048]: local IP address 130.255.120.150
Sep 1 22:31:42 NET01 pppd[31048]: remote IP address 130.255.120.2
Sep 1 22:31:42 NET01 pppd[31048]: CCP terminated by peer (No compression negotiated)
Sep 1 22:31:42 NET01 pppd[31048]: Compression disabled by peer.
Sep 1 22:31:45 NET01 ntpd[22574]: Listen normally on 57 eth0 192.168.177.6 UDP 123
Sep 1 22:31:45 NET01 ntpd[22574]: Listen normally on 58 ppp0 130.255.120.150 UDP 123
Sep 1 22:31:45 NET01 ntpd[22574]: Listen normally on 59 eth0 fe80::3463:31ff:fe66:3364 UDP 123
Sep 1 22:31:45 NET01 ntpd[22574]: Listen normally on 60 eth1.802 fe80::6034:35ff:fe66:3965 UDP 123
Sep 1 22:31:46 NET01 ntpd[22574]: 0.0.0.0 0698 08 no_sys_peer

The effect is that the Interetconnection on the server still exist but no client can connect to the Internet. Is that a problem with the eth0 interface?