NS7 not full bandwidth

NethServer Version: 7.3.1611


i just installed NS7 on my ProxMox Node yesterday and i´m very happy with it. But today i noticed that i´m not getting my full 200Mbit/s through it. In an earlier NS6 installation the problem was solved by @filippo_carletti here. I also tried his soloution but it did just helped a little bit.

For now i´m making speedtest with about 160MBit/s.

When i´m running speedtests or download big files the CPU load is at 99%. Pingtimes are about >100ms. In my earlier NS6 installation that was no problem - downloading 2GB with 200Mbit/s and ping google with 8ms. I think this problem is caused by a single process (ksoftirqd).

I also disabled bandwithd but that didn´t helped. Any ideas?

I´m running stable 200Mbit/s speedtests with my older router.

1 Like

I think that bandwidth is throttled by lack of resources, probably a combination of proxmox and centos network drivers.
You may need to adjust some settings in proxmox. What ethernet drivers are you using?
Could you try to use a different network emulation in the NethServer VM?

1 Like

Thank you! I will try that…
It´s a little bit complex. If i´m changing network driver in proxmox for the ppp0 network card CentOS is going crazy and doing nothing. I had to copy the config from old interface to the new one. But after that the interface is still not working. I think i will do a complete new installation with other drivers tomorrow.

1 Like

yep thats it… Working with VirtIO (paravirtualized) driver. Thanks!


Thanks for reply.
Remember to mark “solved” the answer that you think helped you.
Good job :+1: