Problem with notification mail

Yes, i’ve tried, it start with a new full backup.
Now backup works regurarly as before the update. :wink:

But i have a problem with mail notification: no mail is received !

Our new mailserver is on microsoft office 365 server. In the spam nothing is received.
Our “nethserver” server hasn’t a public domain. It’s part of the internal network.
I’ve tried also with gmail and aruba mail address with the same result, no mail are received.

I suspect that the mail are rejected by the mail server because it doesn’t contain all data like dkim, spf… data that cannot be inserted by a server that hasn’t a public domain.

How to control that the mail has been sent ?
Can the mail been sent using an external service to be sure that the mail contain all data and sign to be marked as regular mail ?

I think you have to add an external mail-domain to your nethserver-mail-server.

I read the documentation.
Do you talk about configuring a smarthost ?

You need to configure a smarthost if your server doesn’t accept mail from NS.
You can find more info inside mail log: /var/log/maillog.

1 Like

Can smarthost be connectet to a mail server with startls security ?
There is no way to set the encryption used by the mailserver.

Take a look at this: HOWTO: Use SSL/port 465 in smarthost
Is it your scenario?

1 Like

I had some problems to use Office 365 smtp server as smarthost to send mail from Nethserver…

You can configure Office 365 smtp server as smarthost on 587 port but Office 365 wants that the sender is the exact mail address tied to the credential’s user.

So it’s better that you use another smarthost server…

“Our mail server” is on office 365.
I haven’t any other mailserver.

Ok, “Your mail server” is on Office 365 but Nethservice has to send the notification mail somewhere.

If you use direct-to-mx connection (without a smarthost), probably (almost sure) that Office 365 server blocks connection because the mail isn’t sent from a trusted IP or from a fake domain or from a MX without SPF (already seen).

So, you have to use a smarthost.

You can use one of your Office 365 to setup a smarthost on Nethservice, but you probably have the problems that I mentioned in the post above.

You can watch /var/log/maillog to see what happens when you sent mails from Nethservice and to debug the issue.

1 Like

Yes it can! The STARTTLS is enabled by default. IIRC an option forces it to disabled.

See also

Great news !
So i haven’t to use stunnel.
Next time i will be in office i will try to configure the office 365 mail server as smarthost.
I will report if it works :wink:

P.S. In the documentation, isn’t very clear that STARTTLS is enabled by default.

I’ve configured on port 587 and works!
The sender mail address had to be the same used to login on smtp server.

Now it’s time to update duplicity to a newer version in the nethserver repo (Ver 6.9) :wink:


Thanks for your reply.
Can you mark this thread as solved please.