NS8-Matomo Module

Dear All, I am, happy to Announce the Initial Vrrsion of Matomo being available. as an ns8 module.

To install, simply use

add-module ghcr.io/compgeniuses/matomo:latest 1

To update, simply use

api-cli run update-module --data '{"module_url":"ghcr.io/compgeniuses/matomo:latest","instances":["matomo1"],"force":true}'

then Login to the Web Dashboard and module settings, then add your hostname.

the module should be configured and running

Visit the hostname to finish on the configuration

The database configurations should be pre-filled Automaticall,

All you have to do is click next.

Deine your super user credentials

Define Website URL settings

you should have your new matomo dashboard ready for use

kindly test and share any challenges you ight encounter

5 Likes

Hello @danb35 since seen you’re testing installing matomo on NS8 here: Install wordpress to NS8 - #23 by danb35

Would you kindly be open to help in testing the matomo module?

@oneitonitram , well that worked very well. It installed flawlessly. I need to add methods to a new website later, but for now, the install and config worked like a charm!

Cheers!

1 Like

Thank you @LayLow for testing, could you kindly help test backup and restore.
Clone and restore.?

I just installed it on my server, but I can’t find where to go to configure it. It doesn’t appear in software center → installed, and I don’t see it elsewhere in the cluster-admin pages. What am I missing?

All softwares not installed from the software center are available on the top right app menu

image

4 Likes

Sure enough–I hadn’t realized that. Much easier way to get to them than I’d been using.

1 Like

FYI:

It seems that the ‘force https’. settings keeps defaulting back to ‘Off’. Despite setting it several time (and save) it keeps coming back as ‘Off’

HTH

1 Like

Works!

ps: I used WPCode ( https://wpcode.com/ ) to embed the Java script ino the Wordpress site. (No commercial intent)

Yep, same here. It seems to do it, but the toggle keeps turning off.

will look into it…

Hi @LayLow

I assume that is why, when I tried to reach Rouncubemail and WebTop, TOR was complaining about the site not having security https.

I never checked back that NS8 parameter.

Michel-André