Nextcloud - Remove Collabora and Install OnlyOffice

Hi guys

I want to uninstall Collabora e install Only Office on my Nextcloud on Nethserver

How can i do that?


To uninstall collabora:

yum autoremove nethserver-collabora

Please check what’s going to be removed before confirming the removal.

I think you need to remove/disable the richdocuments app (Nextcloud Office app) manually in Nextcloud apps page.

Now you’re ready to install onlyoffice, check the wiki for instructions.


I uninstall collabora and install OnlyOffice Quick Install follow this guide:

When i click on the save button i get this error:

But if you go here https://collabora.mydomain.tld the onlyoffice server can reach

Please check out the troubleshooting section in the wiki and scroll to “violates local access rules” error.

1 Like

if i add this command:
‘allow_local_remote_servers’ => true,

On /usr/share/nextcloud/config/config.php

After reboot the server i receive this error:


If i remove this ‘allow_local_remote_servers’ => true, from the config.php file and reboot the server the error remain, now i can’t access nextcloud

Please check again, every comma is important.

You may share the relevant part you changed, so maybe we can find the error…

My bad.

Now i get this error

if i go here: https://collabora.mydomain.tld/healthcheck i see this:

Do you use the same collabora domain for onlyoffice?
If there still exists the /etc/httpd/conf.d/zz_collabora.conf file, please move it away and restart httpd.
Could you please explain step by step what you did?

Let’s also check the onlyoffice config:

config show fw_onlyoffice

yes i use this domain collabora.mydomain.tld for onlyoffice server, i rename the file:

/etc/httpd/conf.d/zz_collabora.conf to /etc/httpd/conf.d/zz_collabora.conf.bak
and restart httpd but i get the same error.
this is the output of this command config show fw_onlyoffice:

I uninstall the collabora whit the command you give me, and install OnlyOffice follow the wiki guide Quick Install.

Do you use a valid cert like letsencrypt?

Onlyoffice uses systemname.domainname by default to be reachable.

If you want to use a special domain you need to configure it:

config setprop fw_onlyoffice host DOMAIN.TLD

I’d like to know the exact steps you did because maybe the wiki entry was misinterpreted.

i use Nginx Proxy Manager and ssl with let’s encrypt

Sorry, I don’t know nginx proxy manager so I can’t help. I don’t think it’s supported within NethServer. Did you install it manually?

Before i install OnlyOffice i use Nginx proxy manager to work with nextcloud and collabora without problem.

Nginx Proxy Manager is installed on a container Docker in another machine not on nethserver

Did you try to enable cache support or websocket in nginx proxy manager?

Did you configure the collabora domain in onlyoffice?

yes i try now:

but i receive tha same error:

Could you try port forwarding 8082 to the NethServer instead of nginx reverse proxy?


I tried nginx proxy manager which is really a nice software to manage nginx redirection/reverse proxy inlcuding letsencrypt.

nethserver-onlyoffice autoconfigures the port to 8082.
I needed to remove the port (:8082) in the onlyoffice docs address because the nginx reverse proxy only listens on default HTTP(S) ports.

I’m going to update the package to be able to leave the port in Nextcloud autoconfig…

1 Like


Yes is very a nice softwaere Nginx Proxy Manager i use for protect portal http redirect to https also…

Anyway i test internal and it works so the problem is only if i access to nextcloud from external network.

So i disable the proxy host in NPM and Port forward 8082 on the firewall and now it works.

Let me now when you apply the modify to the package so i put back the NPM

Thanks Markuz

1 Like

@mrmarkuz Is it necessary to remove the Collabora for installing onlyoffice. I was about to install onlyoffice, but stopped after reading this thread.

a) I want both collabora and onlyoffice installed to test the performance. For me the collabora is slow, and tends to overload the server, if the size of the document file is big.

b) Onlyoffice via the markuz repo is 6.4.2 in the nethwiki

yum -y install

But the latest version is 7.0. there is a warning but it may break something so choose wisely.

c) Pls clarify that there is no need to install nodejs.

No, both apps work on the same server.
You may need to disable one app in Nextcloud to test the other one because both want to open the same file types.

7.0.1 should work. It’s easily possible to downgrade to 6.4.

It’s not needed anymore. I’m going to update the wiki page.


A post was split to a new topic: Onlyoffice cannot be reached