Nextcloud - Remove Collabora and Install OnlyOffice

the best way to work around using both apps, make onlyoffice open opendocument format, like docx, and collabora(nextcloud office) to open the odt format. because each are stronger in those respective formats, unless explicitly defined by users.

1 Like

Hi @mrmarkuz

Do you edit the onlyoffice package to delete the 8082 port so i can use Ngnix Proxy manager?


Yes, I hope I can provide the update soon.


It’s a modifiy can i provide by my self?

Because the certificate of Let’s Encrypt generate on Nethserver has expired on 11th May and i can’t request a new one because the port 80 and 443 is forwarding to the docker with Nginx Proxy Manager.

If you tell me what i need to edit for make this change i appreciate it.
Thank you

You could disable NPM just to get a cert and re-enable it again.

As a workaround you could edit line 118 in /etc/e-smith/events/actions/nethserver-onlyoffice-conf to remove the port:

occ config:app:set onlyoffice DocumentServerUrl --value="https://$dshost/"

Apply the change:

signal-event nethserver-onlyoffice-update


Please test the update:

yum install

To change the port to default HTTPS port:

config setprop fw_onlyoffice NCPort 443

Apply the config:

signal-event nethserver-onlyoffice-update

Now the OnlyOffice app should work with NPM.

i put the 3 command you mention above but now i have this when i try to access to nextxcloud:


You posted the same error here and it seems you already solved it.

I tested it again including NPM and it worked.

My router port forwards the default web ports 80 and 443 to the NPM VM. I disabled the Onlyoffice port forward to the NethServer port 8082.

In NPM I configured 2 proxies including letsencrypt cert:

  • onlyoffice.domain.tld points to my internal NethServer IP, using https, port 8082
  • domain.tld points my NethServer, using https but port 443

Now I can reach both, OnlyOffice via https://onlyoffice.domain.tld and Nextcloud via https://domain.tld/nextcloud

The Nextcloud app is configured to use the FQDN like server.domain.tld, to change it to use onlyoffice.domain.tld I needed to execute

config setprop fw_onlyoffice host onlyoffice.domain.tld NCPort 443

signal-event nethserver-onlyoffice-update

It’s explained in the wiki.

Now the “Save” button in the OnlyOffice app settings should work without issues. If it doesn’t work, please post the error message.

1 Like

Hi i rollback the snapshot and everything it back to works. this is the actual conf of fw_onlyoffice:
I think the nextcloud broken when i do this command:
config setprop fw_onlyoffice NCPort 443

A working snapshot is always good to have.

This command just adds the NCPort 443 to the config db.
The NCPort allows to change the port in the Nextcloud Onlyoffice app. Before the update the port was hardcoded to 8082.

When the configuration is applied, the Nextcloud app is configured using the settings from the config database like <host>:<NCPort>

Did you add the domain you are using in NPM to the config by adding the host property? If you click the save button, does it work or do you get an error message?

[root@server2 ~]# config setprop fw_onlyoffice host onlyoffice.domain.tld NCPort 443
[root@server2 ~]# config show fw_onlyoffice 

Can you reach Nextcloud and Onlyoffice via NPM?

Hi Markuz

The problem is when i do these 3 steps:

  1. yum install
  2. config setprop fw_onlyoffice NCPort 443
  3. signal-event nethserver-onlyoffice-update
    when i try to reach nextcloud web page i get this:

So how can i check this:
If i can’t reach Nextcloud?

Can you reach Nextcloud by using the IP address instead of the name?
Is the NPM reverse proxy configured correctly to point to the right Nextcloud domain?

Hi this is the config on NPM:

i can’t reach nextcloud by using IP address

OK, it seems Nextcloud isn’t there.

Did you configure a custom virtual host in Nextcloud?

Please note that after the configuration of a custom virtual host, Nextcloud will no longer be accessible from the default URL https://your_nethserver_ip/nextcloud .

Does Nextcloud work again if you rollback to the snapshot?

Please also share the Nextcloud config:

config show nextcloud

Yes this is the config VirtualHost in Nextcloud:

If i rollback the snapshot Nextcloud work yes

To simplify things, please try without enabling the custom virtualhost in Nextcloud so you should be able to reach Nextcloud at https://cloud.domain.tld/nextcloud

disable virtualhost i can reach with this URL:

1 Like

Does this work too?


now i try to do the 3 steps and see it works?

1 Like

Yes, please try it.

Ok now i can reach nextcloud and collabora

But without virtual host now when i go to cloud.mydomain.tld i redirect to this url cloud.mydomain.tld/nextcloud/ i don’t want nextcloud in the url infact now the nextcloud desktop app not working because i configure with only this url cloud.mydomain.tld

Anyway OnlyOffice give me an error: