Nextcloud mail app config error

Agreed. While some clients are more or less sensitive to the current ACL, even as an user it looks odd to not be able to list the root while the child nodes are.

Is there any solution to configure mail within nextcloud in the mean time?

@mrmarkuz gave me this solution ad it worked for me

doveadm acl set -A Public authenticated lookup read


Hello All,

could someone (@mrmarkuz perhaps) explain what this command will do on my Nethserver:

doveadm acl set -A Public authenticated lookup read

I’m very interested in getting my Nextcloud Mail to work as well. But I’m hesitant to run anything on my Nethserver that is not standard (or done at install or during update). What, if any, are the risks to running this command on my Nethserver…and what would be the command to back out whatever this instruction is doing?

Thank you.

1 Like

The command is related to acl of Dovecot, the MDA of NethServer. You can look into Dovecot documentation for clarify yourself of the effect of the command.


Maybe disabling shared mailboxes is the safest way without changing anything.

The doveadm command just sets an additional read right for the Public folder. I don’t think that any client has a problem with that.

doveadm acl set -A Public authenticated lookup should reset the Public folder permissions as they were before.


how is this done?

Server manager :

Remove the public mailboxes. But I believe that @mrmarkuz 's fix is the definitive answer to this bug and that it should be included in the next releases.

1 Like

how comes your dashboard has menu option i have to go to apps to get?

From the Applications sections there’s an “Add shortcut” app option.

It looks like nextcloud finally got a fix :

If someone could test ?

EDIT : That’s for nextcloud 20. We’ll have to wait for the NS upgrade.


thats “funny”…
Yesterday I installed Nextcloud for the first time. After I couldn’t connect the mailboxes (although I hadn’t set up any public mailboxes), I uninstalled the package because I thought a reinstall would solve the problem. Now after a reinstallation I am missing the possibility to install any app, including the mail app.

Still not working!
Installed NethServer 7.9.2009
Updated Nextcloud 20.0.4

Mail application does not work with local email addresses.
The solution is the same as before:

  1. Remove Public mailboxes
  2. doveadm acl set -A Public authenticated lookup read

I am still not able to configure the nextcloud-mailapp with a self-sign-cert…
Could you please post a few screenshots of the mail-configuration?

Well, I tried again and made some tests. Here are my findings :

Mail v1.7.2 - NC v20.0.4

  • Connecting in “auto” mode doesn’t work : Unexpected error during account creation. I don’t really understand why but once I configure the servers manually (not using localhost but fqdns) it finally reports Request failed with status code 500 but I can see in the logs that the connections succeeded. Just click on the Mail icon to reload the page and the account appears and starts to index.

EDIT : Scratch the paragraph below :

  • Beside that problem, the Public mailboxes, wether with access to the user or not are not a problem. The client successfully connects to the accounts and ignore the Public Mailboxes it doesn’t have access to, as expected.

  • If the now famous command doveadm acl set -A Public authenticated lookup read is not issued, the account creation fails with error 500 and one can notice that message in nextcloud.log : IMAP error: You do not have adequate permissions to carry out this operation. Therefore it looks like the bug is still not fixed, I’ll report it to the developper.

Anyway on my entry level shared server with 2gigs RAM the indexing is really a memory hog and I’m still not able to use it. So I’ll not investigate further right now.


Mmmh… thinking twice, I should check wether the “doveadm acl set -A Public authenticated lookup read” command has not been issued in the past on my system… Stay tuned.

Confirmed : the bug is not fixed. I edited my post above.

1 Like

For setting up nextcloud-mailapp, I used

I also added to config.php
‘app.mail.verify-tls-peer’ => false,

doveadm acl set -A Public authenticated lookup read

do not delete Public mailboxes

I am using Let’s Encrypt Authority X3 certificate


Hi Bulat, thank you vy much. I was able to configure the nextcloud-mail on nethserver 7.9 with it… :+1:

1 Like

Sorry for necroing this topic, but I am trying to add nethserver mailbox hosted on the same server as nextcloud, but no avail. Tried deleting public mailboxes, adding the read permisison through the doveadm command.
I just can’t add a nethserver mailbox.
I added an external mailbox and that works just fine (
What should I look for to fix this since I really want to be able to add a nethserver mailbox hosted on the same server.

What is the location of this config.php file?
found it: /usr/share/nextcloud/config/config.php
Ok, got it working by adding the line ‘app.mail.verify-tls-peer’ => false,
Don’t forget the trailing comma!! (I did and it didn’t work without it… )