Nethserver Configuration Backup

NethServer Version: 7.7.1908
Module: Backup (Cockpit)

Hello all.

I have searched the forums but was not able to find a topic that addressed my situation. I can’t get Nethserver to create backups of my system configuration. I will select the “Run now” button with a Successful run notification, however the backed up configuration doesn’t show in the Details section nor does it list anything to download. I have my nethserver setup just the way I want it, but I’m afraid that if something goes down or breaks, I won’t have anyway to recover my setup.

Maybe reinstalling Nethserver is a solution however, I can’t risk it considering I have no configuration backup to restore. I’m all ears. Thanks for your help!

Can you show detailed screens from the “Configure” button.

Here is the configuration Button

The problem is similar to this one, but was fixed long ago:

Make sure you have the latest updates for nethserver-cockpit\* packages (no need to enable testing repo):

1 Like

Thanks dnutan. I followed another post enabling “testing repo” hoping it would fix my issue. However I’d rather not have testing repos active. I would like the server to be as stable as possible. How do I remove testing repo? I really am not as ignorant as I seem. I have plenty of experience with Debian based distros. I’m a fish out of water with Redhat/CentOS based. :flushed:

If you just enabled testing repo at runtime (yum update --enablerepo=nethserver-testing ...) no further steps are required, as it is just for that one execution (unless you edited the repo file).

I did not edit the repo file. Thank for your help and input.

Okay, so here is my …api/system-backup/execute file. It looks to be updated with the version that is on GitHub…

    /sbin/e-smith/backup-config -f
    if [ $? -gt 0 ]; then
        /usr/libexec/nethserver/backup-config-history push -t snapshot -d "$(_get name)"

Anything else I need to be looking at? Maybe I should clear out my backup folder perhaps?

No. Just try if config backup works.

This bug has been already solved. Please update your packages with:

yum clean all && yum update -y nethserver-cockpit\*

So far I’ve verified code from gitlab. I’ve done a yum clean all and update. Rebooted. Still no joy. It is still showing 0 backups after using the run now button. Just for posterity here is my /var/lib/nethserver/backup folder contents…

drwxr-xr-x.  6 root root  260 Jan 17 20:23 .
drwxr-xr-x. 15 root root  211 Jan 16 23:45 ..
-rw-r--r--   1 root root  68K Jan 17 01:05 acls.dump
-rw-r-----   1 root root  27K Jan 17 20:23 backup-config.tar.xz
-rw-r--r--   1 root root 4.6K Jan 17 20:23 backup-config.tar.xz-content.md5
-rw-r--r--   1 root root   82 Jan 17 20:23 backup-config.tar.xz.md5
drwxr-xr-x   4 root root   56 Dec 23 23:59 duplicity
-rw-r--r--   1 root root  936 Jan 17 20:23 package-list
drwx------   3 root root   29 Jan 11 01:05 restic
drwxr-xr-x   2 root root 4.0K Jan 17 10:48 restore
-rw-------   1 root root  18K Jan 17 20:23 secrets_tdb.dump

The weird part is that the backup-config.tar.xz files were updated with the timestamp of my attempt to backup. Yet the GUI does not show any backups.

Your server is missing /var/lib/nethserver/backup/history/ directory:

drwxr-xr-x. 2 root root      6 Jan 18 09:56 history

This can be verified with:

[root@server ~]# rpm -Va nethserver-backup-config
missing     /var/lib/nethserver/backup/history

Please, run the following command and try again config backups:

 yum update nethserver-backup-config

If there’s nothing to update and history directory still doesn’t show up, run:

 yum reinstall nethserver-backup-config

I officially nominate dnutan for the 2020 You Rock Award.