NethServer 7 RC3 instance in Virtualbox - Problems accessing the web-admin interface from host

NethServer Version: 7 RC3

I have installed NethServer in Virtualbox but I am having problems accessing the web-admin interface from host.

I followed this tutorial but it didn’t help. I know it is for version 6.7 but I thought the internet settings would not differ.

So I set the Network adapter as bridged/eth0 and the second as Internal Network/intnet. When the installation is finished I switch the second adapter to Host Only/Vboxnet0.

The host Opensuse Leap 42.2 is connected to the internet through ethernet.
The Firewall on Host is stopped. I am not sure if there is a Firewall on NethServer guest by default.

To check if everything was ok on my end I installed Zentyal 5. But here I left Internal Network/intnet. I did not switch to Host only.
After stopping the Firewall on Zentyal all connections were ok in host and in guest.

Is there a Firewall feature in NethServer by default? Something that might be stopping the host from connecting to the web-admin interface

I am new to this so I would appreciate simple terminology.

Thanks a lot in advance.

Just a few more details to make things easier for whoever wants to help.

From Guest. ifconfig.

From Host. ping
Works fine.

From NethServer: ping
ping Name or service not known

From Firefox in Host.
Firefox can’t establish a connection to the server at

Host-only Network Details:
IPv4 Address:
IPv4 Network Mask:
IPV6 Network MAsk Length: 0

Thanks for your time.

From Host: ifconfig

Hi @Christos

I see that in your host you have two active connections on IP 192.168.1.x (I think cable and wifi). Which one is connected to the internet?

which dns is set to nethserver? you can see it with:

config show dns
1 Like

Hi @enzoturri

eth0 is currently connected to the internet

config show dns gives:


Thanks for helping

try to set dns to in nethserver and ping
after try to disable wifi in your pc (host)

How do I set the DNS to Is there a command to do that since I don’t have access to the web interface?

Can you access your nethserver guest terminal from the virtualbox console?

From shell

config setprop dns NameServers
signal-event interface-update
  • From NethServer guest terminal I run the commands.

  • Then in guest: ping
    It works! I have internet in guest.

  • I disable the wifi in host.

Still no access to the web interface.

  • Reboot guest
    Still no access to the web interface

Ping guest from host works fine though and I also have internet in guest.

ifconfig in host:

Hi @FixitFelix

I am not sure how to access the guest terminal from Virtualbox console. Do you mean with VBoxManage?

try like this from shell

netstat -a | grep 980

If the system return a row the web console is active.

Momentarily stops the firewall

systemctl stop shorewall

trying to access the web console.

if it does not work to remove virtualbox vboxnet0 the interface and make sure you have a single network adapter bridged on your network card (eth0).

If it does not work from shell:

yum install lynx

(Confirm with y installation)

and run:


It 'a character browser
(Confirm with y or return the certificate request)

  • netstat -a | grep 980
    Returns a row

  • systemctl stop shorewall
    Returns a row

  • Trying to access the web console
    Does not work

  • Removed virtualbox vboxnet0 interface and made sure I have a single network adapter bridged on my network card (eth0)
    Does not work

  • Installed lynx

  • lynx

Hi Christos
I’m a newbie to Nethserver myself, but have just done a similar thing to you installing NS on VirtualBox and have it set up at the moment. If you want to compare any settings, processes running etc, I’d be happy to post whatever you want from my system.
I’d suggest (just to keep it simple) you do the install with just a single LAN interface and get that running before adding an extra interface.

Hi dwj

Thanks for your help

So you mean instead of using both ethernet and wireless use just one of them?
Interesting, I wonder if that’s the reason. I thought that even if I have both only one is used at a time.
I will try reinstalling.

Yes, I would appreciate it if you could send over any settings you had when you installed. Especially the network ones. Did you have only one LAN and then you set the network to bridged (eth0 or wlan0)?

On the network configuration during the installation did you change anything?

And also did you enable PAE/NX on the processor settings? I don’t think that has to do with the network but I read somewhere that it helps.

Hi Christos,
What is the configuration for the Guest ?
Show us a screen of ifconfig because I only see one adapter in the post above.


Hi Ctek,

ifconfig in guest:

Thanks for your help

Christos, you need two adapters in your NS.
I see only one. In the tutorial there was another adapter set for the virtual machine.

Add another adapter for the NS and then run all the steps from there and let me know if you can reach the guest from the host.


Hi Ctek, I installed following the tutorial. I used two adapters. But it didn’t work. I wonder if it was because I had two LAN interfaces.

Since that tutorial has worked for others what I will do is reinstall with both adapters but having just one LAN interface. I will just use the ethernet.

You need one adapter for “internet” and another for "Lan"
otherwise it will not work