NethServer 7 RC3 instance in Virtualbox - Problems accessing the web-admin interface from host

Makes sense Ctek. I’ll do first with one LAN interface (ethernet) and when/if everything works I will add another adapter for the WiFi.

you do not need to add it for wifi.
The virtual adapters are not bonded to your physical ones.
You can add as many adapters you want (or vbox allows)

try with only two adapters for your NS machine.
and run the steps one by one from the tutorial so you know where you get a different message than the one from the tutorial.


Thanks Ctek

It’s a bit difficult to follow the tutorial in some steps because it is meant for an earlier version of NethServer.
For example there is no red and green adapter choice during the installation in the 7.3 version. I mean not in the way it is described in the tutorial. Although it might be obvious what to do for experienced users to me it is confusing.

Reinstalled again using only one LAN interface but two adapters. Still nothing.

Hi Christos,
What do you mean “only one LAN interface but two adapters” ?

Virtualbox NS machine should have a WAN (internet) and LAN (intranet) adapter.

And the LAN adapter should be used as internal network. The WAN adapter should be bridged with your real physical device so this way NS will be in the same network as your machine.

Sorry I am probably using wrong terminology. By one LAN interface I meant just ethernet or just wifi connection. Two adapters I meant one bridged/eth0 and the internal network/intranet.

Well since nothing worked I downloaded and installed NethServer 6.8. I followed the tutorial and I was able to access the web interface.

I thought that was it but today I got this when I boot the NS guest:

BUG: soft lockup - CPU#0 stuck for 67s! [crond:4588]

And it happens that when I start NS guest, the internet in host does not work.

I got a snapshot yesterday before I started the configuration in the web interface (after the installation). With the guest being on. I had internet in host, I could ping host from guest and vice versa but there was no internet in guest.

When I restore the snapshot now I don’t have internet in host or the guest although I can ping the guest from the host and vice versa. When I switch off the guest machine I get internet.

1 Like

Hi Christos
Yes I definitely used “bridged”.

Definitely only used one network (and I used my eth0 - ie the LAN of my host, not WLAN).

PAE/NX seems not to matter. I noticed that if you select “Other Linux” when setting up the virtual machine, it won’t turn on PAE/NX, but if you select “RedHat” it does. I built system both ways on VB and it worked fine.
During installation, sometimes I set it to a static IP but other times I left it as dynamic, and then changed it after I got to the web interface, so I wouldn’t think that is your problem.

Have included screenshot of VB config. That should eliminate any VB config issue.

It was a very smooth install for me. Out of interest what is your host system (Linux? Windows?). Maybe there’s some subtlety in what VB looks like to the Nethserver install. My host is Win10.

I’d still recommend get one interface in VB going, then add others.

1 Like

Thank you dwj

My host system is Linux (Opensuse Leap 42.2).

How did you get access to the web interface from host after the installation?

I installed with the configuration you had. Here is a screen-shot just in case I missed something:

Without changing any settings here is the output of ifconfig in NS guest:

No internet in guest.

And here is ifconfig from host:

I can ping from host but I cannot access the web interface.

Is there anything else that you did after installing to get access from host?

Thanks a lot for helping. I really don’t know why it doesn’t work for me.

You are insisting in using only one device in the Guest…
There can’t be LAN and WAN on the same device… no matter what you try.

I think you are confusing between physical interfaces (the ETH0 and WIFI in your laptop) and the virtual ones in VBOX.

They are not related. You can have up to 4 devices in the VirtualBox machine.

You only need to bridge your physical device (eth0) to the WAN device in the Virtual box.

Please stick with the default settings as explained in the documentation.
If by any chance you try to achieve something else then say what you want.

Think about how NS has to work: WAN -> NS -> LAN.

If you put only one adapter then it can be either WAN or LAN not both!
So if you assign it as WAN the you can’t get to webconfig.
If you assign it as LAN then you can’t have internet…

Hi Ctek,

I am just trying different things even if they don’t make much sense to me. I managed to get it working with your tutorial and NS 6.8 but next day without doing anything I just got that bug I mentioned. No idea what that is.

Since dwj has it working in another way I wanted to also try that so I see what happens.

There must be something I am doing wrong. I have reinstalled close to 10 times in different ways and I just can’t get it to work. Weird.

It is really strange that you made it work and then it did not…
Maybe an update ? or a dhcp lease…?

Yes I don’t know what that could be. I don’t think it is on the NethServer side. Even the Zentyal guest doesn’t have internet now. Even though I disable the adapters on other guests.

I wonder if my router does something. If it blocks something. I have no idea.

1 Like

Is there something else on your that is
How does your Nethserver vm get an address, you’re setting it or dhcp from the lan’s router? What is the lan’s router ip? Is it the gateway? As many times as I’ve done this using virtualbox, it’s not a bug, it’s something in your setup.

The router ip is But I have tried with other addresses and I get the same result.

NethServer vm gets the address dhcp.

Router LAN ip address is

"Is it the gateway?"
Not sure what you mean, sorry. How do I find that out?

If the router ( for the lan ( that the host ( is on is the same ip as the ns vm, where is your ns vm with a bridged adapter getting its dhcp provided address of from?

Your lan’s router is unlikely to respond on port 980, which is where your browser request to is probably being routed to.

The above is what I can gather about your setup after skimming through all the posts.

You should probably draw out a logical map of your network.

I tried with other addresses as well and nothing worked. The address was there because I left everything default. I changed almost nothing.

I just installed NS 7.3 on VMWare without a single issue. Everything works fine.

It must be something wrong with the configuration in Virtualbox. I must have messed up something. I’ll see what I can do with it.

Strange thing is that I use Windows7 almost daily on VB without any issues.

I just installed NS 7.3 in Virtualbox and wanted to post the settings I changed and steps I took.
I’ll skip the first few steps involving adding the iso to virtualbox and getting it installing.
During the install I set the interface to DHCP.
I left all network settings in v-box default during the install process.
Once installation was complete, I went into v-box manager and then into the settings of the NS instance.
I selected Network, since all settings were left as default there is only one adapter, and I clicked the drop down at
"Attached to:" and changed it to “Bridged Adapter” and then click the Name drop down below it and select the adapter that you are connected to the internet on. This will allow your vm to pull an IP via dhcp from your internet source through your active network adapter.
Next click OK, then restart your VM of NS. When your vm comes back up log into the shell and run ifconfig to see what ip it pulled. Then you should be able to hit the web interface from your browser at https://<the.ip.>:980
I can add screen shots of my v-box network settings if it will help.

1 Like

Hi FixitFelix,

Where did you set the interface to DHCP? There is an “automatic DHCP” option (default) and “DHCP addresses only”. I suppose you left the default option, am I right?

And also did you connect enp0s3 to the internet in the network configuration during the installation or did you just leave it disconnected as it was by default?

Thanks for you help

Hello @Christos,

During the installation setup in the VM. Here are my steps:
I chose NethServer Interactive Installation,
next complete the installation summary including Localization section, Software section, but in the system section click on Network and Hostname where you will enable the ethernet connection (enp0s3) and it will pull a dhcp address off of your host - not your network. However if you want to make sure it’s in dhcp you can click on “Configure” in the lower right corner, then click on IPv4 Settings, and you’ll see that the Method is set to Automatic DHCP.
I apologize. Looking back at my last post it was misleading saying that I set it to dhcp.
Once the network is active then you should be able to continue with the install.
And by default it does look like it is connected.
I left the default v-box network settings during the installation and didn’t change them until after the installation was complete.
I’m sure the v-box network settings could be configured prior to the install, but out of habit I always configure the network after installation when using v-box to save confusion.

Hey FixitFelix,

Thanks a lot. Leaving network settings default and then changing it to bridged/eth0 after the installation was complete worked. To get a red interface I set a second adapter to internal network/intnet (green). For some reason setting it to host only adapter messes it up. I am doing something wrong there.

Not sure if I need to try fiddle with it so Host only adapter works as well or just leave it as it is now since it works.

Anyway many thanks to everyone. Hope everything remains in working order. Fingers crossed.