NethSecurity Beta 1 is ready 🛡

Hello, we are testing beta1, we wanted to know if the BanIp and object creation menu will be implemented, at the moment we cannot find them.

That’s an amazing plan!

Hello and welcome!
Thanks for testing the beta :wink:

Banip is already implemented, you can find the documentation here:

A simple UI for threat shield will be out with Beta2.

I’m not sure to get this one. What are you searching for? Please explain your usage scenario and let’s see if it’s already covered.

in NethServer Enterprise 7.9.2009
is Firewall - Oggetti - Host or Group Host ecc

in beta1 is Lease statici ???

Thank you @alefattorini I hope not to fail, as its becoming complicated, especially the certificate bit.
I had attempted with a standard podman run, using the docker run files, and it actually worked,
But hey, SSO is something critical, so a proper module is needed.

Ill have to thoroughly test backup, restore, clone tec on that module befor ei can put it to prodcution.

While not really that much necessary, as NEthserver 7 modules have operated without, but then why move to NS8 if i cant leverage the Super powers introduced by the NS dev team

Hi,

I am trying to test NethSecurity Beta 1. I just have vmware workstation to test it.
My existing production NS7.9 installations are also on ESXi systems.

Document says use unziped file as disk image for a VM install, but vmware seems not like it.

image

Is there something I need to do before using this image on vmware?

BTW, vmware seems to understand these types of disk files
image

Thanks & Regards,
Ertan

It’s a raw file, try to rename it from .img to .raw.

Ok got it. Objects are not the same things on NethSecurity and NethServer 7: you are not going to find an equivalent page, at least not for now.

If you enter some static leases or DNS names, you will find them also when configuring firewall rules as labels for IP addresses.

Vmware still gives me an error after renaming the file to raw.

image

I double checked that downloaded compressed file is OK. I use WinRAR and use Test button on compressed file and it says no error.

Extracted file should be OK, too. I could not figure what’s wrong.

I do not have a VMWare installation to test, but I’m pretty sure that someone already tried it without problems.
Maybe is a problem of this specific version of VMWare?

You could also try to convert the disk to vmdk.
Let’s if someone else has faced the same issue.

I will ask internally for some tests.

I had the same issue, after extracting it, i’ve used V2V Converter to convert the img file to vmdk format

Under the suggestion of @giacomo I’ve also tested qemu-img and I can confirm that the conversion is done correctly and the disk is accepted by VMware Workstation.

qemu-img convert -O vmdk file.img file.vmdk
4 Likes

I used V2V Converter and it worked out.
Thank you.

Hello,

I get a hang at boot time as below


Boot stopped at here and is not making a progress. I couldn’t understand what the problem might be.

Any help is appreciated.

Thanks & Regards,
Ertan

Hit enter a couple of times.
Should provide you the chance to login, if it’s not “stuck”.
IMVHO this phase need some improvement as UI and UX.

I’ve just documented the procedure: install: document vmware conversion by gsanchietti · Pull Request #39 · NethServer/nethsecurity-docs · GitHub

Is it clear enough @francio87 ?

looks fine to me

1 Like

I’ve create a temporary build: config: add support for some common network cards · NethServer/nethsecurity@7dee4dd · GitHub

The PR has been merged: Trello

A new image will be available soon.

I agree, but for now I didn’t find a quick and clean way to fix it on OpenWrt.

Added to the documentation: Installation — NethSecurity documentation

A stupid hint of what to look for.
At some point the system itself end the boot sequence… i mean, console put out some boot values.

Maybe a text echo of “configuration application completed”?

1 Like

Hi, a question about openwrt, is it able to exploit multicore? we would like to buy multicore appliances with 6 cpu

I was reading about this irqbalance addon

OpenWRT is Linux, and can handle “multicore” for more than 20 years now…

:slight_smile: