Need tests : nethserver-phpsettings


(Stéphane de Labrusse) #1

Accordingly this topic I made a new module, the intended purpose is to set specific PHP settings for one Ibay instead of the whole server. Of course since it is christmas, you have now a panel, with validators thanks to nethesis and specially to @davidep for their support.

Of course you have to use an ibay as the container of your website

yum install http://mirror.de-labrusse.fr/nethserver/nethserver-phpsettings/nethserver-phpsettings-1.0.0-3.ns6.noarch.rpm

In order to see php values, either you can use some web app that can say what are php values or upload a file (phpinfo.php) with that content and use your web browser to display it.

[root@nethserver-dev ~]# cat /var/lib/nethserver/ibay/example/phpinfo.php 
<?php     
 phpinfo();     
?>

I’m also currently working on another module about PHP from software collection, maybe it will be a bundle or separate rpm, Work in progress


(Davide Principi) #2

Thanks @stephdl, I’ll push it into nethforge-testing repo: please move the related Redmine issues into MODIFIED state, and write down any testing procedure that could require a special care!

http://dev.nethserver.org/issues/3133
http://dev.nethserver.org/issues/3058

BTW, I hope I’ll find some time to open the access to testing repositories to all devs


(Stéphane de Labrusse) #3

Sorry but yesterday night I forgot to push to git , now it is available, and the srpm is here http://mirror.de-labrusse.fr/nethserver/nethserver-phpsettings

I wonder if a PPA model could be better. I mean some web folders where only the dev can write. Like this the developer doesn’t have the cost of a web folder/server and for you the cost is near of zero.

A web folder with write permissions by a ssh key and of course the dev will need to have a specific rpm for configuring the /etc/yum.repos.d/

I have a start for nethserver-phpscl, I will provide a rpm https://github.com/stephdl/nethserver-remi-phpscl/tree/ns6 with a cron launched everyday to look after updates. the recipient of emails is ‘admin’. If I did that it is because I don’t want to upgrade rpm from remi except PHP54-php* PHP55-php* PHP56-php*


(Stéphane de Labrusse) #4

done, and @alefattorini can you change the minimum number of characters to 2, I love answer with smiley


(Alessio Fattorini) #5

Nope :smiley:

" Because when you don’t have very much to say, why say anything at all? Just click the like button!"

But can make a poll for this :smiley:


(Giacomo Sanchietti) #6

I agree with @stephdl. Posts with 20 chars are way to long!!!


(Alessio Fattorini) #7

Ok, you have convinced me, now it’s 10 characters.


(Mark Edworthy) #8

Could we see something in this module to allow for basic configuration of the php.ini (eg a slider / dialogue to change memory_limit and upload_max_filesize etc.)


(Stéphane de Labrusse) #9

then you need to test nethserver-php-scl, please go ahead


(Stéphane de Labrusse) #10

I modified nethserver-phpsettings to change the values of php in the e-smith database rather only for the virtualhost. please test and report on NS7 (use a vm please). Of course now you adjust the php settings for the specified virtualhost and/or for the whole apache server.

yum install http://mirror.de-labrusse.fr/NethDev/nethserver-phpsettings-1.1.1/nethserver-phpsettings-1.1.1-1.ns7.sdl.noarch.rpm


Max upload mailattachment in Roundcube
(Davide Principi) #11

A post was split to a new topic: PhpSettings translations


(Antonio) #12

Good job.
There are small errors in the Italian language files:

/usr/share/nethesis/NethServer/Language/it/NethServer_Module_PhpAdjustableValues.php
/usr/share/nethesis/NethServer/Language/it/NethServer_Module_PhpAdjustableValues_Php2Httpd.php
/usr/share/nethesis/NethServer/Language/it/NethServer_Module_PhpAdjustableValues_Php56.php
/usr/share/nethesis/NethServer/Language/it/NethServer_Module_PhpAdjustableValues_Php70.php
/usr/share/nethesis/NethServer/Language/it/NethServer_Module_PhpAdjustableValues_Php71.php

$L[‘Maximum execution time (${0})’] = ‘Maximum running time of scripts ($ {0})’;

$L[‘Maximum input time (${0})’] = ‘Maximum time to analyze input data ($ {0})’;

It should be:

$L[‘Maximum execution time (${0})’] = ‘Maximum running time of scripts (${0})’;

$L[‘Maximum input time (${0})’] = ‘Maximum time to analyze input data (${0})’;


(Davide Principi) #13