Installer bugs on release 7.3.1611 rc3

Guys, the installer is in really bad shape. here is a list I got on 7.3.1611 out of the box:

Wizard Drive select:
Any attempt to select a drive will result in the wizard will saying you haven’t selected a device. only way to get the installer to work is to not touch the drive at all. Obviously the installer should allow you to select any drive and if the drive has a “check” on it it should not give error of “no drive selected”.

When you get into the web interface, the CSS doesnt’ work properly so you cannot see the field you are typing in on Firefox 45 (really?). You go into the software package manager and there is nothing displayed. This RC seems to need a LOT more testing. Given the out of the box on fresh virtual machine install, this is a big fail here. These basic installer issues need to be fixed as it makes this distro unusuable in the web admin interface.

Hi @jlibster, thank you for your report.

About the installer, IIUC the drive selection is performed by Anaconda which comes from RHEL.

Can you post a screenshot of it?

Also a screenshot of the CSS issue on Firefox would help.

An empty software center usually leads to a network configuration issue.

Are you referring to this?

1 Like

Nice catch @filippo_Carletti, I was thinking about that

I guess @jlibster still cannot upload files because he joined us a few minutes ago…

Hi, okay, an update for those doing the wizard:

the source of the software manager menu is from a twofold problem. First, CentOS Doesn’t like it if you have gateway settings on two interfaces. Part of the issue may be it doesn’t like using a gateway on a different subnet. The wizard asks for all network settings for both interfaces (if you have multiple). I foolishly put the gateway on BOTH eth0 and eth1. I discovered a problem with YUM where it could not contact the centos mirror. I read about a bug relating to ipv6 so I disabled that. Then I discovered that I couldn’t resolve DNS entries once I did that. I assume that it was piggybacking on auto address from ipv6 before I disabled it. When I examined the ifcfg-eth0 and ifcfg-eth1 files I discovered that the wizard set up the gateway on eth1 which had a static ip of I set it in eth0 (which has 192.168.1.x static). Once I did that the software manager worked as did yum. But…once I tried to install packages, I lost ability to resolve DNS again. examing the file I discovered the system automatically removed the gateway entry from ifcfg-eth0 so I was back where I started. I put my gateway back into eth0 and removed it from eth1. That appears to have resolved the issue. So, my recommendation…your install wizard should ONLY allow ONE gateway entry and it should be on the network interface that matches the subnet if the address is static. Your wizard correctly colors the gateway in green if matching the interface subnet and yellow if it doesn’t. I suspect it sets up the gateway in order of interfaces (ie. eth0 then eth1) and omits the entry of the 1st if a 2nd gateway is discovered. A bit more logic (ie if the subnet matches put the gateway on THAT interface) so that it works correctly. This sort of behavior is confusing for people new to this or expecting a wizard to just work (ClearOS does a pretty good good as does UCS Small Business Server). I’m confident this will get fix. but please be aware (and fix it. :D). I’ll try to follow up on the odd behavior on the menu overlapping issue, but on a reinstall that seems to have gone away.

Okay, more bugs, I set the AD Domain controller and it has messed up the network access…again. The Gateway setting on eth0 is AGAIN removed and network access is lost. Here is what the AD wizard as set to my network interfaces:



Gotta fix these wizard issues. AD wizard asked for address in a “green” network. I set the network of the domain to (which is correct for the domain controller). Also indicated this interface was the bridge to the domain. So…how do I fix this (short of reinstall the entire system…again…)

Network fails to restart. Error: /etc/sysconfig/network-script, Error, some other host already uses a (cutoff on KVM vlc viewer).
RTNETLINK answer: File exists
Bringint up interface eth1: device eth1 is already a member of a brid (cutoff by viewer width)
Failed to start LSB: Bring up/down networking.

Okay, reinstalled, put the gateway on the eth0 only, disabled ipv6 (ignore) in the wizard. Added domain with DC controller 3rd ip address of But…now I have not one but TWO admin automatically created but when I try to update the password of either with the web interface I get this error:


404 - Not foundadmin@(company name).int


The 2nd admin user:

404 - Not foundadministrator@(company name).int


There is a domain group that is called "domain admins@(company name).int. Note: there are no spaces or special chars in the (company name). Should there be a space in a domain group?Seems wrong, It was auto generated.

Nope. Was trying to do simple all in same partition partition. Nothing fancy. Just trying to do default options.

Okay, figured this out, but again, this is a bug that needs to be fixed. Sorry if I’m being critical but people may get discouraged with these issues. When you add the Samba Active Domain service using your web interface, it seems to clear the sssd.conf file so that it is a file of 0 bytes. Now I’ve never configured the sssd.conf before so this is probably not the best setup but…here is what I did to fix the password change issue after creating a full AD domain:

****************************** /etc/sssd/sssd.conf file contents start *********************
services = nss, pam

[domain/(domain name)]
id_provider = ad
auth_provider = ad
access_provider = ad

use_fully_qualified_names = True
****************************************** File contents end *************************
After I started the sssd service once I added these contents to the file sssd started and I could initialize the password for the domain admin auto generated user. The auto generating routines for conf files seems to be a bit off as this is the 2nd I’ve seen on basic services. So…next bug fix I suggest is to properly generate the appropriate sssd.conf settings upon creating a Samba AD Domain controller because the sssd.conf must have valid settings for the sssd service to start.

Thank you again for testing NethServer!

I’m a bit lost because there are many issues reported here. :confused:

I suggest splitting them into different topics and report the steps to reproduce them.

Also note that in NethServer things are configured automatically by the template system. There should not be any need of editing configuration files by hand!

Here is a brief FAQ on bug reports

1 Like

Hi Jonah,
thanks for the heads-up on this one, that really helps us tackle the issue.

Let me add that that kind of sentences doesn’t help to keep the discussion friendly and effective :slight_smile:
We’re very very jealous of our tone here. :stuck_out_tongue:
Anyway thanks for your time!

1 Like

Yes I do understand that this is an RC. Yes there are multiple issues here. Bear in mind this was from multiple “de facto” installs. I do realize that I shouldn’t have to do custom config file tweaks and in some cases (like smb.conf) it may be overwritten completely. Some of these are important. As a netadmin/dev. Sorry if you take exception to my remark. Bear in mind that others trying out these install may not have the tenacity to make this work. The hard drive “not selected” bug was particularly confusing and annoying. All that said a quick summary of issues found on this installer (which I got to work).

  1. If you change (or even touch) the drive to be installed on for any reason, the installer says you haven’t selected a drive, even when the big graphic “check” is indicated. (didn’t try custom partitions, just "stick it all in “/” root).

  2. when setting up 2 nics (like as a gateway), the installer it should as much as possible keep the gateways on the same subnet to minimize chance of network problems. Most installers only allow one gateway by default to prevent possible issues but I realize that is not always best. But if it sees a gateway on the subnet of a statically set ip on a nic, it should set it to that nics setting so they match there. I realize it seems obvious, but installers give one a sense of security that we may not in fact have. :smiley:

  3. When you set up the OS as a domain controller, it appears the sssd,conf file is delete causing various dependency issues like password administration to fail. You have to manually create a sssd,conf to correct the problem.

those are the big 3 bugs I found and did work arounds for. BW, the version is 7.3 RC3 (Tiramisu).

Newest download obtained 1 day before posting. 7.3 RC 3 Tiramisu

BTW, just so you know, that once the install is stable/working, I’m hopeful this will be a superior alternative to ClearOS. (which was my main SMB recommendation to many clients for a number of years, but their integration of Samba 4 has been spotty at best and I’ve had to do more hacking around on that to get it to work. So hopefully as these bug fixes get done this will be an amazing distro. Would be cool to be able to tweak the files manually without the changes being lost (specifically smb.conf) if a tweak is desired. (in my case, get Samba to use an external NAs drive instead of it’s internal defaults).

There is a manual for this distro. As was mentioned earlier in this thread if you wish to enhance functionality by tweaking the confs… you should be creating templates… as the manual explains.

If you see the following at the top of a conf you’re tweaking, your changes will be lost if any other config changes are made or the machine is rebooted.

 ================= DO NOT MODIFY THIS FILE =================

 Manual changes will be lost when this file is regenerated.

I did glance at it. I can pursue it further but was also hoping that some more Samba savvy person could step me through on what I may be missing in my approach.

Oh, BTW, was looking at the nextcloud server/interface. Is there supposed to be an admin section on the left side navigation? didn’t see any when I looked.

Honestly, having read through your comments a couple of times, I have no idea what you’re doing, did, or want to do with your dc. I do know that the dc setup wizard will get you a working dc out of the box, I have tested this more than a few times.

Regarding Nextcloud, to access the nextcloud admin page you’ll need to be logged in as admin and you’ll find the link to the page on the dropdown in the upper right corner of the gui.

1 Like

HI, I’ve tried a few times to give a summary of the issues I’ve found in the installer as it did not in fact work “out of the box”. I’ve had to do a number of things as I’ve already indicated. Things that didn’t work out of the box were:

  1. allowing to proceed if a drive is checked (gave detailed description) if you happen to look into the configuration of change default options (or change them back which I did) and then “check off” the drive.

  2. Network name resolution on internal lan. (A combination of confusion wizard NIC options which should be tweaked).

  3. When creating a domain the system deletes the sssd.conf file causing the web interface to be unable to initialize passwords on newly created domain admin profiles.

The last one definitely did not work out of the box. The web interface did indicate the required steps but could not set passwords (got misleading error 404 in a popup dialog) because of the sssd.conf was needed for the service upon which the set/change password dialog depends. I gave my solution to the problem above which was easy to do IF you figure it out. (which most people probably won’t)

as for what I want to do with my DC, I simply wanted a DC with full AD and the ability to save the shares (and perhaps profiles in their entirety), to an external NAS because it is already setup and as over 4 TB of space.

I did notice the netcloud link in the dashboard

In this link:

it mentions:
“External Storage Support (search it into the owncloud app store) by which you can mount SMB/CIFS shared folder using any valid credentials.”.

Problem is I cannot see the option in the Software centre. Is that because it’s not ready for Nethserver 7 RC3? Would be nice to have this. But I saw answers in my last posting that will serve. Would be nice if there was a more user friendly gui for this. as I’m sure the community users would REALLY appreciate it.

I’m afraid that doesn’t really help anyone duplicate and fix the issues you’ve encountered. The devs here do a lot of work, weeks of work, for free basically… it behooves users to clearly let them know exactly what their expectation was, was they did, step by step, and what happened that they didn’t like or expect. Your description was pretty clear with your installer issues, not so clear with your dc setup attempt. I have my own idea of what you may have done but I don’t know for sure of course.

Regarding NextCloud, once working with nextcloud, you must use the nextcloud admin, you will need to go to the nextcloud app store from the upper left menu and add the module for external storage, then you should be able to point to your Nethserver samba shares. I don’t think any one of us here believes that Nextcloud should be the module for managing Nethserver samba file shares, though you can certainly manage the files in samba with Nextcloud and its clients.

Also, when using the documentation, it defaults to v6.8, you will need to go down to the very bottom of the left column to find the docs specific to v7, and they are a little rough yet.

1 Like