Sounds good, but WAY above my paygrade ![]()
Thanks!
Sounds good, but WAY above my paygrade ![]()
Thanks!
Renovate is free, I don’t pay for it.
See also Enable Renovate to Receive PRs for Upgrading Your Modules
he meant beyond his understanding
All up and running, thanks @mrmarkuz
Thanks for testing!
Thanks for testing and feedback!
Wanting to put some photos on the public Internet, I decided to install this. Installation ran smoothly enough, configured a hostname, got a cert, all without issue. But noticed a couple of things:
2026-05-19T13:07:32-04:00 [1:immich1:immich-app] e[32m[Nest] 22 - e[39m05/19/2026, 5:07:32 PM e[32m LOGe[39m e[33m[Api:WebsocketRepository]e[39m e[32mWebsocket Connect: Ew8FvXtluh94GJ1FAAAFe[39m
2026-05-19T13:09:18-04:00 [1:immich1:immich-app] e[32m[Nest] 22 - e[39m05/19/2026, 5:09:18 PM e[32m LOGe[39m e[33m[Api:SystemConfigService~pkjgukmr]e[39m e[32mLogLevel=log (set via system config)e[39m
2026-05-19T13:09:18-04:00 [1:immich1:immich-app] e[32m[Nest] 2 - e[39m05/19/2026, 5:09:18 PM e[32m LOGe[39m e[33m[Microservices:SystemConfigService]e[39m e[32mLogLevel=log (set via system config)e[39m
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] e[31m[Nest] 22 - e[39m05/19/2026, 5:09:32 PM e[31m ERRORe[39m e[33m[Api:OAuthRepository~54hdc6wt]e[39m e[31mError in OAuth discovery: TypeError: fetch failede[39m
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] e[31m[Nest] 22 - e[39m05/19/2026, 5:09:32 PM e[31m ERRORe[39m e[33m[Api:OAuthRepository~54hdc6wt]e[39m e[31mTypeError: fetch failed
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at node:internal/deps/undici/undici:15845:13
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at process.processTicksAndRejections (node:internal/process/task_queues:103:5)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async performDiscovery (file:///usr/src/app/server/node_modules/.pnpm/openid-client@6.8.1/node_modules/openid-client/build/index.js:266:16)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async discovery (file:///usr/src/app/server/node_modules/.pnpm/openid-client@6.8.1/node_modules/openid-client/build/index.js:243:16)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async OAuthRepository.getClient (/usr/src/app/server/dist/repositories/oauth.repository.js:88:20)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async OAuthRepository.authorize (/usr/src/app/server/dist/repositories/oauth.repository.js:25:24)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async AuthService.authorize (/usr/src/app/server/dist/services/auth.service.js:179:16)
2026-05-19T13:09:32-04:00 [1:immich1:immich-app] at async OAuthController.startOAuth (/usr/src/app/server/dist/controllers/oauth.controller.js:37:46)e[39m
Doesn’t seem super informative to me, but it looks like it’s having trouble communicating with the Authentik instance using its FQDN.
I released an update to the current version and enabled host loopback so Authentik and Immich should be able to reach each other.
Updated to 1.1.4, and it now works just fine. That was quick!
so does it mean that applications which need to authenticate to authentik or other SSO solutions, needs to have host loopback enabled on them?
Yes, when Authentik and the client app are installed on the same node, see Collabora and Onlyoffice in conjunction with Nextcloud no longer work since the last update (dnf update) from Rocky - #7 by davidep
Thanks, might just help solve an old problem i faced on a certain app, cant even remember the app.. will find it, and resolve, then update it.
Is it possible to store the photos on an other hdd (share)
The size of the harddisk is going to be too small and there is a 2nd harddisk which is smb share with enough space
Good idea! I released a new version 1.2.4 that supports using another disk for the immich-data volume as explained in the documentation.
Wow. That is fast
Is it also possible to use the extra disk which is already mounted on SMB?
ns8-samba supports volume redirection too so if you configured a volume redirection for samba as explained in the documentation link, then it’s possible to add immich.
If you configured it as explained here, then there could be issues as the immich-data volume will be stored inside a samba share/volume. I didn’t test that approach.
Where can i find this menu ?
I’ve seach it but can not find it
This menu appears when you install Immich from Software Center and an extra disk is mounted.