Howto install Onlyoffice document server as Nextcloud app


(Nitram Oneito) #102

is this the better method of installing than

than this method.

(Markus Neuberger) #103

The module is the better method as it eases installation a lot and preconfigures onlyoffice.

(Nitram Oneito) #104

Thank you,

and whats the difference between the quick install, and the installation in the documentation.

do I have to run write both, or only chose one

Collabora intergration
(Markus Neuberger) #105

Choose one. First we make a howto and then we make the module out of the howto. So the module integrates the howto.

(Nitram Oneito) #106

when I install the module with the instruction, will it install on sub.doamin.tld/onlyoffice or do I need to point a subdomain like https://onlyoffice.domin.tld

(Markus Neuberger) #107

The module integrates itself in nextcloud so it depends on nextcloud.

(Nitram Oneito) #108

does that mean I do not have to go and add theh onlyoffcie erver in the nextcloud settings?

(Nitram Oneito) #109

thank you

(Zoran Ramač) #110

Hi everyone,

Yesterday i made a clean install Nethserver + Nextcloud (from Software center) + OnlyOffice + DocumentServer 5.1.4 as per instructions (onlyoffice Wiki).

Despite this, I have always received an error (when I press the Save button in Nextcloud - ONLYOFFICE):
“Command Request on check error: Error while downloading the document file to be converted.”

I spent the whole day trying to solve the problem.

I found a solution this morning. In file default.json (/etc/onlyoffice/documentserver/) I made a simple change (true to false):

“requestDefaults”: {
“headers”: {
“userAgent”: “Node.js/6.13”
“rejectUnauthorized”: false

I know the problem is in the certificates, but only in this way have I managed to make Onlyoffice to work.

I am a little confused :roll_eyes:

(Markus Neuberger) #111

Hi Zoran,

Yes, you need a valid trusted cert like letsencrypt and you probably need to port forward 8082 from your router to your Nethserver. You have to set your domain too.

Thanks for sharing, this is great for using onlyoffice without valid cert but I am afraid it’s not the best for security.

(Zoran Ramač) #112

Thanks Markus,

now I will try to implement the certificates.

(Ralf Jeckel) #113

Hi Markus @mrmarkuz ,

I installed a new NS instance with NC-13.0.6 and only-office 5.0.7 (selfsigned certs).
I had to install librabbitmq and librabbitmq-tools from puias-unsupported.

I did:

and then

yum localinstall -y librabbitmq-0.5.2-1.sdl7.x86_64.rpm
yum localinstall -y librabbitmq-tools-0.5.2-1.sdl7.x86_64.rpm

Now onlyoffice in NC 13 on NS 7.5 is running fine:

Maybe you want to update your Howto.

(Markus Neuberger) #114

IIRC it’s only a problem with old documentserver needed for self-signed certs, newer documentserver version should just work. It’s because epel changed rabbitmq packages.
Thanx, I’ll update the wiki entry asap.

EDIT: updated.

Librabbitmq update error
Nextcloud reinstall / rebuild setup
(Rob Bosch) #115

4 posts were split to a new topic: Content server runs, but no onlyapp options

(Ralf Jeckel) #116

I found a workaround to install onlyoffice 5.1.x with selfsigned certs.
It’s only a workaround, because it breaks SSL security due to allow connections to unauthorized ssl servers, but it works.

Set services.CoAuthoring.requestDefaults.rejectUnauthorized=false in /etc/onlyoffice/documentserver/defaults.json file and restart documentserver serviceis with supervisorctl restart all .

Got it from:

(Markus Neuberger) #117

I updated the module. Please test it so I can put it to the repo!

To update an existing installation (for a full install follow the wiki except of these two lines):

yum -y install
yum -y install

It seems the formats were extended too:


Content server runs, but no onlyapp options
(Ralf Jeckel) #118

Just saw, that I posted the same solution as you did before. Sorry :blush:
I didn’t read this topic exactly enough.
I could have saved half a day of searching if I had done… :wink:

(Ralf Jeckel) #119


Worked here like a charme! Thanks Markus! You are great !:+1:
PS: selfsigned certs still work with changing “true” to “false”.

(Markus Neuberger) #120

Thanks for testing! For the self-signed certs there’s a db prop now too:

I am afraid of future documentserver updates may change the default.json so I decided to add it.

(Alessio Fattorini) #121

Late to the party. Thanks @mrmarkuz and @flatspin good job! This project is growing day-by-day