Howto install Onlyoffice document server as Nextcloud app

nextcloud
v7

(Giacomo Sanchietti) #122

I tried to get started with Onlyoffice following wiki documentation but using DocumentServer 5.2.3.

The server didn’t start. Quick and ugly fix:

chown onlyoffice:onlyoffice /etc/onlyoffice/documentserver/default.json
supervisorctl restart all

(Markus Neuberger) #123

Thanks, I can confirm this, it seems they changed something in 5.2 but I can’t find documentation about it.

I am going to investigate, only found this for the moment, default.json is read-only now and config should be saved in another file:


(Michael Träumner) #124

Here is the changelog, but I can’t find something about it too.

https://helpcenter.onlyoffice.com/de/server/document/changelog.aspx


(Roberto) #125

hello, help me.
Some time ago I made my first installation of ONLYOFFICE and everything went wonderfully.
A few days ago I’m trying to do some installations but I can not start the APP.
I have created more virtual machines with Neth 7.5 or 7.6, update, but the result is always the same.
I do as follows:
I install Nethserver 7.5 or 7.6
I install LDAP
I install NEXTCLOUD
I do everything that the WIKI says

This is the result:
test the document server.

Then open NEXTCLOUD

Then try to open file .docx


(Markus Neuberger) #126

Did you allow self-signed certs? It’s necessary with newer documentserver versions:

https://wiki.nethserver.org/doku.php?id=onlyoffice&s[]=onlyoffice#self-signed_certificate


(Roberto) #127

Hi, Markus
Tomorrow i’ll try and then… I hope


(Steve) #128

When I click on a document in nextcloud im getting the error “ONLYOFFICE cannot be reached. Please contact admin” i can access via https://www.mydomain.com:8082 i get the screen says document server running below is my onlyoffice setting in nextcloud


(Markus Neuberger) #129

Usually you don’t need to set server addresses in “Advanced server settings”. I can reach your Onlyoffice and your Nextcloud so I assume it works if you delete the addresses, and set the correct address (the “www” one) in the “Document Editing Service address” on top.

If you install the module, it will setup everything for you.


(Steve) #130

That fixed it thanks a bunch