Content server runs, but no onlyapp options

I have a porblem using Onlyoffice. I just installed it on my server and when I go to https://domain.tld:8082 I see a nice: Thank you for choosing ONLYOFFICE!
Document Server is running

But when I log into Nextcloud, I don’t see the option to create or edit documents with onlyoffice.
Could it be that I did something wrong with the domain that onlyoffice must be reachable in the config of nextcloud?

Did you try the “save” button in nextcloud settings?

Must be something wrong. I get this message when clicking the save button:

Error when trying to connect (Bad Request or timeout error)

Hi @robb , this how to thread is already very long. Would’t it be better to open a new support thread to this? I hope you don’t mind, but IMO it’s not good to dicuss support in a how to. What do you think?

Thnx @flatspin for the suggestion. I split off the support posts into this new topic

1 Like

Sorry, I could not reproduce except when I close port 8082.
Did you set the domain?

config setprop fw_onlyoffice host DOMAIN.TLD
signal-event nethserver-onlyoffice-update

Are there some helpful entries in /var/lib/nethserver/nextcloud.log ?

Hi @mrmarkuz,
Yes I did set the domain and when I go to https://domain.tld:8082 I see the message that the document server is running. So I think port 8082 must be opened since I can connect with a browser to that port.

Do you use a valid cerificate?

In the nextcloud onlyoffice app settings there has to be trailing slash in the “Document Editing Service address” like https://domain.tld:8082/

You may try signal-event nethserver-onlyoffice-update to reconfigure the module.

Next steps would be to reinstall documentserver or drop the db. Sometimes the documentserver rpm can’t create some links.

Is there nothing in the logfiles?
Which documentserver version do you use?


You may try the new module version.