Onlyoffice and DYNDNS

NethServer Version: 7.7
Module: Nextcloud 18 -> onlyoffice

Hello Guys

I am confused …

Now i trying the thrid time to install Nextcloud ond Onlyoffice… Onlyoffice as a part of Nextcloude not external Server…

First times is running there is a fix IP with VDSL. Was hard but after 5 trys install was okay.

Dokument Editing Service Adress
https://sub.domain.de/nextcloud/index.php/apps/documentserver_community/

and both are gray cant edit …
Document Editing Service address for internal requests from the server
is emty
Server address for internal requests from the Document Editing Service
https://sub.domain.de/nextcloud/

Than i try do install it with dynamic internet adress (like DYNDNS service) the route renew the DNS with the new IP4
Second try was ADSL need 10 trys to intall it. At the first day war running next day (fresh IP) no Onlyoffice.
Yesterday i ty my Home server with a VDSL dynamic IP and DYNDNS service. First try was sucessfull and it is running. New day no Onlyoffice from external (SOGo and Nextcloud running no certificate Errros with the Browser)

A view in to the Admin - Config -Onlyoffice side says internal IP
https://192.168.38.21/nextcloud/index.php/apps/documentserver_community/

all other parts are gray
and the
Server address for internal requests from the Document Editing Service
https://192.168.38.21/nextcloud

if i try to change
A view in to the Admin - Config -Onlyoffice side says internal IP -> to
https://sub.domain.de/nextcloud/index.php/apps/documentserver_community/

I get this error
Fehler beim Anschließen (cURL error 51: Unable to communicate securely with peer: requested domain name does not match the server’s certificate. (see http://curl.haxx.se/libcurl/c/libcurl-errors.html))

Now from my homenetwork Onlyoffice is running but external is a errormassage …

What did i am doing wrong?

thx a lot Axel

I assume you need a valid certificate like letsencrypt.

You could try to use FQDN instead of IP like https://sub.domain.de/nextcloud/ instead of https://1.2.3.4/nextcloud.

Another way is to disable the certificate check (don’t know if it works for internal onlyoffice):

If it’s still not working you may try the external onlyoffice:

https://wiki.nethserver.org/doku.php?id=onlyoffice

Hello Markus

I will send a hallo from new MaskLand … Burkas for everybody ;-)… I klie to change my toiletpapper bay to human rigths :wink:

I do the same work with all servers …

Building a letsencrypt setificate for the subdomain sub.domain.de and let it be default.
HTTPS is fine with with all server Web, SOGo, nextcloud. All kind of browsers are “green”

From the Routes (three times AVM Fritzboxes 7490/7590) the ports 443, 80 a routed to the Nethserver.

so it looks like certificate is okay…

one server is behind a VSDL with fix IP… need a littel bit of time than this server is running with the combination of Nextcloud and Onlyoffice.

one server is behind a ADSL with Dynamic IP. DNS for subdomain is a DYNDNS servive like selfhost…
my Server is sitting behind VDSL with dynamic IP, and a Strato DYNDNS service.

On th the installation day my server is running well, next day with a new IP Onlyoffice is not working from external, but internal. So i am take a view for setting in the Onlyoffice in Nextcloud there was a IP not the SubDomain. Than i try to change Internal IP Nethserver to the subdomain and this is the error

Fehler beim Anschließen (cURL error 51: Unable to communicate securely with peer: requested domain name does not match the server’s certificate. (see http://curl.haxx.se/libcurl/c/libcurl-errors.html))

But i will try it step by step again …
Did you think the letsencrypt is okay ?

I still didn’t find time to the test the internal onlyoffice but I’ll do it asap.
You may check config files or Nextcloud onlyoffice settings for ip addresses and change them to FQDN to make it work but it’s just a guess.

Hello Markus

thx for you help and it show the rigth direction. My homeserver is now fixt…

The solution is very easy and crasy to.

Frist -> setur the route to redirct the ports 80, 443 to my netserver (internal IP)
second-> letsencrypt certificate must installd and be default!!! (but it was)
third-> I am installing Nextcloud (without onlyoffice) and including the TrustedDomains
with

[root@neth ~]# config setprop nextcloud TrustedDomains sub.domain.de
[root@neth ~]# signal-event nethserver-nextcloud-update

We can use Nextcloud form external and internal. (looks like perfect)

Than i am folowing the instruction to Instlla Onlyoffice (its the connector) and the comuninty documentserver.

Try it internal !! :slight_smile: it is running…
try it external fine

Brake -> one beer -> and a lill bit of sleep

Nextday try it again oh not nice not working …
Login as admin (Nextcloud) [not aktivate the Neth admin user] moving to setup -> Onlyoffice
and try to change IP with FQDN (sub.domain.de)
try to change internal too cant change it …
save it wir the error …
but it will be saved …

Try it a few times … :poop:

asking for help …

Now i try

[root@neth ~]# config setprop nextcloud TrustedDomains sub.domain.de
[root@neth ~]# signal-event nethserver-nextcloud-update

again

now ich can change internal sever too
replace IP with FQDN

Hurry Onlyoffice is working internal and external :slight_smile:

1 Like