Help! I've change Motherboard and AD is dead!

I have only 8 hours to fix it!
I moved the hard disk to a more proper server hardware, but nsdc dind’t start. I moved it back to old hardware – and it still doesn’t start.

● nsdc.service - NethServer Domain Controller container
Loaded: loaded (/usr/lib/systemd/system/nsdc.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2021-09-20 19:11:25 +03; 23min ago
Docs: man:systemd-nspawn(1)
Process: 7243 ExecStart=/usr/bin/systemd-nspawn --quiet --keep-unit --boot --network-bridge=${BRIDGE} --machine=nsdc ${OPTIONS} (code=exited, status=1/FAILURE)
Main PID: 7243 (code=exited, status=1/FAILURE)
Status: “Terminating…”

Sep 20 19:11:25 systemd[1]: Starting NethServer Domain Controller container…
Sep 20 19:11:25 systemd-nspawn[7243]: Failed to create directory /var/lib/machines/nsdc//sys/fs/selinux: Read-only file system
Sep 20 19:11:25 systemd-nspawn[7243]: Failed to create directory /var/lib/machines/nsdc//sys/fs/selinux: Read-only file system
Sep 20 19:11:25 systemd-nspawn[7243]: Failed to resolve interface br0: No such device
Sep 20 19:11:25 systemd[1]: nsdc.service: main process exited, code=exited, status=1/FAILURE
Sep 20 19:11:25 systemd[1]: Failed to start NethServer Domain Controller container.
Sep 20 19:11:25 systemd[1]: Unit nsdc.service entered failed state.
Sep 20 19:11:25 systemd[1]: nsdc.service failed.

IMVHO something is not right in the first boot. Read-only file system

I’m afraid to resolve it: what if it is going to overwrite something else? I also noticed that I don’t have br0 interface but only brdef.
Is there a way to rename it to br0?

[root@dc ~]# ifconfig -a
brdef: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 --(mac censored)— prefixlen 64 scopeid 0x20
ether–(mac censored)— txqueuelen 1000 (Ethernet)
RX packets 99543 bytes 6252894 (5.9 MiB)
RX errors 0 dropped 57 overruns 0 frame 0
TX packets 63172 bytes 21618211 (20.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 --(mac censored)— prefixlen 64 scopeid 0x20
ether --(mac censored)— txqueuelen 1000 (Ethernet)
RX packets 100962 bytes 7755119 (7.3 MiB)
RX errors 0 dropped 151 overruns 0 frame 0
TX packets 63180 bytes 21618867 (20.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 7161 bytes 2572661 (2.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 7161 bytes 2572661 (2.4 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Also, “vendor preset: disabled” is that a problem?

Bridge interface can be recreated without hassle… And in any case, some triggering of signal event might re-generate the correct configurations.

I found that some time ago I enabled Nethserver Config backup. So, I restored it. All services are running well. All interfaces are OK. Br0 is back. Users list is back. But, the windows machines can’t find domain controller to login. Admin tools on windows say that “server is not operational”.

What could I do?

After some time the server responded!!!

For avoding my confusion: are you on the “old” or on the “new” mainboard currently?

I am super happy to return to old motherboard! It is working!!!

Of course in future I will have to move to proper server hardware somehow…
But now I’ll make complete copy of the hard drive to experiment on copy.

IMVHO, you can run with this arrangement:

  • connect two drives to the “new” mainboard
  • install NethServer on “new” mainboard + drives
  • do a full USB Backup of your current setup
  • download latest configuration backup of your current setup
  • shutdown or disconnect the current server from the networks
  • full update the new installation (if not already done during install), reboot if a new kernel comes
  • restore the configuration backup
  • plug the usb drive
  • do data restore from your latest backup
  • have dinner, read a book, take a stroll, drink some nice beverage… i mean… LIVE :slight_smile: don’t wait so much time in front of the screen while restoring
  • come back when the restore ends
  • enjoy the new setup.

but the progress bar is my favorite show :slight_smile:

Please think about virtualization, so you don’t have any hardware problems at the future. I work with proxmox and hyperV, but proxmox is my “friend”. :star_struck:

1 Like

So… enjoy the gig :slight_smile:

Well… actually, now that I’m recalling how I installed Nethserver…
Yes! I installed in on the latest AMD Ryzen CPU/Motherboard. It was an adventure:

  1. Have two HDDs in your Ryzen PC
  2. HDD 1 – install modern UBUNTU
  3. Install VirtualBox (don’t forget to enable virtualization in BIOS)
  4. Find out HDD2 path (for me it was /dev/sda )
  5. Add your user to two groups: disk and virtualbox
  6. reboot
  7. Create a linking virtualbox file to physical HDD2
  8. Create a virtual machine without Storage
  9. Add physical HDD2 in virtualbox
  10. Install NethServer on physical HDD2 in virtualbox
  11. Install new kernel in NethServer
  12. Shutdown
  13. Remove Ubuntu HDD and leave only NethSever/VirtualBox HDD2
  14. Boot NethServer on Ryzen!

So… yeah… Virtualization is cool… But my real server hardware (not the desktop Ryzen thing) is real server MB+ server CPU + server RAM + server case + server power supply… I have to move to it. And I’d prefer to do it without virtualization. It’s an entry level server hardware, so slowing it down even more with virtualization is not an option.

You could think about a container at proxmox

I think @Andy_Wismer is more specialised then me at this. Perhaps he can help you.


Hi Sasha

Using an entry level server is not an issue, I have several customers using such an environment, I also have 1 of 3 Proxmox at home also on an 8 year old HP Proliant ML110 (also entry level server).

I recently installed Proxmox, NethServer, OPNsense and a LXC with Debian on a Quad Core Atom! And I was impressed how swift everything worked. If you had asked me two months earlier, I’d have said: no way!

Maybe you don’t know it, but certain tasks can run faster virtualized than on native.
An example, install any Linux on your hardware, and compile the whole Linux kernel.
It will take it’s time, sure.
Then install any virtualizer Host on the same hardware, and inside install again your same Linux, but now virtualized.
This will also take it’s time, but will be faster than above, running natively on the same hardware…
Usually 5-15% faster!

Why is this so?

Two levels of caching, is one reason, there are more…

Disaster recovery on native hardware: Always issues with NICs, Controllers for Disk.
Virtualization: Rock-Solid and fast disaster recovery, on almost ANY hardware.

Move a fussy Windows from AMD to Intel - you get a nice blue screen.
Using Proxmox, I can migrate from AMD to Intel and back Intel to AMD - no issues!
Windows doesn’t even notice the difference of architures nor requires a new registration!

Some small advantages, and the main reasons why almost no knowledgeable person would suggest native installs anymore!

My 2 cents


Just to finalize my adventure:
I was able not only to restore my strangely broken server settings (if you take your HDD and place it in a different hardware and then return it back – your configuration will be broken), but also successfully moved to the new hardware.

Configuration backup allowed me to specify what my new network interface was and corrected all … I mean ALL related configs with appropriate NIC name and MAC address. It was so good… now I know how to change the hardware.

Thank you for such a thoughtful config backup/restore procedure!