First dashboard launch, the FQDN must be changed but this reset the manual network configuration


I have installed NethServer on ESXI server in OVH: NethServer network connection problem with ESXI and OVH.

I have created a VM, booted on NethServer ISO, installed by default.

I have needed to do a manual update of network files to have network on the VM.
Modification of /etc/sysconfig/network-scripts/ifcfg-ensXXX and creation of /etc/sysconfig/network-scripts/route-ensXXX and ifdown ensXXX and ifup ensXXX.

At the first dashboard launch, the FQDN must be updated.
I have accepted to do it but the connection has been lost, no ping.
The network has been reset by default and not good settings.

AFAIK, during the first setup via interactive setup the “anaconda phase” is “useless” for network and hostname.
Nethserver will consider the networks available as green, and will receive DHCP offers.
Using unattended setup, the documentation should be reliable.

The “real” network setup goes with the access to Server Manager (now in cockpit). Roles, IP, hostname(s).

When installing, you’re configuring CentOS. But when you’re accessing the Server Manager, you’re populating the configuration DB, that will override/overwrite CentOS system, service, network, firewall settings.

Every modification to system and service configuration will automatically do…

  • check of the parameters (sometimes fails, but whatever)
  • write the configuration to the DB
  • expanding the configuration with also the custom templates created by the sysadmin
  • overwrite of the settings of the system and/or services configuration with the one created by the expansion.
1 Like

@pike: Thanks for your answer! But there is no DHCP, it is only a VM installed on an ESXI server in OVH.

Docs to configure the network:

Dedicated server with “main” IP / Gateway → ESXI management:

  • VM1 with an “IP Failover” linked to Virtual MAC
  • VM2 with an “IP Failover” linked to Virtual MAC
  • VM3 with an “IP Failover” linked to Virtual MAC

Ok… you can access to ESXi. That’s golden :wink:
This is a screenshot from SSH connection.
But, using the console (even the one of ESXi), I get this.
From the network-recovery interface, you will assign a temporary (and good for you) IP address, then access to cockpit to create a viable network setup (at least one green adapter should exists, even a dummy one)

On the other hand… This for the developers is not a bug.
For any other environment that don’t fit the use of the cooked ISO, any CentOS installation might be “nethified” following this steps.

Another viable option, for people it’s skilled enough, is to create a customized kickstarter file for a “customized” unattended installation with all the bells and whistles you might need.

What I wrote is simply what I know. I’m not endorsing nor arguing with these options.

1 Like

In mode console (not ssh, no network) , after network-recovery:

The IP from OVH is ending by 0.

Clearing Shorewall....
Processing /etc/shorewall/stop ...
Processing /etc/shorewall/tcclear ...
Preparing iptables-restore input...
Running /sbin/iptables-restore --wait 60...
IPv4 Forwarding Enabled
Processing /etc/shorewall/stopped ...
Processing /etc/shorewall/clear ...
[NOTICE] Creating the bridge brtmp
[NOTICE] Adding interface ensXXX to brtmp
[NOTICE] Adding interface ensYYY to brtmp
[NOTICE] Assign IP XXX.XXX.XXX.0/ to brtmp
[NOTICE] Done.

Network does not work…

The /etc/sysconfig/network-scripts/ifcfg-ensXXX is not updated with the IP.

And the route is not here: /etc/sysconfig/network-scripts/route-ensXXX

After manually edition of /etc/sysconfig/network-scripts/ifcfg-ensXXX and creation of /etc/sysconfig/network-scripts/route-ensXXX it works but in Dashboard → Network it is always, screenshots here: Impossible to add good network values "Validation failed: IP address can't be the network or broadcast address" - OVH (ESXI/Proxmox) with screenshots.