Can't install NethServer 7 ISO on Hyper-V

v7-alpha2

(luisr) #1

I downloaded the iso and tried to install it: Not working on hyper-v 2012 R2 2nd generation virtual machine. Someone else tried?


Try out NethServer 7 alpha2 ISO!
(Artem Fedai) #2

@cronopio
What do you mean not working on hyperv?


(luisr) #3

sorry, i just edit my post. Installation of NS 7 alpha2 on Microsoft hyper-v 2nd gen VM…


(Artem Fedai) #4

Hi @cronopio
What is wrong ? Please share more info regarding this matter.


(luisr) #5

2nd Generation Virtual Machine on hyper-v server 2012 R2, 80GB virtual disk, 1024MB RAM (Dynamic Memory option enabled), Secure Boot option: disabled

logs lines 1 to 53

logs lines 54 to 106

logs lines screen 107 to 159

logs lines screen 160 to 212

logs lines screen 213 to 265

logs lines 266 to 318

lines 319 to 371

lines 372 to 424

lines 425 to 477

more needed?


(Artem Fedai) #6

It seems some misconfig in HyperV, try to install clean Centos 6.7 then install from NS Repo.

and how about /dev/root does not exist? on Stuck3 ?

https://blogs.technet.microsoft.com/virtualization/2013/07/24/enabling-linux-support-on-windows-server-2012-r2-hyper-v/


(luisr) #7

ok, i will use the same virtual machine with 6.7 iso…you said Hyper-V missconfig…but read this https://bugs.centos.org/view.php?id=9860
i work with version 6.7 successfully on a PC. I just wanted to test the version 7.2 with the iso on a virtual machine. The update method is laborious to me because the internet connection here is of poor quality with only 512kbps, of which only a quarter of link to Internet.


(Artem Fedai) #8

try to input this option to kernel why not :slight_smile: if it is this bug it will fix it :

initcall_blacklist=clocksource_done_booting

(Giacomo Sanchietti) #9

Thanks for your effort!

I searched a bit, but I didn’t found any CentOS7 related bugs over Hyper-V, in fact is seems fully supported:

Looking to dracut error, I’m wondering if this is caused by a misconfigured root partition in the kickstart.
Can you please try to install a clean CentOS 7 using the NS iso?


(luisr) #10

i’m currently using the iso!!!


(Giacomo Sanchietti) #11

I know, but try to install a plain CentOS 7 not NS.


(luisr) #12

sorry!! ok, i’ll try


(luisr) #13

the same errors after this:


(Artem Fedai) #14

Press “e” and add this at the end of the line

initcall_blacklist=clocksource_done_booting

(luisr) #15

I tried that option. Unsuccessfully
http://comments.gmane.org/gmane.linux.centos.general/156545
http://www.spinics.net/lists/centos/msg157571.html


(Artem Fedai) #16

somth strange, please share Teamviewer credentials, i will take a look


(Giacomo Sanchietti) #17

Just another shot: can you also try with a vanilla ISO from CentOS site ( http://isoredirect.centos.org/centos/7.2.1511/isos/x86_64/ ).

If the problem still persists, this is an incompatibility regarding RHEL/CentOS 7 on some Hyper-V configurations (not NS related), otherwise it’s a bug in our ISO building process.


(luisr) #18

I can not accept TeamViewer connections… is prohibited here …Maybe someone can reproduce the problem. Someone who has installed and use hyper-v R2 20012


(luisr) #19

I’ll put it in the download queue. It may take a couple of days … due to bandwidth constraints we have.
is this enough?:
http://centos.chicago.waneq.com/7/isos/x86_64/CentOS-7-x86_64-Minimal-1511.iso


(Giacomo Sanchietti) #20

Yes, it’s the right iso. Thank you for your time :smile: