Cannot login to web interface (9090) and cluster-admin is not even available

So I got the qcow2 pre-built image for my UNRAID.

  • (Not your fault but you could still improve docs) Nobody mentioned that some KVM default to raw and you need to define it as qcow2 (for example in UNRAID, edit the VM xml).
  • It started and I logged in console with default root password, where it forced me to change password. I assume this didn’t touch admin’s password, only root (again make docs “stupid proof” by mentioning it).
  • I run nmtui to edit the network configuration (you should also say in the docs that probably “Wired Connection 1” is the adapter you need to edit). Also since it is a server maybe first login should force nmtui, as getting DHCP address is probably not best practice.
  • I rebooted the VM (also not clear what to do to apply network changes).
  • This time the login prompt mentioned I should use node.ns8.test:9090 (???)… Hardly. Would probably only work if clients used NS8 test as gateway and/or DNS? Else it doesn’t work. Of course, it also lists the ip: https://[ip I defined in nmtui]:9090.
  • So I connect to that using web. I see Rocky Linux (and not “NethServer8”… shouldn’t it say that?) login prompt… Well NO GO. It doesn’t work with user root or admin and either default (Nethesis,1234) or the forced changed root password. It says “Wrong user name or password”. Tried several times even with copy/paste.
  • http(s)://[ip I defined in nmtui]/cluster-admin does nothing (fails).

…so… What is wrong?


Thanks for testing!

Thanks for pointing out.

That’s right.

Thanks for the pointer.

Maybe we should document the command

nmtui edit "Wired connection 1"

Maybe this was the problem. To restart the network without rebooting:

systemctl restart NetworkManager

Usually you set the FQDN in the cluster-admin…

The NS8 admin page is the cluster-admin.
Cockpit (at port 9090) as part of the OS is not touched or branded (but it’s possbile to customize it)

Thank you for your reply mrmarkuz.
The main problem then, is my last bullet.
cluster-admin never worked then (accessing from IP) - from the premade image.
It is possible that something stops the “first run” and never resumes?
Maybe there should be a check script to see if everything went fine?

1 Like

Please check redis and api-server:

systemctl status api-server redis

Maybe try again without reboot after nmtui?

1 Like

Checcking the status of api-server and redis, they are both running.

You want me to start from clean image and do nmtui and then just restart network manager (not VM) and see what happens?

It’s just a guess…here the qcow2 image worked on Proxmox without issues but I didn’t reboot.

The root user seems to be a disallowed user by default in Cockpit.

Just edit /etc/cockpit/disallowed-users and comment out root to make the login work.

1 Like

But admin ALSO doesn’t login there.
I will start from a new image.
It is weird that I am the only one reporting these things (?)… I am only following the install docs.


admin is just a NS8 user, not a Cockpit user AFAIK.


So is, by default, ANY user allowed in Cockpit when NS8 first starts?

(my main issue of course remains that I never saw any “first start” script running nor have access to cluser admin - I’ll get back on that when I begin with a fresh VM image)


Any system user is allowed to access cockpit but only with restricted access if not in sudoers file.

See also Privileges and Permissions


Back to the main point.

  • http(s)://[ip I defined in nmtui]/cluster-admin does nothing (fails).

I have (exactly) the same experience as OP.
What to do next? Is there any solution or explanation or advice what to try next?
Thank you.

Unless something’s changed, you need a trailing slash: https://server_ip/cluster-admin/. Have you tried it that way?

Why would that make a difference, Dan, I am really interested.
It’s been years since I last heard it mattered.
All web servers I know are smart enough to understand if the URL ends in a file or a folder.

I can’t really speak to the “why,” but that was definitely required when I first tested NS8.

Well I can verify it doesn’t work with or without - in my case.
But if that makes a difference, it means that NS8 web server is not properly configured I would say.

1 Like

So I started from new image.
I edited network settings and enabled them without rebooting.
cluster-admin (with or without trailing slash) works this time.
I rebooted, it still works.

Only difference from first time is that in the first time the image didn’t boot 3-4 times because it was not set as qcow2 (shouldn’t be related to the issue) and that last time I edited the network settings and then rebooted (which DID make the network settings change). I never saw cluster-admin.
It seems weird that this little difference could affect the whole server.

Also I would DEFINITELY expect pre-built images to force me edit the IP or inform me of current IP at least (as I could have arranged things from DHCP side) when they first boot. It is not clear in the docs (yes it is “more or less mentioned” with “if you have network issues” etc. - but definitely needs to be cleaner) what you need to do.

Thanks for all the help.

PS. Rocky Linux cockpit, still doesn’t allow login of root by default. I find it a bit weird, but I guess that is Rocky Linux issue or policy.


2 posts were split to a new topic: Network configuration failed at first-boot

A post was merged into an existing topic: Network configuration failed at first-boot

Shoutout to whoever handles the documentation.
There is still no mention in fresh install using pre-made images, to configure the network first!

Network of the pre built image is configured with DHCP: it is cloud-init fallback method. If it fails and the host is unreachable, follow the hint from