Can’t boot after replacing hardware

NethServer Version: Latest

I have found a “newer” motherboard and CPU and I want to replace my existing Pentium D with an Athlon X2 250 (I know, but it’s more powerful) When I want to boot, it goes to emergency mode.

I tried dracut -f in rescue mode but nothing. I would like to keep the data/config files.

How can I boot the “new” hardware?

1 Like

fun because it should be out of the box, I love to swap my hd to a newer laptop and it runs smoothly :smiley:
I know that the insecure boot needs to be checked but it seems not relevant with your CPU generation :slight_smile:

Not sure if it will have relevance, but if you used raid, do the hdd’s still have the same designation?

1 Like

Unfortunately I didn’t use RAID.

No errors at boot to give us some informations

I did something similar from Acer Veriton with AMD LE1660 CPU to intel E6520 (and related mainboard), but i were totally sure that i installed NethServer with AHCI setup on first mainboard and this was the same one with the new one.
And nethserver boot up without any issue, moving the hard drive to the different mainbord. Only little tweaks for re-setup network card assignment.

If you still can access to the old mainboard and network card, you can:

  • Do a data backup of the server with the old mainboard (USB drive for simplicity), and also save one or more configuration backup
  • Shut down with the old mainboard, the install the disk on the new one (i strongly suggest to have latest bios installed and AHCI setup for SATA Drives)
  • Overwriting the disk drive installing latest version of NethServer, using the same hostname of the old installation
  • As network, assign the same interface you use for internet as green, with a correct setup of ip, network mask and gateway
  • Fully update the server via SSH or Software center
  • Without detach network connection, restore full data and configuration from your USB drive

Downtime for services is higher, but as far as i can understand, this is not a production server.
Take care of the USB drive! If anything goes wrong on setup of the new+restored server, you can still back to a working configuration.
If you have an extra drive of the same size or bigger can be deleted, consider also to use the bigger drive as the new disk for the new+restored server, or clone the old drive with clonezilla: I cloned the drive into a bigger one following this experience

Also, you can use clonezilla for create a “file image” backup of your disk, but IMVHO it’s useful only if you have a second disk for backup.

I would say in this case “fortunately I didn’t use RAID” , as @criticview pointed out it can be a hassle to setup the (soft)raid after it got messed up a bit.

As @stephdl said it would help if you could give us more info to avoid the complete workaround @pike suggested.

For starters:

  • do you have a classical BIOS or modern efi setup for your old and new motherboard ?
  • where does your boot stop / throws an error ? which error ?
  • which one? does it dorp to the dracut- or grub2-shell ?

Dracut emergency mode.

I have an old standard BIOS, far from the UEFi.

The drive start to boot by displaying the 3 lanes at the bottom of the screen but at 3/4, it dramatically slows down and after minutes, it finishes all the 3 lanes and throws me to dracut emergency mode. I checked the posts under the lines and seconds before the end, it starts throwing me warning initramfs errors or something like that.

Unfortunately, I’m not able to boot it on the previous config, so what I have done now it installed the latest ISO on a different drive on the new config and started to restore the latest backup what is created at 8 p.m. every day on my other server with NFS share. So it restored the backup but the mail is still not working. So now, it’s installing about 114 updates and I hope for the best. :smiley: