Allow Anydesk through WebFilter/Proxy

NethServer Version: 7.5.1804
Module: Web Content Filter

Firewall enviroment, Red and Green network interfaces.
Transparent proxy with SSL on Green.

2 filters configured:
Filter 1: unlimited access
Filter 2: access allowed only to whitelisted domains, plus a couple of categories from Université Toulouse BlackList (remote-control, update)

Client which rely on filter 1 cannot be accessed via AnyDesk, as was before enabling the transparent proxy.
I tried also to allow the IP Addresses associated with Anydesk that i found on the squid access.log. Hope this will help someone.
domain “” was already whitelisted
No proxy setup on the anydesk software

How can i enable webfilter/proxy to allow connection? Anyone managed this kind of issue before?

Hi @pike,
I think you have to bypass it with firewall rules.
You can also have a look here:

PS: most posts there are English.

Thanks… :slight_smile:
For this kind of proposed solutions, the hint is “bypass proxy for AnyDesk’s hosts”

Let’s see if this kind of trick works…

1 Like

And it fails…
Settings applied until now.

Perhaps you could have a look with wireshark or an other network tool if there some more addresses to exclude.

This is not what i call “best practice”, however that this option disabled
ran the river to the sea.

But that’s not a solution…

Is it possible block we sites using ip address excluded whitelisted ip addresses? If not could this be a feature?

hello fellows, good afternoon…I’m only use E2guardian with transparent proxy, MITM, all the blocks are working correctly. But i use an remote software access called anydesk and it sends me errors, when i try to deactivate the MITM, it works…

1 Like