Windows 10 join nethserver


(Carlo Minucci) #1

(sorry for my bad english)
i have a problem with windows 10 join domain server, he tell me can’t found the domain. but if i ping the name of the server it respond.
i have applied win7samba.reg patch but don’t join. there is, somewhere, a particular registry patch for windows 10?


(Bogdan Costin) #2

Please take a look and see if the DNS settings in the Win 10 client point to the Nethserver.
If not then add the primary DNS server as NS address.

Best regards
Bogdan


(Carlo Minucci) #3

dns it’s ok. it is the first thing i checked.

ping to the server it’s ok and it resolv the right ip


(Stefano) #4

Please, give us as much details as you can…
First of all, tell us which domain you’re trying to join (the name you used on Windows side)
Moreover, be aware NS is a NT4 DC


(Carlo Minucci) #5

domain name is “volta.polo3” but work with other client with windows 7 or windows xp


(Bogdan Costin) #6

Try to disable firewall in W10.
Also try to have only the DNS of NS. maybe this will help

What is the NSLOOKUP respose for that domain and hosts?
Ping is not always relevant …

BR
Bogdan


(Stefano) #7

AFAIK domain name should not contains .

please remember that windows’ domain has nothing to do with domain.tld you’re using for email/web and so on


(Bogdan Costin) #8

That’s not realy a concern we have: euro.net.intra without any problem.


(Stefano) #9

good to know… I never used such names for mine windows domains…


(Carlo Minucci) #10

my domain with . work with other client :slight_smile:


(Carlo Minucci) #11


(Bogdan Costin) #12

so it seems that windows is not getting any record for that domain.
Can you put here the settings for your dns in windows and the settings in NS ?

BR
Bogdan


(Carlo Minucci) #13



(Bogdan Costin) #14

Your gateway is .254 and your DNS is .253 ??
Which one is NS ? You have a different server in the lan that is responsable for DNS query ?

What are the DHCP settings in NS ?
NS must be your primary DNS server for your clients if you want to join the domain correctly

BR
Bogdan


(Carlo Minucci) #15

sorry
.254 is gateway, a proxy with ipfire
.253 is the ip of nethserver
dhcp is off

i know ns must be primary dns, but my real question is: why other client work properly instead windows 10 no? :slight_smile:


(Bogdan Costin) #16

then all your traffic is directed wrong.
You must configure IP fire so it will handle the ns records. for nethserver.

Your setup is not common and you must make sure that the DNS queryes are directed from the lan to the NS and then to your IPFire box.

Maybe you have other settings on the rest of the clients.

Declare the domain in IPfire, put a host record in DNS for NS server for the LAN so the query will be directed to NS.

Maybe this will work.

It’s really hard to try to guess what you have there (as settings and infrastructure) since you give little information about it.

EDIT: You could try to add a manual entry to the host file in WIN10 for the Nethserver and then reboot and see if you can join the domain

BR
Bogdan


(Carlo Minucci) #17

i assure the aswer is no. the rest of the clients has the same configuration and work properly

the dns and gateway can be different

i tried but don’t work

i found this. it talk about a registry patch for windows 10 but i haven’t. i think this is the problem.


(Stéphane de Labrusse) #18

Sme is always the keys of your issues :smile:

I confirm that the registry patch is different between w7/8 and w10


(Carlo Minucci) #19

where is the difference? :smile:


(Stefano) #20

don’t ask so, you don’t really want to know :wink: