Webfilter stops working

ERROR: A FATAL ERROR OCCURRED: ALL REQUESTS ARE ANSWERED WITH “OK” (see previous lines with “FATAL ERROR” for more information) *****

Hi, i am getting this error and my web filtering gets stop working and all URL gets opened for all users. Then i need to either update and download again all urls from shalla or othr sites or need to restore the backup then it works fine.

Hi @sonihiren15,
welcome to the community. Can you give us some more information about your system?

  • Which version of nethserver do you use
  • Is it up to date
  • squid and webfilter installed
  • from which logfile is the error

Could you also post mor lines of the log.


Hi thank you for your reply, here is the details
NethServer release 7.8.2003
Ya its up to date and had also installed squid and web filter and also configured my own custom url to allowed & block.
The log i send was from web proxy & filter -> logs -> ufdbguardd.log
Note : earlier it was working fine the url was getting blocked and allowed as per configuration but later when i tried to add one url to allowed (In category) and clicked configured -> save and download to apply the url, the whole filter got disabled and all url got open

Thanks for your informations, have you looked at the previous lines?
Also you could have a look at messages.log for the time the problem happens.

Ya i have looked at both, it was showing this fatal error which i have posted. neth-bug

This was the error i got

Could you please post


before and after trying to add the url.

For better reading set in an

config file


1 Like

Hi, after applying the url my “filter” was simply reloading and was not able to take access, and when i checked the database from terminal it was not showing any file related to ufdbguard then later on after restoring from backup i got ufdbguard.config file.

May i know how to check mysql database details for ufdbguard tabels ?

Which versions of nethserver-squidguard and ufdbGuard are installed? It was updated recently, see Ufdbguard conflicts between attempted installs of nethserver-squidguard

[root@server ~]# rpm -q nethserver-squidguard ufdbGuard

Please check the log for more error information:

cat /var/log/ufdbguard/ufdbguardd.log | grep -i "fatal error"

ufdbguard does not use mysql AFAIK.

1 Like

Using latest version of nethserver-squidguard and ufdbGuard but i think our ufdbgaurd database and tables got crash as i didn’t find any data related to ufdbGuard.

Here are some commands to troubleshoot ufdbguard but I think there’s an error preventing ufdbguard from starting.

ufdbguard does not use a db like mysql but let’s check the squidguard config and the contentfilter db:

config show squidguard
db contentfilter show

1 Like

OK its working now, the problem was “zimbra.com” match with may of the categories but on shalla website it was showing in single category “forum” so finally for that i need to specially add this url in my own custom category list. Thanks for your support.



Could you mark it as solved please?

3 posts were split to a new topic: Proxy blacklist doesn’t work