Ufdbguard conflicts between attempted installs of nethserver-squidguard

** NethServer 7.8.2003:**
Web Filter:

I cant install web filter. I receive this:

{
“status”: “failed”,
“message”: “[YumTestTransactionError] Test Transaction Errors: file /var/log/ufdbguard conflicts between attempted installs of nethserver-squidguard-1.9.2-1.ns7.noarch and ufdbGuard-1.34.5-2.el7.x86_64\n”,
“steps”: -1,
“event”: null
}

1 Like

Confirmed. Thanks, you found a bug. Update of ufdbguard is not working too.

Transaction check error: file /var/log/ufdbguard from install of ufdbGuard-1.34.5-2.el7.x86_64 conflicts with file from package nethserver-squidguard-1.9.2-1.ns7.noarch

I think ufdbguard uses it’s own logfile now and it conflicts with the dir /var/log/ufdbguard but my dev machine has some problems, I need to fix that first but I don’t have time now.

Indeed this is a bug: the package has been added to EPEL, it wasn’t present before.

We use packages from: https://www.urlfilterdb.com/downloads/packages.html
I do not know if we can switch to EPEL package, we should make some tests.
In the meanwhile, if you want to workaround the problem, you could try this:

yum install https://www.urlfilterdb.com/files/downloads/ufdbGuard-1.34.5-CentOS7.x86_64.rpm nethserver-squidguard
2 Likes

I had the time to test it, but sadly the workaround doesn’t work because EPEL package takes precedence.
So we need further investigation.

Edit: issue opened https://github.com/NethServer/dev/issues/6243

1 Like

JFI

same error on Yum update

Installing:
kernel x86_64 3.10.0-1127.18.2.el7 ce-updates 50 M
Updating:
grub2 x86_64 1:2.02-0.86.el7.centos ce-updates 32 k
grub2-common noarch 1:2.02-0.86.el7.centos ce-updates 729 k
grub2-pc x86_64 1:2.02-0.86.el7.centos ce-updates 32 k
grub2-pc-modules noarch 1:2.02-0.86.el7.centos ce-updates 850 k
grub2-tools x86_64 1:2.02-0.86.el7.centos ce-updates 1.8 M
grub2-tools-extra x86_64 1:2.02-0.86.el7.centos ce-updates 1.0 M
grub2-tools-minimal x86_64 1:2.02-0.86.el7.centos ce-updates 174 k
kernel-tools x86_64 3.10.0-1127.18.2.el7 ce-updates 8.1 M
kernel-tools-libs x86_64 3.10.0-1127.18.2.el7 ce-updates 8.0 M
python-perf x86_64 3.10.0-1127.18.2.el7 ce-updates 8.1 M
ufdbGuard x86_64 1.34.5-2.el7 epel 516 k
Removing:
kernel x86_64 3.10.0-1062.9.1.el7 @ce-updates 64 M

Transaction Summary

Transaction Summary

Install 1 Package
Upgrade 11 Packages
Remove 1 Package

Total size: 79 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test

Transaction check error:
file /var/log/ufdbguard from install of ufdbGuard-1.34.5-2.el7.x86_64 conflicts with file from package nethserver-squidguard-1.9.2-1.ns7.noarch

Error Summary

OK, so we have a bug…it happens :slight_smile:
I tried the workaround, to no avail.
What is the process now and how do we fix our servers? Is it just a case of wait till a new upgrade is made and try again, or will there be an announcement? Sorry for my lack of experience, never had to deal with a bug like this before…all info gratefully recieved!

Jim

Muchas gracias smile:

Any workaround?

Just exclude ufdbguard from the updates

2 Likes

Thanks, could you explainme how do it please? :sweat_smile:

I just hit the same bug on a test-vm.

with yum update --exclude=ufdbguard it works.

4 Likes

Perfect! i’t works!

Finally I applied both solutions.

First,

yum update --exclude=ufdbguard

Then I applied the command:

yum install https://www.urlfilterdb.com/files/downloads/ufdbGuard-1.34.5-CentOS7.x86_64.rpm nethserver-squidguard

and now I can install the Web Filter package.

Thanks a lot…

hello all !!

Everyone can help me ?

[root@NethServer ~]# echo ‘{“action”:“update”,“packages”:[]}’ | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq
{
“state”: “running”,
“steps”: -1,
“event”: “Initialization”
}
{
“state”: “running”,
“steps”: -1,
“event”: “Resolving RPM dependencies”
}
{
“state”: “running”,
“steps”: -1,
“event”: “Downloading Packages”
}
{
“state”: “running”,
“steps”: -1,
“event”: “Check Package Signatures”
}
{
“state”: “running”,
“steps”: -1,
“event”: “Running Test Transaction”
}
{
“status”: “failed”,
“message”: “[YumTestTransactionError] Test Transaction Errors: file /var/log/ufdbguard from install of ufdbGuard-1.34.5-2.el7.x86_64 conflicts with file from package nethserver-squidguard-1.9.2-1.ns7.noarch\n”,
“steps”: -1,
“event”: null
}
{
“id”: “1596785631”,
“type”: “EventFailed”,
“message”: “See /var/log/messages”
}
[root@NethServer ~]#

file ufdbguardd.log is empty :frowning:

merci Jesus_Chavez_Bastias

EPEL has a new ufdbGuard package ready to be tested.
I did test it, but I’d like some more independent tests.

The following command installs both the NethServer package and the EPEL package (on a clean machine):

yum --enablerepo=epel-testing,nethserver-testing install nethserver-squidguard

Substitute install with update to test a machine where the URL filter is already installed.

Pay attention to ufdbGuard version: it should be 1.34.6-2.el7 (some EPEL mirrors are still serving 1.34.6-1.el7).
nethserver-squidguard version is 1.9.2-1.7.g186a20a.ns7.

Thank you.

4 Likes

Tested on a clean test-vm. Works perfectly.

Tested on an older test-vm with already installed packages. Works also perfectly.

Thank you for your great work Fillipo!! :+1: :smiley:

1 Like

Seems to have done the charm.

Thanks.

1 Like

For me doesn’t work, after update with:

yum --enablerepo=epel-testing,nethserver-testing update nethserver-squidguard

in the services appear stopped ufdb process, and when I try to restart show these error:

2020-08-12 13:12:28 [3520] The directory ‘/var/run/ufdbguard’ where the pid file is stored, does not exist. creating it.
2020-08-12 13:12:28 [3520] ERROR: Cannot create directory /var/run/ufdbguard: Permission denied
2020-08-12 13:12:28 [3520] ERROR: make sure that /var/run/ufdbguard exists and has the correct permissions
2020-08-12 13:12:28 [3520]
2020-08-12 13:12:28 [3520] FATAL ERROR: cannot write my PID to the pidfile (see previous lines) *****

Now appear running in services, but filtering is not working