Web Proxy stops functioning


(Jason Hurd) #1

Hello All

I’m having an issue with the web proxy functionality. It seems more often than not when I get back into work in the morning it is no longer working, as in, can not navigate to any webpages.

I’m fairly new to NethServer and just testing things out at the moment. It is a fresh install with only backup and web proxy installed as extras. I am running in a virtual machine with only red (eth0) and green (eth1) networks setup.

I have tried to disable the proxy and re-enable but that doesn’t fix the issue, I have to reboot NethServer. Both interfaces are displaying OK in the dashboard. I’ve had a look around the log files but am a bit unfamiliar with them so I didn’t see anything that would lead me in the right direction.

Any information would be greatly appreciated.

Thanks,

Jason

EDIT I’m running the proxy in Transparent Mode, Cache Enabled…


(Filippo Carletti) #2

Do you see an explicit error or a generic timeout?
Please, also have a look at squid/cache.log in the log viewer.


(Jason Hurd) #3

Thank you for your reply

I believe the error is your standard page not found message but I will confirm that the next time it stops working.

Nothing out of the ordinary with the cache.log. No messages from the time I started the server yesterday to when I restarted it this morning.


(Jason Hurd) #4

This has not been an issue since I made the post, oddly enough but not surprised. Maybe it was ISP related as we had issues with it a couple days after that have been resolved.


(Mansoor) #5

Hi,

I’m facing the same issue. The server has to be restarted every day when I come in to the office. The squid cache log file shows nothing since I restarted yesterday, till today.

Basically from the client machine, the “green IP” or “WAN” ip stops responding, but it is pingable from the server itself. Any advice on where to look for a cause for this?


(Gabriel GHEORGHIU) #6

Hi,

I had the same issue but not with NS.
The ping has worked from LAN (GREEN), from UTM I had access to internet but not from LAN.
I observed that if I unplugged the LAN cable from UTM and then plugged in again after a few seconds or I restarted the UTM, everything was ok.
Finally, I replaced the NIC. Since then, I don’t have any issue.
Also, may be an issue with the patch from LAN switch / patch panel to NS.


(Mansoor) #7

Hi,

Thanks for your input. However, I think this isn’t an NIC or patch-cord issue in my case. My NS is hosted on a VMware ESXI server, with other production machines on it as well. Nothing else loses connectivity except NS.


(Jose "Martin" Abeleira. AKA Marto) #8

Can you paste the logs so we can look at them?

Este correo electrónico se ha enviado desde un equipo libre de virus y
protegido por Avast.
www.avast.com
https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail
<#DDB4FAA8-2DD7-40BB-A1B8-4E2AA1F9FDF2>